gcc-patches
Thread
Date
Earlier messages
Later messages
Messages by Thread
[PATCH v2 1/3] vect: Make non-SLP paths unreachable in strided slp/elementwise.
Robin Dapp
[PATCH v2 2/3] vect: Remove non-SLP paths in strided slp/elementwise.
Robin Dapp
Re: [PATCH v2 2/3] vect: Remove non-SLP paths in strided slp/elementwise.
Richard Biener
[PATCH v2 3/3] vect: Use strided loads for VMAT_STRIDED_SLP.
Robin Dapp
[committed] libstdc++: Fix some names.cc test failures on AIX
Jonathan Wakely
[COMMITTED PATCH v4 0/3] asf: Fix ICE on emit_move_insn [PR119884]
Konstantinos Eleftheriou
[COMMITTED PATCH v4 1/3] sbitmap: Rename bitmap_bit_in_range_p to bitmap_any_bit_in_range_p
Konstantinos Eleftheriou
[COMMITTED PATCH v4 3/3] asf: Fix calling of emit_move_insn on registers of different modes [PR119884]
Konstantinos Eleftheriou
[COMMITTED PATCH v4 2/3] sbitmap: Add bitmap_all_bits_in_range_p function
Konstantinos Eleftheriou
Re: [PATCH,LRA] Do inheritance transformations for any optimization [PR118591]
Georg-Johann Lay
[PATCH] testsuite: Add tls_link effective target
Christophe Lyon
Re: [PATCH v15] ada: fix timeval timespec on 32 bits archs with 64 bits time_t [PR114065]
Marc Poulhiès
[PATCH] tree-optimization/117965 - phiprop validity checking is too strict
Richard Biener
[PATCH] testsuite: arm: remove arm32 check from a few effective-targets
Christophe Lyon
[committed] libstdc++: Regenerate include/Makefile.in
Jonathan Wakely
[committed] libstdc++: Fix test failures for 32-bit AIX
Jonathan Wakely
Re: [committed] libstdc++: Fix test failures for 32-bit AIX
Tomasz Kaminski
Re: [committed] libstdc++: Fix test failures for 32-bit AIX
Jonathan Wakely
[PATCH] libstdc++: Implement C++26 std::polymorphic [PR119152]
Tomasz Kamiński
[committed] doc: Fix typo in description of nonstring attribute
Jonathan Wakely
[avr,patch,applied] PR120442: Support fdiml in avr/libf7
Georg-Johann Lay
[PATCH] RISC-V:Add the MIPS P8700 conditional move extension instruction support.
Umesh Kalappa
Re: [PATCH] RISC-V:Add the MIPS P8700 conditional move extension instruction support.
Umesh Kalappa
[PATCH] RISC-V:Add the MIPS P8700 conditional move extension instruction support.
Umesh Kalappa
[PATCH] RISC-V: Add Shlcofideleg extension.
Jiawei
[PATCH] RISC-V: Avoid division by zero in check_builtin_call [PR120436].
Robin Dapp
Re: [PATCH] RISC-V: Avoid division by zero in check_builtin_call [PR120436].
钟居哲
[avr,patch,applied] PR120441: Limit f7_exp's expo to 1024 (not to 512).
Georg-Johann Lay
[PATCH v1 0/1] Add error message to cmp_* and in_range.
Luc Grosheintz
[PATCH v1 1/1] libstdc++: Improve diagnostic message for `cmp_*` and `in_range`.
Luc Grosheintz
Re: [PATCH v1 0/1] Add error message to cmp_* and in_range.
Jonathan Wakely
Re: [PATCH v1 0/1] Add error message to cmp_* and in_range.
Luc Grosheintz
[PATCH 1/2] forwprop: Change test in loop of optimize_memcpy_to_memset
Andrew Pinski
[PATCH 2/2] forwprop: Add stats for memcpy->memset
Andrew Pinski
Re: [PATCH 2/2] forwprop: Add stats for memcpy->memset
Richard Biener
Re: [PATCH 1/2] forwprop: Change test in loop of optimize_memcpy_to_memset
Richard Biener
Re: [PATCH v2] c++: Unwrap type traits defined in terms of builtins within diagnostics [PR117294]
Nathaniel Shead
Re: [PATCH v2] c++: Unwrap type traits defined in terms of builtins within diagnostics [PR117294]
Patrick Palka
[PATCH v1 0/3] Refine the avg_floor with fixed point vaadd
pan2 . li
[PATCH v1 2/3] RISC-V: Reconcile the existing test for avg_floor
pan2 . li
[PATCH v1 3/3] RISC-V: Add test cases for avg_floor vaadd implementation
pan2 . li
[PATCH v1 1/3] RISC-V: Leverage vaadd.vv for signed standard name avg_floor
pan2 . li
Re: [PATCH v1 1/3] RISC-V: Leverage vaadd.vv for signed standard name avg_floor
Robin Dapp
Re: [PATCH v1 1/3] RISC-V: Leverage vaadd.vv for signed standard name avg_floor
Jeff Law
RE: [PATCH v1 1/3] RISC-V: Leverage vaadd.vv for signed standard name avg_floor
Li, Pan2
[committed] c-c++-common/gomp/{attrs-,}metadirective-3.c: Fix expected result [PR118694]
Tobias Burnus
[PATCH v1] rs6000: Restore opaque overload variant for correct diagnostics
Kishan Parmar
[PATCH] arm: always enable both simd and mve builtins
Christophe Lyon
Re: [PATCH] arm: always enable both simd and mve builtins
Christophe Lyon
[committed] libstdc++: Run in_place constructor test for std::indirect [PR119152]
Tomasz Kamiński
[PATCH] arm_neon.h: remove useless push/pop pragmas
Christophe Lyon
Re: [PATCH] arm_neon.h: remove useless push/pop pragmas
Christophe Lyon
[PATCH] testsuite: arm: add needed -mcpu / -march to arm_crypto_ok
Christophe Lyon
[PATCH] testsuite, arm: factorize arm_v8_neon_ok flags
Christophe Lyon
[PATCH] testsuite: Restore dg-do run on pr116906 and pr78185 tests
Christophe Lyon
Re: [PATCH] testsuite: Restore dg-do run on pr116906 and pr78185 tests
Christophe Lyon
[PATCH RFA] fold: DECL_VALUE_EXPR isn't simple [PR120400]
Jason Merrill
Re: [PATCH RFA] fold: DECL_VALUE_EXPR isn't simple [PR120400]
Iain Sandoe
Re: [PATCH RFA] fold: DECL_VALUE_EXPR isn't simple [PR120400]
Richard Biener
[PATCH v4 0/8] Implement layouts from mdspan.
Luc Grosheintz
[PATCH v4 4/8] libstdc++: Implement layout_right from mdspan.
Luc Grosheintz
Re: [PATCH v4 4/8] libstdc++: Implement layout_right from mdspan.
Tomasz Kaminski
Re: [PATCH v4 4/8] libstdc++: Implement layout_right from mdspan.
Luc Grosheintz
[PATCH v4 2/8] libstdc++: Implement layout_left from mdspan.
Luc Grosheintz
Re: [PATCH v4 2/8] libstdc++: Implement layout_left from mdspan.
Tomasz Kaminski
Re: [PATCH v4 2/8] libstdc++: Implement layout_left from mdspan.
Luc Grosheintz
Re: [PATCH v4 2/8] libstdc++: Implement layout_left from mdspan.
Tomasz Kaminski
Re: [PATCH v4 2/8] libstdc++: Implement layout_left from mdspan.
Tomasz Kaminski
[PATCH v4 1/8] libstdc++: Improve naming and whitespace for extents.
Luc Grosheintz
Re: [PATCH v4 1/8] libstdc++: Improve naming and whitespace for extents.
Tomasz Kaminski
[PATCH v4 6/8] libstdc++: Implement layout_stride from mdspan.
Luc Grosheintz
Re: [PATCH v4 6/8] libstdc++: Implement layout_stride from mdspan.
Tomasz Kaminski
Re: [PATCH v4 6/8] libstdc++: Implement layout_stride from mdspan.
Tomasz Kaminski
[PATCH v4 5/8] libstdc++: Add tests for layout_right.
Luc Grosheintz
Re: [PATCH v4 5/8] libstdc++: Add tests for layout_right.
Tomasz Kaminski
[PATCH v4 3/8] libstdc++: Add tests for layout_left.
Luc Grosheintz
[PATCH v4 7/8] libstdc++: Add tests for layout_stride.
Luc Grosheintz
Re: [PATCH v4 7/8] libstdc++: Add tests for layout_stride.
Tomasz Kaminski
Re: [PATCH v4 7/8] libstdc++: Add tests for layout_stride.
Tomasz Kaminski
[PATCH v4 8/8] libstdc++: Make layout_left(layout_stride) noexcept.
Luc Grosheintz
Re: [PATCH v4 8/8] libstdc++: Make layout_left(layout_stride) noexcept.
Tomasz Kaminski
Re: [PATCH v4 8/8] libstdc++: Make layout_left(layout_stride) noexcept.
Jonathan Wakely
Re: [PATCH v4 8/8] libstdc++: Make layout_left(layout_stride) noexcept.
Jonathan Wakely
Re: [PATCH v4 0/8] Implement layouts from mdspan.
Luc Grosheintz
Re: [PATCH v4 0/8] Implement layouts from mdspan.
Tomasz Kaminski
Re: [PATCH v4 0/8] Implement layouts from mdspan.
Tomasz Kaminski
[pushed 1/2] c++: add cxx_dump_pretty_printer
Jason Merrill
[pushed 2/2] c++: add -fdump-lang-tinst
Jason Merrill
[PATCH v2] s390: Floating point vector lane handling
Juergen Christ
Re: [PATCH v2] s390: Floating point vector lane handling
Stefan Schulze Frielinghaus
Re: [PATCH] testsuite: Fix pr101145inf*.c testcases [PR117494]
Christophe Lyon
RE: [PATCH] testsuite: Fix pr101145inf*.c testcases [PR117494]
Andrew Pinski (QUIC)
Re: [PATCH] testsuite: Fix pr101145inf*.c testcases [PR117494]
Christophe Lyon
Re: [PATCH] testsuite: Fix pr101145inf*.c testcases [PR117494]
Andrew Pinski
Fwd: [PATCH] testsuite: Fix up dg-do-if
Xi Ruoyao
Re: Fwd: [PATCH] testsuite: Fix up dg-do-if
Alexandre Oliva
[PATCH] Fixup gcc.target/i386/vect-epilogues-5.c
Richard Biener
[PATCH] i386: Add more forms peephole2 for adc/sbb
Hu, Lin1
[PATCH] or1k: Support long jump offsets with -mcmodel=large
Stafford Horne
[PATCH] expmed: Prevent non-canonical subreg generation in store_bit_field [PR118873]
Konstantinos Eleftheriou
Re: [PATCH] expmed: Prevent non-canonical subreg generation in store_bit_field [PR118873]
Richard Biener
Re: [PATCH] expmed: Prevent non-canonical subreg generation in store_bit_field [PR118873]
Konstantinos Eleftheriou
[PATCH v1 0/3] RISC-V: Combine vec_duplicate + vxor.vv to vxor.vx on GR2VR cost
pan2 . li
[PATCH v1 3/3] RISC-V: Add test for vec_duplicate + vxor.vv combine case 1 with GR2VR cost 0, 1 and 2
pan2 . li
Re: [PATCH v1 0/3] RISC-V: Combine vec_duplicate + vxor.vv to vxor.vx on GR2VR cost
Robin Dapp
[PATCH v1 2/3] RISC-V: Add test for vec_duplicate + vxor.vv combine case 0 with GR2VR cost 0, 2 and 15
pan2 . li
[PATCH v1 1/3] RISC-V: Combine vec_duplicate + vxor.vv to vxor.vx on GR2VR cost
pan2 . li
[pushed] c++: dump_template_bindings tweak
Jason Merrill
[PATCH] [lra] force reg update after spilling to memory [PR120424]
Alexandre Oliva
Re: [PATCH] [lra] force reg update after spilling to memory [PR120424]
Vladimir Makarov
[PATCH] x86: Enable *mov<mode>_and only for -Oz
H.J. Lu
[PATCH] x86: Enable *mov<mode>_(and|or) only for -Oz
H.J. Lu
PATCH v2] x86: Enable *mov<mode>_(and|or_store) only for -Oz
H.J. Lu
[PATCH v3] x86: Enable *mov<mode>_(and|or) only for -Oz
H.J. Lu
[to-be-committed][RISC-V] Add andi+bclr synthesis
Jeff Law
[PATCH] rs6000: Remove include of reload.h
Segher Boessenkool
[Ada] Install ACATS 4.2 testsuite in acats-4 directory
Eric Botcazou
[Ada] Install ACATS 3.1 testsuite in acats-3 directory
Eric Botcazou
[to-be-committed][RISC-V] shift+and+shift for logical and synthesis
Jeff Law
[PATCH v1] libstdc++: Fix bug in default ctor of extents.
Luc Grosheintz
Re: [PATCH v1] libstdc++: Fix bug in default ctor of extents.
Tomasz Kaminski
Re: [PATCH v1] libstdc++: Fix bug in default ctor of extents.
Jonathan Wakely
Re: [PATCH v1] libstdc++: Fix bug in default ctor of extents.
Tomasz Kaminski
[Ada] Move ACATS 2.6 testsuite to acats-2 directory
Eric Botcazou
[PATCH] Improve copy prop for aggregates and combine with zeroing case
Andrew Pinski
Re: [PATCH] Improve copy prop for aggregates and combine with zeroing case
Andrew Pinski
[PATCH] c++/modules: Support re-streaming TU_LOCAL_ENTITYs [PR120412]
Nathaniel Shead
Re: [PATCH] c++/modules: Support re-streaming TU_LOCAL_ENTITYs [PR120412]
Patrick Palka
Re: [PATCH RFA (diagnostic)] c++: modules and #pragma diagnostic
Jason Merrill
Re: [PATCH RFA (diagnostic)] c++: modules and #pragma diagnostic
David Malcolm
Re: [PATCH RFA (diagnostic)] c++: modules and #pragma diagnostic
Jason Merrill
Re: [PATCH RFA (diagnostic)] c++: modules and #pragma diagnostic
Jason Merrill
Re: [PATCH RFA (diagnostic)] c++: modules and #pragma diagnostic
Jason Merrill
Re: [PATCH RFA (diagnostic)] c++: modules and #pragma diagnostic
Patrick Palka
Re: [PATCH RFA (diagnostic)] c++: modules and #pragma diagnostic
Patrick Palka
Re: [PATCH RFA (diagnostic)] c++: modules and #pragma diagnostic
David Malcolm
[pushed] c++: drop push_tinst_level in mangling
Jason Merrill
[PATCH] doc: Correct the return type of float comparison
Trevor Gross
Re: [PATCH] doc: Correct the return type of float comparison
Joseph Myers
Re: [PATCH] doc: Correct the return type of float comparison
Trevor Gross
[PATCH] libstdc++: Add smart ptr owner_equals and owner_hash structs and members for P1901R2
Paul Keir
Re: [PATCH] libstdc++: Add smart ptr owner_equals and owner_hash structs and members for P1901R2
Jonathan Wakely
Re: [PATCH] libstdc++: Add smart ptr owner_equals and owner_hash structs and members for P1901R2
Paul Keir
[committed] libstdc++: Add always_inline to std::is_constant_evaluated()
Jonathan Wakely
[PATCH] libstdc++: Replace some uses of std::__addressof with std::addressof
Jonathan Wakely
Re: [PATCH] libstdc++: Replace some uses of std::__addressof with std::addressof
Tomasz Kaminski
Re: [PATCH] libstdc++: Replace some uses of std::__addressof with std::addressof
Jonathan Wakely
[PATCH] libstdc++: Support std::abs for 128-bit integers and floats [PR96710]
Jonathan Wakely
Re: [PATCH] libstdc++: Support std::abs for 128-bit integers and floats [PR96710]
Tomasz Kaminski
[committed] libstdc++: Fix 17_intro/names.cc failure on Solaris 11.3
Jonathan Wakely
[PATCH] Fix makeinfo error from recently-added nodes missing in menu
Hans-Peter Nilsson
Re: [PATCH] Fix makeinfo error from recently-added nodes missing in menu
Richard Biener
[PATCH] c++/modules: Fix stream-in of member using-decls [PR120414]
Nathaniel Shead
Re: [PATCH] c++/modules: Fix stream-in of member using-decls [PR120414]
Jason Merrill
Re: [PATCH 2/2] VR-VALUES: Rewrite test_for_singularity using range_op_handler
Andrew MacLeod
Re: [PATCH 2/2] VR-VALUES: Rewrite test_for_singularity using range_op_handler
Jeff Law
[PATCH] Verify 'GIMPLE_RETURN' vs. 'RESULT_DECL' if 'aggregate_value_p' [PR119835]
Thomas Schwinge
Re: [PATCH] Verify 'GIMPLE_RETURN' vs. 'RESULT_DECL' if 'aggregate_value_p' [PR119835]
Richard Biener
Disable 'pass_nrv' for offloading compilation [PR119835] (was: [PATCH] Verify 'GIMPLE_RETURN' vs. 'RESULT_DECL' if 'aggregate_value_p' [PR119835])
Thomas Schwinge
Re: Disable 'pass_nrv' for offloading compilation [PR119835] (was: [PATCH] Verify 'GIMPLE_RETURN' vs. 'RESULT_DECL' if 'aggregate_value_p' [PR119835])
Richard Biener
Defuse 'RESULT_DECL' check in 'pass_nrv' for offloading compilation [PR119835] (was: Disable 'pass_nrv' for offloading compilation [PR119835])
Thomas Schwinge
Re: Defuse 'RESULT_DECL' check in 'pass_nrv' for offloading compilation [PR119835] (was: Disable 'pass_nrv' for offloading compilation [PR119835])
Richard Biener
[PATCH v2] ext-dce: Don't refine live width with SUBREG mode if !TRULY_NOOP_TRUNCATION_MODES_P [PR 120050]
Xi Ruoyao
Re: [PATCH v2] ext-dce: Don't refine live width with SUBREG mode if !TRULY_NOOP_TRUNCATION_MODES_P [PR 120050]
Richard Sandiford
[COMMITTED] MAINTAINERS: Add myself to write after approval
Kishan Parmar
[PATCH 1/2] allow contraction to synthetic single-element vector FMA
Alexander Monakov
[PATCH 2/2] c-family: switch away from -ffp-contract=fast
Alexander Monakov
Re: [PATCH 1/2] allow contraction to synthetic single-element vector FMA
Richard Biener
Re: [PATCH 1/2] allow contraction to synthetic single-element vector FMA
Alexander Monakov
GCC 14.3.1 Status Report (2025-05-23)
Richard Biener
[wwwdocs] Add notes about C++20 iterator concepts and std::vector
Jonathan Wakely
[PATCH] Add anchor to new link to GCC 15 notes
Jonathan Wakely
[PATCH] Conditionalize libgdiagnostic processing on presence
Richard Biener
Re: [PATCH] Conditionalize libgdiagnostic processing on presence
Jakub Jelinek
Re: [PATCH] Conditionalize libgdiagnostic processing on presence
Richard Biener
Re: [PATCH] Conditionalize libgdiagnostic processing on presence
Jakub Jelinek
Re: [PATCH 1/3] LoongArch: testsuite: Fix pr112325.c and pr117888-1.c.
Xi Ruoyao
Re: [PATCH 1/3] LoongArch: testsuite: Fix pr112325.c and pr117888-1.c.
Lulu Cheng
[committed] libgomp.c-c++-common/metadirective-1.c: Expect 'error:' for nvptx compile [PR118694]
Tobias Burnus
[Patch] OpenMP/C++: Avoid ICE for BIND_EXPR with empty BIND_EXPR_BLOCK [PR120413]
Tobias Burnus
Re: [Patch] OpenMP/C++: Avoid ICE for BIND_EXPR with empty BIND_EXPR_BLOCK [PR120413]
Jakub Jelinek
Re: [Patch] OpenMP/C++: Avoid ICE for BIND_EXPR with empty BIND_EXPR_BLOCK [PR120413]
Tobias Burnus
[PATCH v1 0/3] RISC-V: Combine vec_duplicate + vor.vv to vor.vx on GR2VR cost
pan2 . li
[PATCH v1 2/3] RISC-V: Add test for vec_duplicate + vor.vv combine case 0 with GR2VR cost 0, 2 and 15
pan2 . li
[PATCH v1 1/3] RISC-V: Combine vec_duplicate + vor.vv to vor.vx on GR2VR cost
pan2 . li
[PATCH v1 3/3] RISC-V: Add test for vec_duplicate + vor.vv combine case 1 with GR2VR cost 0, 1 and 2
pan2 . li
Re: [PATCH v1 0/3] RISC-V: Combine vec_duplicate + vor.vv to vor.vx on GR2VR cost
Robin Dapp
[PATCH v2] x86: Add preserve_none and update no_caller_saved_registers attributes
H.J. Lu
[PATCH][GCC16][GCC15] aarch64: Add support for FUJITSU-MONAKA (-mcpu=fujitsu-monaka) CPU
Yuta Mukai (Fujitsu)
Re: [PATCH][GCC16][GCC15] aarch64: Add support for FUJITSU-MONAKA (-mcpu=fujitsu-monaka) CPU
Kyrylo Tkachov
Re: [PATCH][GCC16][GCC15] aarch64: Add support for FUJITSU-MONAKA (-mcpu=fujitsu-monaka) CPU
Kyrylo Tkachov
[PATCH] [MAINTAINERS] Add myself to write after approval and DCO.
dhruvc
[committed] c: Document C23 implementation-defined behavior
Joseph Myers
Re: [committed] c: Document C23 implementation-defined behavior
Rainer Orth
[PATCH RFC] diagnostics: use -Wformat-diag more consistently
Jason Merrill
Re: [PATCH RFC] diagnostics: use -Wformat-diag more consistently
David Malcolm
[testsuite] Remove obsolete ada/acats/overflow.lst file
Eric Botcazou
[pushed] c++: constexpr always_inline [PR120935]
Jason Merrill
[FYI] [vxworks] build partial libatomic
Alexandre Oliva
RISC-V TLS Descriptors in GCC
Dongsheng Song
Earlier messages
Later messages