Allon Mureinik has posted comments on this change. Change subject: core: Support undoing diskless previews ......................................................................
Patch Set 4: (4 inline comments) .................................................... File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RestoreAllSnapshotsCommand.java Line 86: boolean hasAsyncTasks = false; It's more readable. If explicitly specifying false save someone a second reading it but costs 5 opcodes in the JVM - it's a worthwhile tradeoff. Especially since the rest of the function is packed with DB access :-) Line 87: if (getImagesList().size() > 0) { Agreed. Line 91: getVmId(), targetSnapshot, removedSnapshotId); It's redundent - it's not used outside this scope, so holding a reference (to a temp object!) not only delays GC (which is peanuts), but also allows for confusiion (which is a big no-no, IMHO) Line 92: VdcReturnValueBase returnValue = runAsyncTask(VdcActionType.RestoreFromSnapshot, params); Done -- To view, visit http://gerrit.ovirt.org/6676 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: Ic62eee3cfb03abd21905ad6aa132c8cc10dbfb70 Gerrit-PatchSet: 4 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Ayal Baron <aba...@redhat.com> Gerrit-Reviewer: Daniel Erez <de...@redhat.com> Gerrit-Reviewer: Liron Aravot <lara...@redhat.com> Gerrit-Reviewer: Maor Lipchuk <mlipc...@redhat.com> _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches