On Mon, Apr 29, 2013 at 02:31:40PM +0400, Maksim Kuznetsov wrote: > Jakub, Richard, thank you for your feedback! > > > I wonder if it %{ and %} shouldn't be better handled in final.c > > for all #ifdef ASSEMBLER_DIALECT targets, rather than just for one specific. > > I moved %{ and %} cases to output_asm_insn in final.c > > > Also: > > *(p + 1) > > should be better written as p[1] (more readable). > > Fixed. > > I also documented new escapes. > Could you please have a look?
ChangeLog entry is missing. Also, why are you handling just %{ and %}, and not also %| ? I mean, if you want to print say {|} into assembly for both dialects, don't you need: asm ("{dialect1%{%|%}|%{%|%}dialect2}"); or similar? If you use just | instead of %|, it would be handled as separator of the dialects. Otherwise it looks good to me. Jakub