Ayal Baron has posted comments on this change. Change subject: core: prevent simultaneous reconstructs on the same pool(#845838) ......................................................................
Patch Set 12: (1 inline comment) .................................................... File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/storage/ReconstructMasterDomainCommand.java Line 82: } Line 83: return toReturn; Line 84: } Line 85: Line 86: protected boolean performChecks(){ please rename to something that actually explains what checks are being performed Line 87: List<storage_pool_iso_map> poolDomains = DbFacade.getInstance() Line 88: .getStoragePoolIsoMapDao().getAllForStoragePool(getStoragePool().getId()); Line 89: for (storage_pool_iso_map poolDomain : poolDomains) { Line 90: if (poolDomain.getstatus() == StorageDomainStatus.Locked) { -- To view, visit http://gerrit.ovirt.org/7982 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: Ia0dfb227b014af602e5bd1ab952d7c543992aa0f Gerrit-PatchSet: 12 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Liron Aravot <lara...@redhat.com> Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Ayal Baron <aba...@redhat.com> Gerrit-Reviewer: Daniel Paikov <pai...@gmail.com> Gerrit-Reviewer: Liron Aravot <lara...@redhat.com> Gerrit-Reviewer: Maor Lipchuk <mlipc...@redhat.com> Gerrit-Reviewer: Michael Kublin <mkub...@redhat.com> Gerrit-Reviewer: Vered Volansky <vvola...@redhat.com> _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches