Allon Mureinik has posted comments on this change. Change subject: core: Added GetManagementInterfaceAddressByVdsId query ......................................................................
Patch Set 1: (2 inline comments) .................................................... File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/GetManagementInterfaceAddressByVdsIdQuery.java Line 6: public class GetManagementInterfaceAddressByVdsIdQuery<P extends GetManagementInterfaceAddressByVdsIdParameters> extends QueriesCommandBase<P> { I disagree with most of this comment. Re the class' name: Java/backend conventions are to use whole works. Also, as part of the "wonderful" querying mechanism, the name must end with "Query", at least for now. (See Backend.runQuery). Regarding the parameter class - this is another [ugly] convention, that should probably be cleaned up across the board, in a concentrated effort. Specifically for this one, VdsIdParametersBase could be used instead of creating a new class. .................................................... File backend/manager/modules/dal/src/main/java/org/ovirt/engine/core/dao/InterfaceDAODbFacadeImpl.java Line 139: .addValue("vds_id", id).addValue("user_id", userID).addValue("is_filtered", isFiltered); it's a matter of style, IMHO, but all the DAOs use this chained call convention. -- To view, visit http://gerrit.ovirt.org/4854 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: Ic6d855734c6cdec937de6ec91d1c80a23333eec8 Gerrit-PatchSet: 1 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Tal Nisan <tni...@redhat.com> Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Ayal Baron <aba...@redhat.com> _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches