[ 
http://jira.codehaus.org/browse/SUREFIRE-696?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=255058#action_255058
 ] 

Kristian Rosenvold commented on SUREFIRE-696:
---------------------------------------------

LinkedHashSet is a jdk1.4 class and the booter is actually (believe it or not!) 
a java 1.3 module. 

I would also prefer using a private copy-constructor in the join method to 
retain immutability.

Personally I see no point in using an interator when the code *also* has to 
maintain a counter, at least not when you can't use a linkedhashset ;)

The other changes are nice, would you mind updating the patch?

> Improve the design of the class Classpath
> -----------------------------------------
>
>                 Key: SUREFIRE-696
>                 URL: http://jira.codehaus.org/browse/SUREFIRE-696
>             Project: Maven Surefire
>          Issue Type: Improvement
>          Components: Maven Surefire Plugin
>    Affects Versions: 2.7.2
>            Reporter: Stefan Birkner
>            Priority: Minor
>         Attachments: SUREFIRE-Classpath.patch
>
>
> This patch contains some improvements for the class Classpath:
> * Only use a set for storing the elements.
> * append(Classpath) has been changed to Classpath.join(Classpath, Classpath), 
> because the classpath doesn't get appended. Instead a new one is created.
> * Renamed setForkProperties to writeToForkProperties.
> * Renamed setAsSystemProperty to writeToSystemProperty.
> * Moved getClassPathAsString() into writeToSystemProperty and only call 
> writeToSystemProperty from outside.
> * Added readFromForkProperties in order to have serialization and 
> deseralization being part of the same class.
> From my point of view these changes improve the readability of the Surefire 
> code and are another step on the way to clean code.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: 
http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to