[ http://jira.codehaus.org/browse/SUREFIRE-696?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Kristian Rosenvold updated SUREFIRE-696: ---------------------------------------- Fix Version/s: (was: 2.7.3) 2.8 > Improve the design of the class Classpath > ----------------------------------------- > > Key: SUREFIRE-696 > URL: http://jira.codehaus.org/browse/SUREFIRE-696 > Project: Maven Surefire > Issue Type: Improvement > Components: Maven Surefire Plugin > Affects Versions: 2.7.2 > Reporter: Stefan Birkner > Priority: Minor > Fix For: 2.8 > > Attachments: SUREFIRE-696.patch, SUREFIRE-Classpath.patch > > > This patch contains some improvements for the class Classpath: > * Only use a set for storing the elements. > * append(Classpath) has been changed to Classpath.join(Classpath, Classpath), > because the classpath doesn't get appended. Instead a new one is created. > * Renamed setForkProperties to writeToForkProperties. > * Renamed setAsSystemProperty to writeToSystemProperty. > * Moved getClassPathAsString() into writeToSystemProperty and only call > writeToSystemProperty from outside. > * Added readFromForkProperties in order to have serialization and > deseralization being part of the same class. > From my point of view these changes improve the readability of the Surefire > code and are another step on the way to clean code. -- This message is automatically generated by JIRA. - If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa - For more information on JIRA, see: http://www.atlassian.com/software/jira