Gilad Chaplik has posted comments on this change. Change subject: core: Quota Dependency Test + RemoveSnapshot fix ......................................................................
Patch Set 2: (1 inline comment) .................................................... File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RemoveSnapshotCommand.java Line 124: getParameters().getImagesParameters().add(p); Line 125: Line 126: if (vdcReturnValue != null && vdcReturnValue.getInternalTaskIdList() != null) { Line 127: getReturnValue().getTaskIdList().addAll(vdcReturnValue.getInternalTaskIdList()); Line 128: } rollbackQuota looks better than removeQuotaFromCache. I'd delete removeQuotaFromCache, seems like a duplicate code. Line 129: QuotaManager.getInstance().removeQuotaFromCache(getStoragePoolId().getValue(), source.getQuotaId()); Line 130: QuotaManager.getInstance().removeQuotaFromCache(getStoragePoolId().getValue(), dest.getQuotaId()); Line 131: } Line 132: setSucceeded(true); -- To view, visit http://gerrit.ovirt.org/9413 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: Ifd9e215abaa5de0fc03dae0609d9dc3ffc957f55 Gerrit-PatchSet: 2 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: ofri masad <oma...@redhat.com> Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Gilad Chaplik <gchap...@redhat.com> Gerrit-Reviewer: ofri masad <oma...@redhat.com> _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches