Ayal Baron has posted comments on this change.

Change subject: core: Support undoing diskless previews
......................................................................


Patch Set 1: I would prefer that you didn't submit this

(4 inline comments)

Without delving into the inner methods the flow still looks broken to me.

....................................................
File 
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/RestoreAllSnapshotsCommand.java
Line 92:         if (getImagesList().size() > 0) {
although it works, I would put this 'if' before the 'for' loop.

Line 99:                     return;
I don't understand why we only return in case returnValue is not null and not 
in case there are no tasks.
If we do not return at this stage then I believe endCommand should be called 
outside of 'else' clause below.

Line 107:         }
This method calls: restoreSnapshotAndRemoveObsoleteSnapshots()
above.

what's the difference between OrphanedImages and RemoveObsoleteSnapshots?

what's the difference between removeSnapshotsFromDB and removeSnapshot?

Line 108:         else {
why would we reach this point without needing to call EndVmCommand?
why would we reach this point in failing state? (i.e. not needing to 
setSucceeded(true)

--
To view, visit http://gerrit.ovirt.org/6676
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Ic62eee3cfb03abd21905ad6aa132c8cc10dbfb70
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Allon Mureinik <amure...@redhat.com>
Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com>
Gerrit-Reviewer: Ayal Baron <aba...@redhat.com>
Gerrit-Reviewer: Daniel Erez <de...@redhat.com>
Gerrit-Reviewer: Maor Lipchuk <mlipc...@redhat.com>
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to