Yair Zaslavsky has posted comments on this change.

Change subject: jsonrpc: Stomp changes in vdsbroker
......................................................................


Patch Set 14:

(5 comments)

http://gerrit.ovirt.org/#/c/26783/14/backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VdsManager.java
File 
backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/VdsManager.java:

Line 84:     private static Map<Guid, String> recoveringJobIdMap = new 
ConcurrentHashMap<Guid, String>();
Line 85:     private boolean isSetNonOperationalExecuted;
Line 86:     private MonitoringStrategy monitoringStrategy;
Line 87:     private EngineLock monitoringLock;
Line 88: 
empty line, please remove
Line 89:     public Object getLockObj() {
Line 90:         return _lockObj;
Line 91:     }
Line 92: 


Line 752: 
Line 753:     private void setStartTime() {
Line 754:         updateStartTime = System.currentTimeMillis();
Line 755:     }
Line 756: 
same
Line 757:     private void setLastUpdate() {
Line 758:         lastUpdate = System.currentTimeMillis();
Line 759:     }
Line 760: 


http://gerrit.ovirt.org/#/c/26783/14/backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/irsbroker/IrsBrokerCommand.java
File 
backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/irsbroker/IrsBrokerCommand.java:

Line 608:                         // Get the values of the timeouts:
Line 609:                         int clientTimeOut = Config.<Integer> 
getValue(ConfigValues.vdsTimeout) * 1000;
Line 610:                         int connectionTimeOut = Config.<Integer> 
getValue(ConfigValues.vdsConnectionTimeout) * 1000;
Line 611:                         int clientRetries = Config.<Integer> 
getValue(ConfigValues.vdsRetries);
Line 612:                         privatemIrsProxy = 
TransportFactory.createIrsServer(getProtocol(), host, getmIrsPort(), 
clientTimeOut, connectionTimeOut, clientRetries);
can you please change the name of the field? both private and m? :)
Line 613:                         runStoragePoolUpEvent(storagePool);
Line 614:                     }
Line 615:                 }
Line 616:             }


Line 1053:         }
Line 1054: 
Line 1055:         private void nullifyInternalProxies() {
Line 1056:             if (privatemIrsProxy != null) {
Line 1057:                 if 
(IrsServerWrapper.class.isInstance(privatemIrsProxy)) {
isn't a part of it shared with the dispose method? do u want to perhaps reuse 
the code somehow?
Line 1058:                     
XmlRpcUtils.shutDownConnection(((IrsServerWrapper) 
privatemIrsProxy).getHttpClient());
Line 1059:                 } else {
Line 1060:                     ((JsonRpcIIrsServer) privatemIrsProxy).close();
Line 1061:                 }


http://gerrit.ovirt.org/#/c/26783/14/backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/jsonrpc/FutureMap.java
File 
backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/jsonrpc/FutureMap.java:

Line 20: import org.ovirt.vdsm.jsonrpc.client.utils.LockWrapper;
Line 21: 
Line 22: /**
Line 23:  * Provides asynchronous behavior to synchronous engine code. Request 
is sent during construction of this map but it
Line 24:  * blocks waiting for response only when it is needed so you can pass 
around this map and have little or no blocking
what does little blocking mean?
Line 25:  * behavior.
Line 26:  *
Line 27:  */
Line 28: @SuppressWarnings("serial")


-- 
To view, visit http://gerrit.ovirt.org/26783
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: If78de6620ba6891543531ac8ddd633b67828a89c
Gerrit-PatchSet: 14
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Piotr Kliczewski <piotr.kliczew...@gmail.com>
Gerrit-Reviewer: Barak Azulay <bazu...@redhat.com>
Gerrit-Reviewer: Daniel Erez <de...@redhat.com>
Gerrit-Reviewer: Eli Mesika <emes...@redhat.com>
Gerrit-Reviewer: Juan Hernandez <juan.hernan...@redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourf...@redhat.com>
Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczew...@gmail.com>
Gerrit-Reviewer: Saggi Mizrahi <smizr...@redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com>
Gerrit-Reviewer: automat...@ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to