Yair Zaslavsky has posted comments on this change.

Change subject: aaa: Removal of authenticator classes
......................................................................


Patch Set 3:

(3 comments)

http://gerrit.ovirt.org/#/c/25571/3/backend/manager/modules/aaa/src/main/java/org/ovirt/engine/core/aaa/Authenticator.java
File 
backend/manager/modules/aaa/src/main/java/org/ovirt/engine/core/aaa/Authenticator.java:

Line 85:         return (String) 
context.get(ExtensionProperties.AAA_CHANGE_EXPIRED_PASSWORD_MSG);
Line 86:     }
Line 87: 
Line 88:     public boolean isNegotiationAuth() {
Line 89:         return 
context.get(ExtensionProperties.AAA_AUTHENTICATION_CAPABILITIES) != null ? 
(Extension.AAAFlags.AAA_NEGOTIATION_AUTH_FLAG & (int) 
context.get(ExtensionProperties.AAA_AUTHENTICATION_CAPABILITIES)) == 
Extension.AAAFlags.AAA_NEGOTIATION_AUTH_FLAG
> hmmm... this is wrong.
Done
Line 90:                 : false;
Line 91:     }
Line 92: 
Line 93:     public boolean isPasswordAuth() {


http://gerrit.ovirt.org/#/c/25571/3/backend/manager/modules/extensions-api-root/extensions-api/src/main/java/org/ovirt/engine/api/extensions/Extension.java
File 
backend/manager/modules/extensions-api-root/extensions-api/src/main/java/org/ovirt/engine/api/extensions/Extension.java:

Line 20:         AAA_CHANGE_EXPIRED_PASSWORD_MSG,
Line 21:         AAA_AUTHENTICATION_CAPABILITIES,
Line 22:     };
Line 23: 
Line 24:     public static class AAAFlags {
> you should decide what flags this belongs to.
Ok, then I'll rename AAAFlags to AuthCapabilitiesFlags.
I thought you want to have one set of flags for AAA.
Line 25:         public static final int AAA_PASSWORD_AUTH_FLAG = 0x00000001;
Line 26:         public static final int AAA_NEGOTIATION_AUTH_FLAG = 0x00000010;
Line 27:     }
Line 28: 


Line 22:     };
Line 23: 
Line 24:     public static class AAAFlags {
Line 25:         public static final int AAA_PASSWORD_AUTH_FLAG = 0x00000001;
Line 26:         public static final int AAA_NEGOTIATION_AUTH_FLAG = 0x00000010;
> no need AAA_ within scope.
Done
Line 27:     }
Line 28: 
Line 29:     /**
Line 30:      * Sets the context of the Extension


-- 
To view, visit http://gerrit.ovirt.org/25571
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: If3a6f8586bdb14fcc6c09c77dc1b761b795fce07
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Yair Zaslavsky <yzasl...@redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alo...@redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com>
Gerrit-Reviewer: automat...@ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to