Alon Bar-Lev has posted comments on this change.

Change subject: aaa: Removal of authenticator classes
......................................................................


Patch Set 3:

(2 comments)

http://gerrit.ovirt.org/#/c/25571/3/backend/manager/modules/extensions-api-root/extensions-api/src/main/java/org/ovirt/engine/api/extensions/Extension.java
File 
backend/manager/modules/extensions-api-root/extensions-api/src/main/java/org/ovirt/engine/api/extensions/Extension.java:

Line 20:         AAA_CHANGE_EXPIRED_PASSWORD_MSG,
Line 21:         AAA_AUTHENTICATION_CAPABILITIES,
Line 22:     };
Line 23: 
Line 24:     public static class AAAFlags {
> Ok, then I'll rename AAAFlags to AuthCapabilitiesFlags.
AAA is OK... as this is AAA.

AAAAuthCapabilitiesFlags is ok... in future it will be constant anyway...

not sure why not have plain:

 public static final int AAA_AUTH_CAP_FLAGS_PASSWORD = (1<<0);
 public static final int AAA_AUTH_CAP_FLAGS_NEGOTIATING = (1<<1);

without the outer class... but we discuss this in future.
Line 25:         public static final int AAA_PASSWORD_AUTH_FLAG = 0x00000001;
Line 26:         public static final int AAA_NEGOTIATION_AUTH_FLAG = 0x00000010;
Line 27:     }
Line 28: 


Line 22:     };
Line 23: 
Line 24:     public static class AAAFlags {
Line 25:         public static final int AAA_PASSWORD_AUTH_FLAG = 0x00000001;
Line 26:         public static final int AAA_NEGOTIATION_AUTH_FLAG = 0x00000010;
> Done
please remove the _FLAG as well, as you are in inner class of flags.
Line 27:     }
Line 28: 
Line 29:     /**
Line 30:      * Sets the context of the Extension


-- 
To view, visit http://gerrit.ovirt.org/25571
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: If3a6f8586bdb14fcc6c09c77dc1b761b795fce07
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Yair Zaslavsky <yzasl...@redhat.com>
Gerrit-Reviewer: Alon Bar-Lev <alo...@redhat.com>
Gerrit-Reviewer: Yair Zaslavsky <yzasl...@redhat.com>
Gerrit-Reviewer: automat...@ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to