Second try, added netdev to the cc: list this time.
This cleans up other usages of of vmalloc in ebtables.c. The
changes are similar to the cleanup done in
ebtables-fix-allocation-in-net-bridge-netfilter-ebtablesc.patch
Patch Description:
This patch makes all the vmalloc calls in net/bridge/ne
On Wed, Apr 19, 2006 at 10:04:53AM +0400, Boris B. Zhmurov wrote:
>
> I confirm, finally I don't see messages in dmesg about assertions. Nice
> work :)
That's great. Thanks a lot for your and everyone else's help in
tracking down.
Cheers,
--
Visit Openswan at http://www.openswan.org/
Email: H
Hello, Herbert Xu.
On 19.04.2006 03:27 you said the following:
On Tue, Apr 18, 2006 at 01:22:56PM -0700, David S. Miller wrote:
I think it is deserving of some run time assertions, else these bugs
will elude us continually. Luckily there are only a few places that
would need the run time ass
On Wed, 2006-04-19 at 01:02 +0100, Daniel Drake wrote:
> wpa_supplicant requires some notification when association has completed, and
> this is the way to do it.
Check out the patches I posted earlier:
http://softmac.sipsolutions.net/patches/
Specifically, this one by Dan Williams:
http://softma
From: Mark Brown <[EMAIL PROTECTED]>
Provide a module option which configures the natsemi driver to use the
external MII port on the chip but ignore any PHYs that may be attached to it.
The link state will be left as it was when the driver started and can be
configured via ethtool. Any PHYs tha
From: Michael Buesch <[EMAIL PROTECTED]>
This fixes coverity bug:
http://marc.theaimsgroup.com/?l=linux-netdev&m=114417628413880&w=2
Signed-off-by: Michael Buesch <[EMAIL PROTECTED]>
Signed-off-by: Andrew Morton <[EMAIL PROTECTED]>
---
drivers/net/wireless/bcm43xx/bcm43xx_power.c | 115 ++
From: Bjorn Helgaas <[EMAIL PROTECTED]>
Apparently the Intel PRO/100 device enables interrupts on reset. Unless
firmware explicitly disables PRO/100 interrupts, we can get a flood of
interrupts when a driver attaches to an unrelated device that happens to
share the PRO/100 IRQ.
This should reso
From: Linas Vepstas <[EMAIL PROTECTED]>
If a PCI bus error/fault triggers a PCI bus reset, attempts to get the
ethernet packet count statistics from the hardware will fail, returning
garbage data upstream. This patch skips statistics data collection if the
PCI device is not on the bus.
This pat
From: Willy TARREAU <[EMAIL PROTECTED]>
Recent patch cb764326dff0ee51aca0d450e1a292de65661055 introduced a thinko
in e1000_main.c : e1000_media_type_copper is compared to hw.phy_type
instead of hw.media_type. Original patch proposed by Jesse Brandeburg was
correct, but what has been merged is no
From: Michael Buesch <[EMAIL PROTECTED]>
This cleans up the bcm43xx sysfs code and makes it compliant with the
unwritten sysfs rules (at least I hope so).
Signed-off-by: Michael Buesch <[EMAIL PROTECTED]>
Cc: Jeff Garzik <[EMAIL PROTECTED]>
Cc: Greg KH <[EMAIL PROTECTED]>
Signed-off-by: Andrew M
From: Ingo Oeser <[EMAIL PROTECTED]>
general:
- endian annotation of the ring descriptors
nv_getlen():
- use htons() instead of __constant_htons()
to improvde readability and let the compiler constant fold it.
nv_rx_process():
- use a real for() loop in process
From: Linas Vepstas <[EMAIL PROTECTED]>
Various PCI bus errors can be signaled by newer PCI controllers. This
patch adds the PCI error recovery callbacks to the intel gigabit ethernet
e1000 device driver. The patch has been tested, and appears to work well.
[EMAIL PROTECTED]: minor cleanups]
S
From: Thibaut VARENE <[EMAIL PROTECTED]>
Fix a problem with Tulip 21142 HP branded PCI cards (PN#: B5509-66001),
which feature a NatSemi DP83840A PHY.
Without that patch, it is impossible to properly initialize the card's PHY,
and it's thus impossible to monitor/configure it.
It's a timing/post
From: [EMAIL PROTECTED] (Linas Vepstas)
Various PCI bus errors can be signaled by newer PCI controllers. This
patch adds the PCI error recovery callbacks to the intel ethernet e100
device driver. The patch has been tested, and appears to work well.
Signed-off-by: Linas Vepstas <[EMAIL PROTECTE
From: Alexey Kuznetsov <[EMAIL PROTECTED]>
Date: Wed, 19 Apr 2006 03:52:22 +0400
> Actually, this weird case in inet_get_route() is the only place, where
> a dummy skb is used and it is needed mostly to resolve multicast routes.
> In this case this fake skb really passes through all the engine, ev
In article <[EMAIL PROTECTED]> (at Tue, 18 Apr 2006 14:49:14 -0700 (PDT)),
"David S. Miller" <[EMAIL PROTECTED]> says:
> All applied, and I agree with pushing 1-3 into -stable,
> please send it.
Done. Thanks.
--yoshfuji
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the
Hello!
> There is also the ARP code which passes an ARP packet through that
> would get dereferenced as an IP packet. Granted this shouldn't crash
> because nh is set properly.
And point to something which is not an IP header. So, iph->protocol
is something funny. :-)
It is plain luck that this
On Wednesday 19 April 2006 02:38, Ravinandan Arakali wrote:
> configuration: A mask(specified using loadable parameter rth_fn_and_mask)
> can be used to select a subset of TCP/UDP tuple for hash calculation.
> eg. To mask source port for TCP/IPv4 configuration,
> # insmod s2io.ko rx_steering_type=
Hello!
> There is also the ARP code which passes an ARP packet through that
> would get dereferenced as an IP packet. Granted this shouldn't crash
> because nh is set properly.
And points to something which is not an IP header. So, iph->protocol
is something funny. :-)
It is plain luck that thi
Hi Jeff,
Any comments on the below patch ?
Thanks,
Ravi
-Original Message-
From: Ravinandan Arakali [mailto:[EMAIL PROTECTED]
Sent: Friday, March 10, 2006 12:32 PM
To: [EMAIL PROTECTED]; netdev@vger.kernel.org
Cc: [EMAIL PROTECTED]; [EMAIL PROTECTED];
[EMAIL PROTECTED]; [EMAIL PROTECTED];
On Wed, Apr 19, 2006 at 03:52:22AM +0400, Alexey Kuznetsov wrote:
>
> Actually, this weird case in inet_get_route() is the only place, where
There is also the ARP code which passes an ARP packet through that
would get dereferenced as an IP packet. Granted this shouldn't crash
because nh is set p
wpa_supplicant requires some notification when association has completed, and
this is the way to do it.
Before this patch, wpa_supplicant just times out when trying to associate,
even though the association completed successfully in the background. This was
reported at
http://www.mail-archive.com
On 04/14/2006 06:26 AM, David S. Miller wrote:
> These interfaces were added so that new users of netlink could
> write their code more easily.
>
> Unused does not equate to "comment out or delete".
Does a GENETLINK Kconfig option make sense (possibly dependant on
EMBEDDED)? I'm unsure whether th
Hello!
> Looking at this again, the root of this problem is the IGMPv3
> patch which started using the skb->nh.iph->protocol as a key.
No, root is that this fake skb was not properly initialized.
It should, it should be a good real IP skb.
> In fact I'm unsure as to whether all the other users
On Tue, Apr 18, 2006 at 01:22:56PM -0700, David S. Miller wrote:
>
> I think it is deserving of some run time assertions, else these bugs
> will elude us continually. Luckily there are only a few places that
> would need the run time assertion checks on skb->truesize, and I'll
> try to spend a fe
Thomas A. Oehser <[EMAIL PROTECTED]> :
[...]
> It is actually about a 30GB transfer, it was just after the first
> 170Mb that it failed. The command in question is just a simple
> "nc -l -p 12345|buffer|cpio -iumdB", and the sender may well be
> able to generate the data faster than the receiving
On Tue, Apr 18, 2006 at 02:54:16PM -0700, David S. Miller wrote:
>
> There are other areas of the packet which are interpreted in various
> ways. For example, the martian source handling will dump the MAC
> directly from skb->mac.raw into the kernel logs.
That's scary. I think this stuff needs
From: Herbert Xu <[EMAIL PROTECTED]>
Date: Tue, 18 Apr 2006 16:54:48 +1000
> Looking at this again, the root of this problem is the IGMPv3
> patch which started using the skb->nh.iph->protocol as a key.
>
> So what we really should do is make the protocol an explicit parameter
> to the ip_route_i
From: YOSHIFUJI Hideaki <[EMAIL PROTECTED]>
Date: Wed, 19 Apr 2006 00:20:45 +0900 (JST)
> Following changesets fix several errors in extension header handling.
> I'd propose to push them (except 4/4, maybe) to -stable.
>
> [PATCH 1/4] [IPV6]: Ensure to have hop-by-hop options in our header of
>
Dominik Brodowski wrote:
Please review these patches which I inted to push upstream for 2.6.17 soon.
Thanks,
Dominik
Subject: [PATCH] pcmcia: add new ID to pcnet_cs
This adds a new ID to pcnet_cs, as noted by Kuro Moji.
Signed-off-by: Dominik Brodowski <[EMAIL PROTECTED]>
ACK, thanks
From: Herbert Xu <[EMAIL PROTECTED]>
Date: Tue, 18 Apr 2006 22:32:04 +1000
> You're absolutely right about there being a problem with the TSO packet
> trimming code. The cause of this lies in the tcp_fragment() function.
>
> When we allocate a fragment for a completely non-linear packet the
> tr
From: Ingo Oeser <[EMAIL PROTECTED]>
Date: Tue, 18 Apr 2006 18:29:59 +0200
> But shouldn't we put this kind of hairy manipulation into some nice
> functions? Driver writers were already confused by all that size,
> len and truesize stuff, as this bug showed.
It's 2 lines and frankly it's a bit c
Please review these patches which I inted to push upstream for 2.6.17 soon.
Thanks,
Dominik
Subject: [PATCH] pcmcia: add new ID to pcnet_cs
This adds a new ID to pcnet_cs, as noted by Kuro Moji.
Signed-off-by: Dominik Brodowski <[EMAIL PROTECTED]>
---
drivers/net/pcmcia/pcnet_cs.c |
Hi,
This patch series implements two e100 fixes for an old and new patch mishap.
[1] fix mispatch for media type detect.
[2] fix mismerge skb_put.
These changes are available through git.
git://63.64.152.142/~ahkok/git/netdev-2.6 e1000-7.0.38-k2-fixes
these patches are against
netdev-2.6#up
Recent patch was mismerged in the miitool path. e1000_media_type_copper
was being compared with the phy type instead of the media type.
Signed-off-by: Jesse Brandeburg <[EMAIL PROTECTED]>
Signed-off-by: Auke Kok <[EMAIL PROTECTED]>
---
drivers/net/e1000/e1000_main.c |2 +-
1 files changed,
Seems there was a bit of a fix needed to due a bad merge in the legacy
receive path. Fixes a panic due to skb_over_panic.
Signed-off-by: Jesse Brandeburg <[EMAIL PROTECTED]>
Signed-off-by: Auke Kok <[EMAIL PROTECTED]>
---
drivers/net/e1000/e1000_main.c |3 +--
1 files changed, 1 insertions
On Tue, Apr 18, 2006 at 07:48:41PM +0100, Alan Cox wrote:
> On Maw, 2006-04-18 at 16:19 +0200, Adrian Bunk wrote:
> > OTOH, we also have to always check whether users are expected soon (and
> > recheck whether there are really users after some time) since every
> > single export makes the kernel
On Maw, 2006-04-18 at 16:19 +0200, Adrian Bunk wrote:
> OTOH, we also have to always check whether users are expected soon (and
> recheck whether there are really users after some time) since every
> single export makes the kernel larger for nearly everyone.
Of course fixing the amount of memory
On Tue, 2006-04-18 at 18:07 +0200, Eric Sesterhenn wrote:
> Hi,
>
> the coverity checker spotted that cred is always NULL
> when we jump to out_err ( there is just one case, when
> we fail to allocate the memory for cred )
> This is Coverity ID #79
>
> Signed-off-by: Eric Sesterhenn <[EMAIL PROTE
Hi Herbert,
Herbert Xu wrote:
> I've copied the code you used in tso_fragment which should work here.
I'm happy to see, that this got resolved and this is a nice minimalistic fix
for -stable.
But shouldn't we put this kind of hairy manipulation into some nice functions?
Driver writers were alr
Hi,
the coverity checker spotted that cred is always NULL
when we jump to out_err ( there is just one case, when
we fail to allocate the memory for cred )
This is Coverity ID #79
Signed-off-by: Eric Sesterhenn <[EMAIL PROTECTED]>
--- linux-2.6.17-rc1/net/sunrpc/auth_gss/auth_gss.c.orig20
[IPV6]: Ensure to have hop-by-hop options in our header of &sk_buff.
Signed-off-by: YOSHIFUJI Hideaki <[EMAIL PROTECTED]>
---
net/ipv6/exthdrs.c | 12
1 files changed, 12 insertions(+), 0 deletions(-)
7bcedcc73a45a5577103422c33e01f1633173984
diff --git a/net/ipv6/exthdrs.c b/net
[IPV6] XFRM: Don't use old copy of pointer after pskb_may_pull().
Signed-off-by: YOSHIFUJI Hideaki <[EMAIL PROTECTED]>
---
net/ipv6/xfrm6_policy.c |4 +++-
1 files changed, 3 insertions(+), 1 deletions(-)
83e25b9fb69b2c04ebfec2ee2b9fe95e5a7c0584
diff --git a/net/ipv6/xfrm6_policy.c b/net/i
[IPV6] XFRM: Fix decoding session with preceding extension header(s).
We did not correctly decode session with preceding extension
header(s). This was because we had already pulled preceding
headers, skb->nh.raw + 40 + 1 - skb->data was minus, and
pskb_may_pull() failed.
We now have IP6CB(skb)->
[IPV6]: Clean up hop-by-hop options handler.
- Removed unused argument (nhoff) for ipv6_parse_hopopts().
- Make ipv6_parse_hopopts() to align with other extension header
handlers.
- Removed pointless assignment (hdr), which is not used afterwards.
Signed-off-by: YOSHIFUJI Hideaki <[EMAIL PROTEC
Hello.
Following changesets fix several errors in extension header handling.
I'd propose to push them (except 4/4, maybe) to -stable.
[PATCH 1/4] [IPV6]: Ensure to have hop-by-hop options in our header of &sk_buff.
[PATCH 2/4] [IPV6] XFRM: Don't use old copy of pointer after pskb_may_pull().
[PAT
Hi John,
I already sent these three patches for inclusion into
the softmac version of the driver. Here are the devicescape
port versions for inclusion in your wireless-dev tree.
--
Greetings Michael.
Index: wireless-dev-ds/drivers/net/wireless/bcm43xx-d80211/bcm43xx.h
===
On Fri, Apr 14, 2006 at 02:56:12PM +0400, Evgeniy Polyakov wrote:
>...
> Although it is always statically built systems, it is still very
> convenient way of netlink usage for others (future modular systems).
I do understand Dave's "new API, users are expected soon" point.
OTOH, we also have to a
Hi Dave:
You're absolutely right about there being a problem with the TSO packet
trimming code. The cause of this lies in the tcp_fragment() function.
When we allocate a fragment for a completely non-linear packet the
truesize is calculated for a payload length of zero. This means that
truesize
Hi David,
You wrote:
> 2) We can't turn sk_forward_alloc easily into an atomic_t. The
>masking operation in __sk_stream_mem_reclaim() does not translate
>readily into an atomic_t op:
>
> sk->sk_forward_alloc &= SK_STREAM_MEM_QUANTUM - 1;
>
>That line has always driven
50 matches
Mail list logo