[Lldb-commits] [PATCH] D70023: [lldb] [Process/NetBSD] Copy watchpoints to newly-created threads

2019-11-25 Thread Michał Górny via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rGd970d4d4aa73: [lldb] [Process/NetBSD] Copy watchpoints to newly-created threads (authored by mgorny). Herald added a project: LLDB. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https

[Lldb-commits] [PATCH] D70025: [lldb] [Process/NetBSD] Fix handling concurrent watchpoint events

2019-11-25 Thread Michał Górny via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG7644d8ba4dc4: [lldb] [Process/NetBSD] Fix handling concurrent watchpoint events (authored by mgorny). Herald added a project: LLDB. Changed prior to commit: https://reviews.llvm.org/D70025?vs=228955&id=

[Lldb-commits] [PATCH] D70022: [lldb] [Process/NetBSD] Improve threading support

2019-11-25 Thread Michał Górny via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG8d9400b65b97: [lldb] [Process/NetBSD] Improve threading support (authored by mgorny). Herald added a project: LLDB. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.

[Lldb-commits] [PATCH] D70532: [lldb] Improve/fix base address selection in location lists

2019-11-25 Thread Greg Clayton via Phabricator via lldb-commits
clayborg added a comment. In D70532#1758962 , @labath wrote: > In D70532#1758907 , @clayborg wrote: > > > So I am worried by seeing any mention of "load address" and "load bias" in > > this patch. All information t

[Lldb-commits] [PATCH] D69535: build: improve python check for Windows

2019-11-25 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. This looks fine to me, and it's really great to get rid of the that code, but it would be good for some some "windows person" to ack this too. I'm particularly interested in Stella's opinion, as according to http://lab.llvm.org:8011/buildslaves/win-py3-buildbot, her bot

[Lldb-commits] [PATCH] D70532: [lldb] Improve/fix base address selection in location lists

2019-11-25 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. In D70532#1758907 , @clayborg wrote: > So I am worried by seeing any mention of "load address" and "load bias" in > this patch. All information that is extracted from the DWARF should be solely > in terms if "file addresses" IMHO,

[Lldb-commits] [PATCH] D70025: [lldb] [Process/NetBSD] Fix handling concurrent watchpoint events

2019-11-25 Thread Kamil Rytarowski via Phabricator via lldb-commits
krytarowski added a comment. In D70025#1758800 , @labath wrote: > LGTM, since this seems to be the best we can do given the current netbsd > behavior. > > However, I'd like to repeat what I said on the IRC, that I consider this > behavior of netbsd to be

[Lldb-commits] [PATCH] D70532: [lldb] Improve/fix base address selection in location lists

2019-11-25 Thread Greg Clayton via Phabricator via lldb-commits
clayborg added a comment. So I am worried by seeing any mention of "load address" and "load bias" in this patch. All information that is extracted from the DWARF should be solely in terms if "file addresses" IMHO, unless I am not understanding something from the new location lists. For mach-o D

[Lldb-commits] [PATCH] D69309: Support template instantiation in the expression evaluator

2019-11-25 Thread Greg Clayton via Phabricator via lldb-commits
clayborg added a comment. I wanted to make sure that people understand about how templates are done in DWARF and the implications, just for completeness: 1. DWARF represents only specializations of templates (foo) and not the generic template definition in terms of type T (foo) 2. DWARF only cr

[Lldb-commits] [PATCH] D70025: [lldb] [Process/NetBSD] Fix handling concurrent watchpoint events

2019-11-25 Thread Pavel Labath via Phabricator via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. Herald added a subscriber: dexonsmith. LGTM, since this seems to be the best we can do given the current netbsd behavior. However, I'd like to repeat what I said on the IRC, that I consider th

[Lldb-commits] [PATCH] D70668: [lldb][NFC] Allow range-based for-loops on VariableList

2019-11-25 Thread Raphael Isemann via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rGd1782133d96d: [lldb][NFC] Allow range-based for-loops on VariableList (authored by teemperor). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D70668/new/ http

[Lldb-commits] [lldb] d178213 - [lldb][NFC] Allow range-based for-loops on VariableList

2019-11-25 Thread Raphael Isemann via lldb-commits
Author: Raphael Isemann Date: 2019-11-25T15:03:46+01:00 New Revision: d1782133d96d316c3bc98e33a191994794a26851 URL: https://github.com/llvm/llvm-project/commit/d1782133d96d316c3bc98e33a191994794a26851 DIFF: https://github.com/llvm/llvm-project/commit/d1782133d96d316c3bc98e33a191994794a26851.dif

[Lldb-commits] [PATCH] D70668: [lldb][NFC] Allow range-based for-loops on VariableList

2019-11-25 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor updated this revision to Diff 230888. teemperor added a comment. - Added `_sp` suffix to variable names. - Using const-references where possible. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D70668/new/ https://reviews.llvm.org/D70668 Files: lldb/include/lldb/Symbol/Variabl

[Lldb-commits] [PATCH] D70668: [lldb][NFC] Allow range-based for-loops on VariableList

2019-11-25 Thread Pavel Labath via Phabricator via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. Since copying shared pointers isn't completely cheap, I think we should use `const shared_ptr &`s whereever possible. Also, the typical lldb naming convention for shared_pointer variables is t

[Lldb-commits] [PATCH] D70668: [lldb][NFC] Allow range-based for-loops on VariableList

2019-11-25 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor created this revision. teemperor added a reviewer: labath. Herald added a reviewer: jdoerfert. Herald added subscribers: lldb-commits, JDevlieghere. Herald added a project: LLDB. Adds support for doing range-based for-loops on LLDB's VariableList and modernises all the index-based for-lo

[Lldb-commits] [PATCH] D70663: [lldb] Remove lldb's own ASTDumper

2019-11-25 Thread Raphael Isemann via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG7a6588abf8ba: [lldb] Remove lldb's own ASTDumper (authored by teemperor). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D70663/new/ https://reviews.llvm.org/

[Lldb-commits] [PATCH] D70663: [lldb] Remove lldb's own ASTDumper

2019-11-25 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor updated this revision to Diff 230875. teemperor added a comment. - Address feedback (Thanks Pavel) CHANGES SINCE LAST ACTION https://reviews.llvm.org/D70663/new/ https://reviews.llvm.org/D70663 Files: lldb/include/lldb/Symbol/ClangUtil.h lldb/source/Plugins/ExpressionParser/Cla

[Lldb-commits] [lldb] 7a6588a - [lldb] Remove lldb's own ASTDumper

2019-11-25 Thread Raphael Isemann via lldb-commits
Author: Raphael Isemann Date: 2019-11-25T13:27:51+01:00 New Revision: 7a6588abf8bac99d716188608adfbfb4928714db URL: https://github.com/llvm/llvm-project/commit/7a6588abf8bac99d716188608adfbfb4928714db DIFF: https://github.com/llvm/llvm-project/commit/7a6588abf8bac99d716188608adfbfb4928714db.dif

[Lldb-commits] [PATCH] D70663: [lldb] Remove lldb's own ASTDumper

2019-11-25 Thread Pavel Labath via Phabricator via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. Yay Comment at: lldb/source/Plugins/ExpressionParser/Clang/ClangExpressionDeclMap.cpp:1675 + " CEDM::FEVD[{0}] Found variable {1}, returned\n{2} (original {3})",

[Lldb-commits] [PATCH] D70663: [lldb] Remove lldb's own ASTDumper

2019-11-25 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor created this revision. teemperor added a reviewer: labath. Herald added subscribers: lldb-commits, JDevlieghere, mgorny. Herald added a project: LLDB. LLDB's ASTDumper is just a clone of Clang's ASTDumper but with some scary code and some unrelated functionality (like dumping name/attri

[Lldb-commits] [PATCH] D70645: RFC 1/3: Unify src<->dst DWARFASTParser for CopyUniqueClassMethodTypes()

2019-11-25 Thread Raphael Isemann via Phabricator via lldb-commits
teemperor added a comment. I think it's possible that for example with -gmodules we have multiple ClangASTContext's (and therefore multiple DWARFASTParserClang), but the only place where we call this function seems to only concerned about a single SymbolFileDWARF so this seems safe. Repositor

[Lldb-commits] [PATCH] D70645: RFC 1/3: Unify src<->dst DWARFASTParser for CopyUniqueClassMethodTypes()

2019-11-25 Thread Pavel Labath via Phabricator via lldb-commits
labath added a reviewer: teemperor. labath added a subscriber: teemperor. labath added a comment. @shafik or @teemperor will know more about this. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D70645/new/ https://reviews.llvm.org/D70645 _

[Lldb-commits] [PATCH] D70647: RFC 3/3: Remove DWARFDIE dependency from functions moved by D70646

2019-11-25 Thread Pavel Labath via Phabricator via lldb-commits
labath added inline comments. Comment at: lldb/include/lldb/Symbol/TypeSystem.h:108-110 + virtual DWARFASTParser *GetDWARFParser(SymbolFileDWARF &dwarf) { +return nullptr; + } This part looks pretty dodgy. I'd like to avoid introducing plugin references in

[Lldb-commits] [PATCH] D70646: RFC 2/3: Move non-DWARF code: `DWARFUnit` -> `SymbolFileDWARF`

2019-11-25 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. > @labath, maybe this is the only patch you did mean? This is (more or less -- I can't say I had a really exact picture in my head) what I had in mind, when I said that moving the high-level code out of the DWARFUnit class would be useful for the llvm<->lldb dwarf parser

[Lldb-commits] [PATCH] D70622: [cmake][lit] Follow symlinks when looking for lit tests & reconfigure lldb's tests.

2019-11-25 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. Thanks for looking into this. This is something I've missed too, but never got around to checking it out. Jonas, what do you think about this? Should we do this, or move the testcases themselves into the "test/API" folder? Repository: rG LLVM Github Monorepo CHANGES

[Lldb-commits] [PATCH] D70023: [lldb] [Process/NetBSD] Copy watchpoints to newly-created threads

2019-11-25 Thread Pavel Labath via Phabricator via lldb-commits
labath marked an inline comment as done. labath added inline comments. Comment at: lldb/test/Shell/Watchpoint/netbsd-nouserdbregs.test:5 +# REQUIRES: native && system-netbsd && (target-x86 || target-x86_64) && !dbregs-set +# RUN: %clang %p/Inputs/thread-dbreg.c -pthread -g -o %t

[Lldb-commits] [PATCH] D70127: [lldb-vscode] Fix a race in test_extra_launch_commands

2019-11-25 Thread Pavel Labath via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rGaa16bf15fe38: [lldb-vscode] Fix a race in test_extra_launch_commands (authored by labath). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D70127/new/ https://

[Lldb-commits] [lldb] aa16bf1 - [lldb-vscode] Fix a race in test_extra_launch_commands

2019-11-25 Thread Pavel Labath via lldb-commits
Author: Pavel Labath Date: 2019-11-25T10:07:38+01:00 New Revision: aa16bf15fe38ae4d12d85e7610891dd48e6c0cda URL: https://github.com/llvm/llvm-project/commit/aa16bf15fe38ae4d12d85e7610891dd48e6c0cda DIFF: https://github.com/llvm/llvm-project/commit/aa16bf15fe38ae4d12d85e7610891dd48e6c0cda.diff