labath accepted this revision. labath added a comment. This revision is now accepted and ready to land.
Since copying shared pointers isn't completely cheap, I think we should use `const shared_ptr &`s whereever possible. Also, the typical lldb naming convention for shared_pointer variables is to have them end in `_sp`, so I'd try to preserve that. Besides that, LGTM. Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D70668/new/ https://reviews.llvm.org/D70668 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits