[Lldb-commits] [PATCH] D57330: Adjust documentation for git migration.

2019-01-28 Thread Mehdi AMINI via Phabricator via lldb-commits
mehdi_amini added a comment. LGTM, but for one comment that requires a fix I believe (lld on Windows) Comment at: libcxx/docs/BuildingLibcxx.rst:47 - * ``cd build`` - * ``cmake -G [options] `` So nice to see these steps going away :) C

[Lldb-commits] [PATCH] D57363: Fix handling of CreateTemplateParameterList when there is an empty pack

2019-01-28 Thread Davide Italiano via Phabricator via lldb-commits
davide added inline comments. Comment at: packages/Python/lldbsuite/test/expression_command/radar_47565290/TestClassTemplateSpecializationParametersHandling.py:5-6 + +from __future__ import print_function + + I think this is not needed. Commen

[Lldb-commits] [PATCH] D57363: Fix handling of CreateTemplateParameterList when there is an empty pack

2019-01-28 Thread Adrian Prantl via Phabricator via lldb-commits
aprantl added inline comments. Comment at: packages/Python/lldbsuite/test/expression_command/radar_47565290/TestClassTemplateSpecializationParametersHandling.py:23 + +(self.target, self.process, _, bkpt) = lldbutil.run_to_source_breakpoint(self, '// break here', +

[Lldb-commits] [PATCH] D57363: Fix handling of CreateTemplateParameterList when there is an empty pack

2019-01-28 Thread Adrian Prantl via Phabricator via lldb-commits
aprantl added inline comments. Comment at: packages/Python/lldbsuite/test/expression_command/radar_47565290/TestClassTemplateSpecializationParametersHandling.py:9 +import os +import time +import lldb I don't think these are used Comment at: p

[Lldb-commits] [PATCH] D57363: Fix handling of CreateTemplateParameterList when there is an empty pack

2019-01-28 Thread Adrian Prantl via Phabricator via lldb-commits
aprantl added inline comments. Comment at: packages/Python/lldbsuite/test/expression_command/radar_47565290/Makefile:1 +LEVEL = ../../make + Could you give the directory a more descriptive name instead of `radar_47565290`? It's fine to mention a rdar:// link in

[Lldb-commits] [PATCH] D57363: Fix handling of CreateTemplateParameterList when there is an empty pack

2019-01-28 Thread Shafik Yaghmour via Phabricator via lldb-commits
shafik created this revision. shafik added reviewers: aprantl, jingham, teemperor, martong. Herald added a subscriber: rnkovacs. Herald added a reviewer: serge-sans-paille. When we are creating a ClassTemplateSpecializationDecl in ParseTypeFromDWARF(...) we are not handling the case where variadi

[Lldb-commits] [PATCH] D54617: [Reproducers] Add file provider

2019-01-28 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere updated this revision to Diff 183968. JDevlieghere marked 4 inline comments as done. JDevlieghere added a comment. - Feedback pavel CHANGES SINCE LAST ACTION https://reviews.llvm.org/D54617/new/ https://reviews.llvm.org/D54617 Files: include/lldb/Host/FileSystem.h include/ll

[Lldb-commits] [PATCH] D57330: Adjust documentation for git migration.

2019-01-28 Thread Shoaib Meenai via Phabricator via lldb-commits
smeenai accepted this revision. smeenai added a comment. This revision is now accepted and ready to land. The amount of duplicated and out-of-date documentation makes me sad, but this is an awesome effort to clean that up. Comment at: lldb/packages/Python/lldbsuite/test/funct

[Lldb-commits] [PATCH] D57273: Make Type::GetByteSize optional

2019-01-28 Thread Adrian Prantl via Phabricator via lldb-commits
aprantl added a comment. Pavel, I may need you help. I reverted the commit because it broke three PDB-related tests (SymbolFilePDBTests, func-symbols, and typedefs) that need more than just lld in order to run. The fix is probably trivial. We only need to set a breakpoint in `Type.cpp:119` and

[Lldb-commits] [lldb] r352434 - Revert "Make Type::GetByteSize optional (NFC)"

2019-01-28 Thread Adrian Prantl via lldb-commits
Author: adrian Date: Mon Jan 28 13:44:35 2019 New Revision: 352434 URL: http://llvm.org/viewvc/llvm-project?rev=352434&view=rev Log: Revert "Make Type::GetByteSize optional (NFC)" This reverts commit r352394 because it broke three windows-specific tests. Modified: lldb/trunk/include/lldb/Sym

[Lldb-commits] [PATCH] D57272: Remove unimplemented function

2019-01-28 Thread Phabricator via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rLLDB352417: Remove unimplemented function (authored by adrian, committed by ). Changed prior to commit: https://reviews.llvm.org/D57272?vs=183669&id=183926#toc Repository: rLLDB LLDB CHANGES SINCE LA

[Lldb-commits] [lldb] r352417 - Remove unimplemented function

2019-01-28 Thread Adrian Prantl via lldb-commits
Author: adrian Date: Mon Jan 28 11:38:08 2019 New Revision: 352417 URL: http://llvm.org/viewvc/llvm-project?rev=352417&view=rev Log: Remove unimplemented function Looks like this was an unintended sideeffect of r124250. Differential Revision: https://reviews.llvm.org/D57272 Modified: lldb/t

[Lldb-commits] [PATCH] D56904: [NativePDB] Process virtual bases in the correct order

2019-01-28 Thread Zachary Turner via Phabricator via lldb-commits
zturner added a comment. Sorry, due to the way Phabricator re-orders feedback across files when sending the email notification, if you're reading my comments in email you have to read the previous email from the bottom up. Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.l

[Lldb-commits] [PATCH] D56904: [NativePDB] Process virtual bases in the correct order

2019-01-28 Thread Zachary Turner via Phabricator via lldb-commits
zturner added a comment. The above suggestion is admittedly minor, but since it's both a minor performance improvement **and** a minor readability/maintainability improvement, I think it's probably worth doing. Comment at: lit/SymbolFile/NativePDB/tag-types.cpp:5 // Test tha

[Lldb-commits] [PATCH] D57213: [Scalar] Add support for 512-bits values.

2019-01-28 Thread Davide Italiano via Phabricator via lldb-commits
davide marked an inline comment as done. davide added inline comments. Comment at: lldb/source/Utility/Scalar.cpp:161 +if (endian::InlHostByteOrder() == eByteOrderBig) { + swapped_words[0] = apint_words[7]; + swapped_words[1] = apint_words[6]; zturn

[Lldb-commits] [PATCH] D56126: [NativePDB] Add basic support of methods recostruction in AST

2019-01-28 Thread Zachary Turner via Phabricator via lldb-commits
zturner added a comment. Thanks for the reminder! CHANGES SINCE LAST ACTION https://reviews.llvm.org/D56126/new/ https://reviews.llvm.org/D56126 ___ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/list

[Lldb-commits] [PATCH] D57213: [Scalar] Add support for 512-bits values.

2019-01-28 Thread Zachary Turner via Phabricator via lldb-commits
zturner added inline comments. Comment at: lldb/source/Utility/Scalar.cpp:161 +if (endian::InlHostByteOrder() == eByteOrderBig) { + swapped_words[0] = apint_words[7]; + swapped_words[1] = apint_words[6]; I'm confused. You say it returns a pointer t

[Lldb-commits] [PATCH] D57275: [seven] Remove trailing characters from command output.

2019-01-28 Thread Jonas Devlieghere via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rLLDB352397: [testsuite] Remove trailing characters from command output. (authored by JDevlieghere, committed by ). Changed prior to commit: https://reviews.llvm.org/D57275?vs=183877&id=183900#toc Reposi

[Lldb-commits] [lldb] r352398 - [testsuite] Remove unused seven module imports.

2019-01-28 Thread Jonas Devlieghere via lldb-commits
Author: jdevlieghere Date: Mon Jan 28 10:07:41 2019 New Revision: 352398 URL: http://llvm.org/viewvc/llvm-project?rev=352398&view=rev Log: [testsuite] Remove unused seven module imports. Modified: lldb/trunk/packages/Python/lldbsuite/test/functionalities/exec/TestExec.py lldb/trunk/packa

[Lldb-commits] [lldb] r352397 - [testsuite] Remove trailing characters from command output.

2019-01-28 Thread Jonas Devlieghere via lldb-commits
Author: jdevlieghere Date: Mon Jan 28 10:07:28 2019 New Revision: 352397 URL: http://llvm.org/viewvc/llvm-project?rev=352397&view=rev Log: [testsuite] Remove trailing characters from command output. When running the test suite on macOS with Python 3 we noticed a difference in behavior between Pyt

[Lldb-commits] [PATCH] D57273: Make Type::GetByteSize optional

2019-01-28 Thread Phabricator via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL352394: Make Type::GetByteSize optional (NFC) (authored by adrian, committed by ). Herald added a subscriber: llvm-commits. Changed prior to commit: https://reviews.llvm.org/D57273?vs=183671&id=183895#t

[Lldb-commits] [lldb] r352394 - Make Type::GetByteSize optional (NFC)

2019-01-28 Thread Adrian Prantl via lldb-commits
Author: adrian Date: Mon Jan 28 09:49:33 2019 New Revision: 352394 URL: http://llvm.org/viewvc/llvm-project?rev=352394&view=rev Log: Make Type::GetByteSize optional (NFC) This is a continuation of my quest to make the size 0 a supported value. Differential Revision: https://reviews.llvm.org/D572

[Lldb-commits] [PATCH] D57330: Adjust documentation for git migration.

2019-01-28 Thread James Y Knight via Phabricator via lldb-commits
jyknight updated this revision to Diff 183891. jyknight added a comment. Fix some warnings I added. Restore TestSuiteMakefileGuide.rst, which apparently isn't 100% obsolete. (But it is incorrect, and I'm not sure exactly how to fix it, so I just left a FIXME). CHANGES SINCE LAST ACTION https:

[Lldb-commits] [PATCH] D56822: [Reproducers] Tool to insert SBReproducer macros

2019-01-28 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere updated this revision to Diff 183888. JDevlieghere added reviewers: labath, davide, friss. JDevlieghere added a comment. Fix `MacroMacro` and other code cleanups. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D56822/new/ https://reviews.llvm.org/D56822 Files: tools/CMakeL

[Lldb-commits] [lldb] r352388 - [CMake] Add code signing for lldb-server on iOS

2019-01-28 Thread Stefan Granitz via lldb-commits
Author: stefan.graenitz Date: Mon Jan 28 08:57:23 2019 New Revision: 352388 URL: http://llvm.org/viewvc/llvm-project?rev=352388&view=rev Log: [CMake] Add code signing for lldb-server on iOS Modified: lldb/trunk/tools/lldb-server/CMakeLists.txt Modified: lldb/trunk/tools/lldb-server/CMakeList

[Lldb-commits] [lldb] r352387 - [CMake] Dump LLDB.framework tools at configuration time

2019-01-28 Thread Stefan Granitz via lldb-commits
Author: stefan.graenitz Date: Mon Jan 28 08:57:19 2019 New Revision: 352387 URL: http://llvm.org/viewvc/llvm-project?rev=352387&view=rev Log: [CMake] Dump LLDB.framework tools at configuration time Modified: lldb/trunk/cmake/modules/LLDBFramework.cmake Modified: lldb/trunk/cmake/modules/LLDB

[Lldb-commits] [PATCH] D57275: [testsuite] Remove seven dependency

2019-01-28 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere updated this revision to Diff 183877. JDevlieghere added a comment. - Remove trailing characters from get_command_status_output. - Remove unused seven imports. (I'll land this as two separate commits) CHANGES SINCE LAST ACTION https://reviews.llvm.org/D57275/new/ https://reviews

[Lldb-commits] [PATCH] D56237: Implement GetFileLoadAddress for the Windows process plugin

2019-01-28 Thread Greg Clayton via Phabricator via lldb-commits
clayborg added a comment. In D56237#1373234 , @labath wrote: > I think there are some architectural issues here in how ProcessWindows works. > Normally (i.e., on all non-windows process classes), it is the job of the > dynamic loader plugin to create mod

[Lldb-commits] [PATCH] D57273: Make Type::GetByteSize optional

2019-01-28 Thread Adrian Prantl via Phabricator via lldb-commits
aprantl marked an inline comment as done. aprantl added inline comments. Comment at: include/lldb/Symbol/Type.h:221 + uint64_t m_byte_size : 63; + unsigned m_byte_size_has_value : 1; Declaration m_decl; clayborg wrote: > Does this need to be uint64_t to shar

[Lldb-commits] [PATCH] D57273: Make Type::GetByteSize optional

2019-01-28 Thread Greg Clayton via Phabricator via lldb-commits
clayborg added inline comments. Comment at: include/lldb/Symbol/Type.h:221 + uint64_t m_byte_size : 63; + unsigned m_byte_size_has_value : 1; Declaration m_decl; Does this need to be uint64_t to share the same space as m_byte_size? CHANGES SINCE LAST ACTIO

[Lldb-commits] [PATCH] D57334: [CMake] Accept ENTITLEMENTS in llvm_add_library()

2019-01-28 Thread Stefan Gränitz via Phabricator via lldb-commits
sgraenitz created this revision. sgraenitz added a reviewer: beanz. Herald added subscribers: llvm-commits, mgorny. We added support for code signing entitlements in add_llvm_executable() with D54443 . In the future it would be useful to have this functionality a

[Lldb-commits] [PATCH] D57213: [Scalar] Add support for 512-bits values.

2019-01-28 Thread Davide Italiano via Phabricator via lldb-commits
davide added a comment. Thanks for the review, Greg! CHANGES SINCE LAST ACTION https://reviews.llvm.org/D57213/new/ https://reviews.llvm.org/D57213 ___ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/l

[Lldb-commits] [PATCH] D57233: [CMake] Quick-Fix targets don't exist when building against LLVM install-tree with LLDB_INCLUDE_TESTS=ON

2019-01-28 Thread Phabricator via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rLLDB352382: [CMake] Quick-Fix targets don't exist when building against LLVM install-tree… (authored by stefan.graenitz, committed by ). Herald added a subscriber: teemperor. Changed prior to commit: ht

[Lldb-commits] [lldb] r352382 - [CMake] Quick-Fix targets don't exist when building against LLVM install-tree with LLDB_INCLUDE_TESTS=ON

2019-01-28 Thread Stefan Granitz via lldb-commits
Author: stefan.graenitz Date: Mon Jan 28 08:15:27 2019 New Revision: 352382 URL: http://llvm.org/viewvc/llvm-project?rev=352382&view=rev Log: [CMake] Quick-Fix targets don't exist when building against LLVM install-tree with LLDB_INCLUDE_TESTS=ON The issue came up during release testing for LLVM

[Lldb-commits] [PATCH] D57330: Adjust documentation for git migration.

2019-01-28 Thread James Y Knight via Phabricator via lldb-commits
jyknight created this revision. jyknight added reviewers: jlebar, rnk, mehdi_amini. Herald added subscribers: jsji, jfb, arphaman, christof, delcypher, hiraditya, nhaehnle, jvesely, nemanjai, kubamracek, arsenm. Herald added a reviewer: bollu. Herald added a reviewer: serge-sans-paille. This fixe

[Lldb-commits] [PATCH] D57282: [cmake] Fix get_llvm_lit_path() to respect LLVM_EXTERNAL_LIT always

2019-01-28 Thread Michał Górny via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL352374: [cmake] Fix get_llvm_lit_path() to respect LLVM_EXTERNAL_LIT always (authored by mgorny, committed by ). Changed prior to commit: https://reviews.llvm.org/D57282?vs=183693&id=183855#toc Reposit

[Lldb-commits] [lldb] r352374 - [cmake] Fix get_llvm_lit_path() to respect LLVM_EXTERNAL_LIT always

2019-01-28 Thread Michal Gorny via lldb-commits
Author: mgorny Date: Mon Jan 28 07:16:03 2019 New Revision: 352374 URL: http://llvm.org/viewvc/llvm-project?rev=352374&view=rev Log: [cmake] Fix get_llvm_lit_path() to respect LLVM_EXTERNAL_LIT always Refactor the get_llvm_lit_path() logic to respect LLVM_EXTERNAL_LIT, and require the fallback to

[Lldb-commits] [PATCH] D57282: [cmake] Fix get_llvm_lit_path() to respect LLVM_EXTERNAL_LIT always

2019-01-28 Thread Stefan Gränitz via Phabricator via lldb-commits
sgraenitz accepted this revision. sgraenitz added a comment. This revision is now accepted and ready to land. LGTM CHANGES SINCE LAST ACTION https://reviews.llvm.org/D57282/new/ https://reviews.llvm.org/D57282 ___ lldb-commits mailing list lldb-c

[Lldb-commits] [PATCH] D56904: [NativePDB] Process virtual bases in the correct order

2019-01-28 Thread Aleksandr Urakov via Phabricator via lldb-commits
aleksandr.urakov added a comment. Ping! Can you take a look, please? Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D56904/new/ https://reviews.llvm.org/D56904 ___ lldb-commits mailing list lldb-commits@lists.llvm.or

[Lldb-commits] [PATCH] D56126: [NativePDB] Add basic support of methods recostruction in AST

2019-01-28 Thread Aleksandr Urakov via Phabricator via lldb-commits
aleksandr.urakov added a comment. Ping! Can you take a look, please? CHANGES SINCE LAST ACTION https://reviews.llvm.org/D56126/new/ https://reviews.llvm.org/D56126 ___ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/c

[Lldb-commits] [PATCH] D55318: [Expressions] Add support of expressions evaluation in some object's context

2019-01-28 Thread Aleksandr Urakov via Phabricator via lldb-commits
aleksandr.urakov updated this revision to Diff 183816. aleksandr.urakov added a comment. Herald added a reviewer: serge-sans-paille. Sorry for the long delay with reply. My colleague with a Mac (and Obj-C knowledge) have created the test for the Obj-C case. Can you take a look, please? Reposit

[Lldb-commits] [PATCH] D57275: [testsuite] Remove seven dependency

2019-01-28 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. +1 for keeping seven.py. Anything that moves code out of dotest.py is a good thing. Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D57275/new/ https://reviews.llvm.org/D57275 ___ lldb-commits

[Lldb-commits] [PATCH] D57273: Make Type::GetByteSize optional

2019-01-28 Thread Pavel Labath via Phabricator via lldb-commits
labath accepted this revision. labath added a comment. This revision is now accepted and ready to land. Looks fine to me. I guess this would be the place I'd start thinking about an `OptionalSize` class (to replace the two fields in the Type class). But I don't think that's necessary yet... C

[Lldb-commits] [PATCH] D54617: [Reproducers] Add file provider

2019-01-28 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. I don't have any major issues with this patch. The thing I'd like to see though is one test which uses a path with `..` components and symlinks. If nothing else, it would serve as a good documentation for how these are supposed to be handled. Comment

[Lldb-commits] [PATCH] D56822: [Reproducers] Tool to insert SBReproducer macros

2019-01-28 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. Is this ready for review now? Comment at: tools/sbrepro/SBRepro.cpp:98 + +static std::string GetRegisterConstructorMacroMacro(StringRef Class, +StringRef Signature) { `MacroMacro`? CH