Author: jmolenda
Date: Fri Aug 14 21:59:42 2015
New Revision: 245151
URL: http://llvm.org/viewvc/llvm-project?rev=245151&view=rev
Log:
Update DynamicRegisterInfo::SetRegisterInfo to accept eh_frame register
numbers in the key name "ehframe" or "eh_frame" in addition to the deprecated
"gcc" name (e
Author: jmolenda
Date: Fri Aug 14 20:21:01 2015
New Revision: 245141
URL: http://llvm.org/viewvc/llvm-project?rev=245141&view=rev
Log:
A messy bit of cleanup: Move towards more descriptive names
for eh_frame and stabs register numberings. This is not
complete but it's a step in the right directio
dawn added a comment.
See inline comments.
Comment at: source/Commands/CommandObjectExpression.cpp:308
@@ -307,3 @@
-else
-options.SetLanguage(target->GetLanguage());
-
Why was this removed? Doesn't this break the intent of the target.langua
Author: jmolenda
Date: Fri Aug 14 19:09:23 2015
New Revision: 245130
URL: http://llvm.org/viewvc/llvm-project?rev=245130&view=rev
Log:
There is no such thing as gdb_arm_f8, this register set is f0-f7.
Remove this entry and adjust the numbering for the rest of the arm
register definitions.
Modifi
Author: ovyalov
Date: Fri Aug 14 18:57:15 2015
New Revision: 245129
URL: http://llvm.org/viewvc/llvm-project?rev=245129&view=rev
Log:
Fix Android build.
Modified:
lldb/trunk/source/Plugins/SymbolFile/DWARF/SymbolFileDWARFDebugMap.h
Modified: lldb/trunk/source/Plugins/SymbolFile/DWARF/Symbol
paulherman created this revision.
paulherman added reviewers: clayborg, sivachandra, spyffe.
paulherman added a subscriber: lldb-commits.
Consider having a global variable 'a' and a static variable with the same name
inside a class. This resolves the arbitrary choice when resolving the name 'a'.
Author: zturner
Date: Fri Aug 14 18:29:32 2015
New Revision: 245128
URL: http://llvm.org/viewvc/llvm-project?rev=245128&view=rev
Log:
Enable settings test for i686 as well as i386.
Modified:
lldb/trunk/test/settings/TestSettings.py
Modified: lldb/trunk/test/settings/TestSettings.py
URL:
htt
Author: zturner
Date: Fri Aug 14 18:29:24 2015
New Revision: 245127
URL: http://llvm.org/viewvc/llvm-project?rev=245127&view=rev
Log:
Make skipUnlessArch decorator actually skip instead of XFAIL.
Modified:
lldb/trunk/test/lldbtest.py
Modified: lldb/trunk/test/lldbtest.py
URL:
http://llvm.or
Author: zturner
Date: Fri Aug 14 18:29:17 2015
New Revision: 245126
URL: http://llvm.org/viewvc/llvm-project?rev=245126&view=rev
Log:
XFAIL some data formatter tests on Windows.
Fixing these bugs is tracked by http://llvm.org/pr24462.
Modified:
lldb/trunk/test/functionalities/data-formatter
Author: zturner
Date: Fri Aug 14 18:28:49 2015
New Revision: 245125
URL: http://llvm.org/viewvc/llvm-project?rev=245125&view=rev
Log:
Disable libstdc++ and libcxx data formatter tests on Windows.
Neither of these libraries has been ported to Windows. Eventually
if they are ever ported we can re-
chaoren accepted this revision.
This revision is now accepted and ready to land.
Comment at: test/lldbtest.py:943
@@ -947,1 +942,3 @@
+def skipUnlessArch(archlist):
+def myImpl(func):
zturner wrote:
> chaoren wrote:
> > Is there a reason
> > ```
> > return u
Author: gclayton
Date: Fri Aug 14 18:16:12 2015
New Revision: 245122
URL: http://llvm.org/viewvc/llvm-project?rev=245122&view=rev
Log:
Unbreak the windows and linux buildbots.
Modified:
lldb/trunk/source/Plugins/SymbolFile/DWARF/SymbolFileDWARF.h
Modified: lldb/trunk/source/Plugins/SymbolFi
Author: gclayton
Date: Fri Aug 14 18:15:48 2015
New Revision: 245121
URL: http://llvm.org/viewvc/llvm-project?rev=245121&view=rev
Log:
Don't crash if we don't have a type system for a language.
Modified:
lldb/trunk/source/Plugins/SymbolFile/DWARF/SymbolFileDWARF.cpp
Modified: lldb/trunk/sou
clayborg accepted this revision.
clayborg added a comment.
This revision is now accepted and ready to land.
Looks good.
http://reviews.llvm.org/D12043
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/li
zturner updated this revision to Diff 32195.
zturner added a comment.
Remove unicode byte-order-marks from python files
http://reviews.llvm.org/D12043
Files:
test/functionalities/expr-doesnt-deadlock/Makefile
test/functionalities/expr-doesnt-deadlock/TestExprDoesntBlock.py
test/functional
zturner created this revision.
zturner added reviewers: clayborg, jingham.
zturner added a subscriber: lldb-commits.
This eliminates portability issues among platforms that don't have a pthreads
implementation.
There was one situation in TestTlsGlobals.py where it seems the intention is to
comp
zturner added inline comments.
Comment at: test/lldbtest.py:943
@@ -947,1 +942,3 @@
+def skipUnlessArch(archlist):
+def myImpl(func):
chaoren wrote:
> Is there a reason
> ```
> return unittest2.skipUnless(getArchitecture() in archlist, ...)
> ```
> is not su
chaoren added inline comments.
Comment at: test/lldbtest.py:943
@@ -947,1 +942,3 @@
+def skipUnlessArch(archlist):
+def myImpl(func):
Is there a reason
```
return unittest2.skipUnless(getArchitecture() in archlist, ...)
```
is not sufficient?
Also, please a
Author: ovyalov
Date: Fri Aug 14 16:16:00 2015
New Revision: 245100
URL: http://llvm.org/viewvc/llvm-project?rev=245100&view=rev
Log:
Fix Linux build after r245090.
Modified:
lldb/trunk/source/Symbol/ClangASTContext.cpp
Modified: lldb/trunk/source/Symbol/ClangASTContext.cpp
URL:
http://llvm
zturner created this revision.
zturner added a reviewer: chaoren.
zturner added a subscriber: lldb-commits.
http://reviews.llvm.org/D12039
Files:
test/lldbtest.py
Index: test/lldbtest.py
===
--- test/lldbtest.py
+++ test/lldbtest.
paulherman added a comment.
This patch does exactly that. It detects the language of the frame and upgrades
it according to the rules you said (I think I might've missed ObjC -> ObjC++,
but that can be added).
Regarding the global setting of ObjC, I believe it is not helpful. What I mean
is, w
spyffe added a subscriber: spyffe.
spyffe added a comment.
I totally agree that Objective-C shouldn’t be part of the default on non-Apple
platforms.
The way I imagine this working is that your current frame’s language gets
“upgraded” – for the Clang expression parser, at least to something that
Is Objective C++ even a thing on non-Apple platforms? I dont' think we
should be forcing a default *anything* to a language that only exists on a
subset of supported platforms. But even ignoring that, I don't think
preferential treatment should be given to any particular language.
If there is go
dawn added a comment.
Hi Paul,
Some background... I basically tried the same thing in my original
http://reviews.llvm.org/D11102 and http://reviews.llvm.org/D11173. In light of
Sean's objections in http://reviews.llvm.org/D11173, I created
http://reviews.llvm.org/D11482 which used an option
dawn added a comment.
Hi Sean,
In http://reviews.llvm.org/D11790#221730, @spyffe wrote:
> Ooh, I'm reading the patch at the beginning of ClangUserExpression::Evaluate
> again and it does look like this patch sets language based on the language of
> the containing frame, and that affects what l
Author: gclayton
Date: Fri Aug 14 13:18:07 2015
New Revision: 245078
URL: http://llvm.org/viewvc/llvm-project?rev=245078&view=rev
Log:
Don't test the output of "target modules dump symfile a.out" as this isn't
something we should be testing for. This makes this test pass again.
Modified:
ll
Sure, if Greg approves.
Thanks,
Hans
On Thu, Aug 13, 2015 at 11:25 PM, Bhushan Attarde
wrote:
> Hi Hans,
>
> Could you please merge this to the release branch?
>
> Thanks
> Bhushan
>
>
> -Original Message-
> From: lldb-commits [mailto:lldb-commits-boun...@lists.llvm.org] On Behalf Of
>
Author: zturner
Date: Fri Aug 14 11:45:32 2015
New Revision: 245066
URL: http://llvm.org/viewvc/llvm-project?rev=245066&view=rev
Log:
Update dosep to print unexpected successes at the end.
Modified:
lldb/trunk/test/dosep.py
Modified: lldb/trunk/test/dosep.py
URL:
http://llvm.org/viewvc/llvm
Author: yrnkrn
Date: Thu Aug 13 13:48:44 2015
New Revision: 244936
URL: http://llvm.org/viewvc/llvm-project?rev=244936&view=rev
Log:
Remove more uses of raw_svector_ostream::flush() call following r244928.
Modified:
lldb/trunk/source/Host/macosx/HostInfoMacOSX.mm
lldb/trunk/source/Plugin
Author: yrnkrn
Date: Thu Aug 13 13:42:29 2015
New Revision: 244935
URL: http://llvm.org/viewvc/llvm-project?rev=244935&view=rev
Log:
Remove raw_svector_ostream::flush() call following r244928.
Modified:
lldb/trunk/source/Host/posix/HostInfoPosix.cpp
Modified: lldb/trunk/source/Host/posix/Ho
ovyalov added a comment.
In http://reviews.llvm.org/D12025#224355, @tberghammer wrote:
> The implementation looks good, but I don't like the approach you try to
> handle the problem.
>
> I think you do far too much work to use UriParser in a case where it isn't
> necessary and isn't make things
tberghammer accepted this revision.
tberghammer added a comment.
LGTM
http://reviews.llvm.org/D11987
___
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits
tberghammer added a comment.
The implementation looks good, but I don't like the approach you try to handle
the problem.
I think you do far too much work to use UriParser in a case where it isn't
necessary and isn't make things easier. I think a better (and definitely
simpler) solution would b
33 matches
Mail list logo