Fix passing zero to 'PTR_ERR' warning
Signed-off-by: Wang Qing
---
drivers/crypto/caam/caamalg_qi.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/crypto/caam/caamalg_qi.c b/drivers/crypto/caam/caamalg_qi.c
index 66f60d7..add60e8
--- a/drivers/crypto/caam/caamalg_qi.
The return value of qat_hal_rd_ae_csr() is always a CSR value and never
a status and should not be stored in the status variable of
qat_hal_put_rel_rd_xfer().
This removes the assignment as qat_hal_rd_ae_csr() is not expected to
fail.
A more comprehensive handling of the theoretical corner case wh
Remove unnecessary parenthesis across the firmware loader.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
drivers/crypto/qat/qat_common/qat_hal.c | 6 +++---
drivers/crypto/qat/qat_common/qat_uclo.c | 16 -
Rework firmware loader in QAT driver in preparation for the support of the
qat_4xxx driver.
Patch #1 add support for the mof format in the firmware loader
Patches from #2 to #7 introduce some general fixes
Patches from #8 to #30 rework and refactor the firmware loader to support the
new features
From: Giovanni Cabiddu
Implement infrastructure for the Multiple Object File (MOF) format
in the firmware loader. This will allow to load a specific firmware
image contained inside an MOF file.
This patch is based on earlier work done by Pingchao Yang.
Signed-off-by: Giovanni Cabiddu
Reviewed-
Introduce additional parenthesis to resolve a warninga reported by
checkpatch.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
drivers/crypto/qat/qat_common/icp_qat_hal.h | 14 +++---
drivers/crypto/qat/qat_commo
Change the API and the behaviour of the qat_hal_start() function.
With this change, the function starts under the hood all acceleration
engines (AEs) and there is no longer need to call it for each engine.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Re
Change micro word data mask since the Acceleration Engine (AE)
instruction codes have been changed in the new generation QAT devices.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
drivers/crypto/qat/qat_common/qat_uclo
Move the definition of ICP_QAT_AE_OFFSET, ICP_QAT_CAP_OFFSET,
LOCAL_TO_XFER_REG_OFFSET and ICP_QAT_EP_OFFSET from qat_hal.c to
icp_qat_hal.h to avoid the definition of generation specific constants
in qat_hal.c.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziem
Include the offset of GLOBAL_CSR directly into the enum hal_global_csr
and remove the macros SET_GLB_CSR/GET_GLB_CSR to simplify the global CSR
access.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
drivers/crypto/qat/q
Change type for ctx_mask from unsigned char to unsigned long to avoid
type casting.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
drivers/crypto/qat/qat_common/adf_common_drv.h | 8
drivers/crypto/qat/qat_com
Add support for local memory lm2 and lm3 which is introduced in the next
generation of QAT devices.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
.../crypto/qat/qat_common/adf_common_drv.h| 2 +
.../qat/qat_common
Do not mask the AE number with the AE mask when accessing the AE local
CSRs. Bit 12 of the local CSR address is the start of AE number so just
take out the AE mask here.
Signed-off-by: Jack Xu
Reviewed-by: Giovanni Cabiddu
---
drivers/crypto/qat/qat_common/icp_qat_hal.h | 6 ++
1 file chang
Rename the function qat_uclo_del_uof_obj() in qat_uclo_del_obj() since
it frees the memory allocated for all firmware objects.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
drivers/crypto/qat/qat_common/adf_accel_engin
Change message in error path of qat_uclo_check_image_compat() to report
an incompatible firmware image that contains a neighbor register table.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
drivers/crypto/qat/qat_commo
Add the local memory size to the chip info since the size of this memory
will be different in the next generation of QAT devices.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
drivers/crypto/qat/qat_common/icp_qat_fw_l
Improve the way micro instructions (FW code) are uploaded to Accelerator
Engines (AEs). If code starts at PC zero (absolute addressing), read
uwords with no relative address. Otherwise, use relative addressing to
the page region.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off
Add global clock enable CSR to the chip info since the CSR offset
will be different in the next generation of QAT devices.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
.../crypto/qat/qat_common/icp_qat_fw_loader_handl
Add reset CSR offset and mask to chip info since they are different
in new QAT devices. This also simplifies the reset/clrReset functions
by using the reset mask.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
.../qat/q
Add the wake up event to chip info since this value will be different
in the next generation of QAT devices.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
drivers/crypto/qat/qat_common/icp_qat_fw_loader_handle.h | 1 +
Replace long expressions with local variables in the functions
qat_uclo_wr_uimage_page(), qat_uclo_init_globals() and
qat_uclo_init_umem_seg() to improve readability.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
drive
Introduce the chip info structure which contains device specific
information. The initialization path has been split between common and
hardware specific in order to facilitate the introduction of the next
generation hardware.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by
Refactor qat_uclo_set_ae_mode() by moving the logic that sets the AE
modes to a separate function, qat_hal_set_modes().
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
drivers/crypto/qat/qat_common/qat_uclo.c | 69 ++
Modify condition in qat_uclo_wr_mimage() to use a capability of the
device (sram_visible), rather than the device ID, so the check is not
specific to devices of the same type.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
-
Introduce the next neighbor (NN) capability in chip_info as NN registers
are not supported in certain SKUs of QAT.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
.../crypto/qat/qat_common/icp_qat_fw_loader_handle.h | 1
Add support for shared ustore mode support. This is required by the next
generation of QAT devices to share the same fw image across engines.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
.../qat/qat_common/icp_qat_fw_
Add support for the QAT gen4 devices in the firmware loader.
Signed-off-by: Jack Xu
Reviewed-by: Giovanni Cabiddu
---
.../crypto/qat/qat_common/adf_accel_devices.h | 2 +
drivers/crypto/qat/qat_common/icp_qat_hal.h | 12 ++-
drivers/crypto/qat/qat_common/icp_qat_uclo.h | 2 +
drivers/crypt
Add null pointer check when freeing the memory for firmware.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
---
drivers/crypto/qat/qat_common/qat_uclo.c | 28 ++--
1 file changed, 17 insertions(+), 11 deletions(-)
diff --git a/driver
Add support for broadcasting mode in firmware loader to enable the next
generation of QAT devices.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
.../qat/qat_common/icp_qat_fw_loader_handle.h | 1 +
drivers/crypto/qat/
Use ae_mask to decide which Accelerator Engine (AE) to target in AE
related operations, instead of a sequential loop, to skip AEs that are
fused out.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
drivers/crypto/qat/qat
Add misc control CSR to chip info since the CSR offset will be different
in the next generation of QAT devices.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
.../crypto/qat/qat_common/icp_qat_fw_loader_handle.h | 1 +
Add firmware control unit (FCU) CSRs to chip info so the firmware
authentication code is common between all devices.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
.../qat/qat_common/icp_qat_fw_loader_handle.h | 6 +++
Introduce new API, qat_uclo_set_cfg_ae_mask(), to allow the load of the
firmware image to a subset of Acceleration Engines (AEs). This is
required by the next generation of QAT devices to be able to load
different firmware images to the device.
Signed-off-by: Jack Xu
Reviewed-by: Giovanni Cabiddu
Add support for CSS3K, which uses RSA3K as image signature algorithm,
to support the next generation of QAT devices.
Signed-off-by: Jack Xu
Co-developed-by: Wojciech Ziemba
Signed-off-by: Wojciech Ziemba
Reviewed-by: Giovanni Cabiddu
---
.../qat/qat_common/icp_qat_fw_loader_handle.h | 1 +
d
Based on lessons learnt from optimizing the 32-bit version of this driver,
we can simplify the arm64 version considerably, by reordering the final
two stores when the last block is not a multiple of 64 bytes. This removes
the need to use permutation instructions to calculate the elements that are
c
On 11/3/20 1:05 AM, Nick Terrell wrote:
From: Nick Terrell
Move away from the compatibility wrapper to the zstd-1.4.6 API. This
code is functionally equivalent.
Signed-off-by: Nick Terrell
---
fs/btrfs/zstd.c | 48
1 file changed, 28 inserti
On 11/3/20 1:05 AM, Nick Terrell wrote:
From: Nick Terrell
Please pull from
g...@github.com:terrelln/linux.git tags/v5-zstd-1.4.6
to get these changes. Alternatively the patchset is included.
Where did we come down on the code formatting question? Personally I'm of the
mind that as lo
> On Nov 6, 2020, at 9:10 AM, Josef Bacik wrote:
>
> On 11/3/20 1:05 AM, Nick Terrell wrote:
>> From: Nick Terrell
>> Move away from the compatibility wrapper to the zstd-1.4.6 API. This
>> code is functionally equivalent.
>> Signed-off-by: Nick Terrell
>> ---
>> fs/btrfs/zstd.c | 48 +++
You just keep resedning this crap, don't you? Haven't you been told
multiple times to provide a proper kernel API by now?
On Mon, Nov 02, 2020 at 10:05:27PM -0800, Nick Terrell wrote:
> From: Nick Terrell
>
> Adds zstd_compat.h which provides the necessary functions from the
> current zstd.h AP
> On Nov 6, 2020, at 9:15 AM, Josef Bacik wrote:
>
> On 11/3/20 1:05 AM, Nick Terrell wrote:
>> From: Nick Terrell
>> Please pull from
>> g...@github.com:terrelln/linux.git tags/v5-zstd-1.4.6
>> to get these changes. Alternatively the patchset is included.
>
> Where did we come down on the co
Right now, all new ZIP drivers are adapted to crypto_acomp APIs rather
than legacy crypto_comp APIs. Tradiontal ZIP drivers like lz4,lzo etc
have been also wrapped into acomp via scomp backend. But zswap.c is still
using the old APIs. That means zswap won't be able to work on any new
ZIP drivers in
41 matches
Mail list logo