chandlerc added a comment.
(Just a reminder that we need to have both performance and code size numbers
for this patch. And given that there are a few options, may need a few
examples.)
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D70157/new/
https://reviews.llvm.org/D70157
___
chandlerc accepted this revision.
chandlerc added a comment.
This revision is now accepted and ready to land.
Minor nits around redundant predicates for SROA. With thouse fixed, LGTM.
I'd really love to find a way to make TCO debuggable so that we don't lose
that. I'm particularly worried about
chandlerc added a comment.
I'm seeing lots of updates to fix bugs, but no movement for many days on both
my meta comments and (in some ways more importantly) James's meta comments.
(And thanks Philip for chiming in too!)
Meanwhile, we really, really need to get this functionality in place. The
chandlerc added a comment.
Just wanted to say thanks for the performance data! I know it was hard to get,
but it is really, really useful to help folks evaluate these kinds of changes
with actual data around the options available.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D70157/new
chandlerc added a comment.
Can we add an LLVM test w/ the metadata so that we have an entirely LLVM test
flow that ensures the pass builder DTRT?
(I still would include the Clang side test which is also very useful to test
integrating Clang w/ different flows through the pass manager.)
Reposi
chandlerc resigned from this revision.
chandlerc added a comment.
I think this is more a question for Richard... Add me back to the reviewers if
there is a specific need for my input here.
Repository:
rC Clang
https://reviews.llvm.org/D43871
___
chandlerc requested changes to this revision.
chandlerc added a comment.
This revision now requires changes to proceed.
Just a question really.
Comment at: clang/CMakeLists.txt:215
+set(ENABLE_EXPERIMENTAL_NEW_PASS_MANAGER FALSE CACHE BOOL
+ "Enable the experimental new pass
chandlerc resigned from this revision.
chandlerc added a comment.
Since this seems not going anywhere, removing it from my review dashboard.
Repository:
rC Clang
https://reviews.llvm.org/D42787
___
cfe-commits mailing list
cfe-commits@lists.llvm.
chandlerc accepted this revision.
chandlerc added a comment.
Just wanted to explicitly say +1 to this default change (with the adjustment
Richard suggested).
Also, John already said +1 to this default change on the bug.
Repository:
rC Clang
https://reviews.llvm.org/D45289
___
chandlerc accepted this revision.
chandlerc added a comment.
This revision is now accepted and ready to land.
Meh, I think this is fine as-is.
Repository:
rC Clang
https://reviews.llvm.org/D44330
___
cfe-commits mailing list
cfe-commits@lists.llv
chandlerc added a comment.
So, doing research to understand the impact of this has convinced me we
*really* need to stop doing this. Multiple libraries are actually trying to
enumerate every CPU that has feature X for some feature X. =[[[ This, combined
with the fundamental pattern of defining
chandlerc accepted this revision.
chandlerc added a comment.
This revision is now accepted and ready to land.
LGTM, nice.
https://reviews.llvm.org/D39349
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/l
chandlerc added a comment.
In https://reviews.llvm.org/D38824#908540, @RKSimon wrote:
> Where is the best place to document this policy so people have a chance of
> understanding it going forward?
Given the (apparent) amount of confusion here, I'd suggest a dedicated document
in Clang's docum
chandlerc accepted this revision.
chandlerc added a comment.
This revision is now accepted and ready to land.
LGTM, nice catch!
Maybe update one of the new PM tests to check that this debug printing is
available? =D
https://reviews.llvm.org/D40007
___
This revision was automatically updated to reflect the committed changes.
Closed by commit rL290159: Fix the spelling of 'bitfield' in diagnostics to be
consistently 'bit-field'. (authored by chandlerc).
Changed prior to commit:
https://reviews.llvm.org/D26530?vs=81008&id=82055#toc
Repository:
chandlerc created this revision.
chandlerc added reviewers: rsmith, mehdi_amini.
chandlerc added a subscriber: cfe-commits.
Herald added a subscriber: mcrosier.
Much to my surprise, '-disable-llvm-optzns' which I thought was the
magical flag I wanted to get at the raw LLVM IR coming out of Clang
d
chandlerc created this revision.
chandlerc added reviewers: rsmith, rnk, mehdi_amini.
chandlerc added a subscriber: cfe-commits.
chandlerc added a dependency: D28047: Remove the '-disable-llvm-passes' flag
(which I didn't even know existed, and I suspect many others aren't aware of
either) and st
chandlerc added a comment.
In https://reviews.llvm.org/D28047#629824, @mehdi_amini wrote:
> In https://reviews.llvm.org/D28047#629746, @rnk wrote:
>
> > How about standardizing on -disable-llvm-passes instead of
> > -disable-llvm-optzns? I never liked "optzns" and can't remember how to
> > spel
chandlerc added a comment.
In https://reviews.llvm.org/D28053#629830, @mehdi_amini wrote:
> > It would be awesome if attribute sets were a bit more FileCheck friendly,
> > but oh well.
>
> I've been wondering about that, what's the point of attribute sets in the
> textual IR?
> I understand th
chandlerc updated this revision to Diff 82356.
chandlerc added a comment.
Herald added a subscriber: wdng.
Fix an thinko found in review, clean up comments, and clean up pass pipeline
selection as that actually needs to happen in this patch as well.
Also update one test using -O1 and observing th
chandlerc added a comment.
In https://reviews.llvm.org/D28053#629834, @mehdi_amini wrote:
> In https://reviews.llvm.org/D28053#629768, @rnk wrote:
>
> > The big change here is that `clang -O0` now applies the noinline attribute
> > everywhere. I can see why someone might expect things to work th
chandlerc added a comment.
In https://reviews.llvm.org/D28047#629892, @mehdi_amini wrote:
> LGTM, but please wait for @rnk to confirm :)
>
> Also any opinion about a driver option -emit-raw-llvm as @joerg suggested?
I like the idea generally, but I don't have an immediate use case and would
d
This revision was automatically updated to reflect the committed changes.
Closed by commit rL290392: Make '-disable-llvm-optzns' an alias for
'-disable-llvm-passes'. (authored by chandlerc).
Changed prior to commit:
https://reviews.llvm.org/D28047?vs=82313&id=82383#toc
Repository:
rL LLVM
h
This revision was automatically updated to reflect the committed changes.
Closed by commit rL290398: Cleanup the handling of noinline function
attributes, -fno-inline, (authored by chandlerc).
Changed prior to commit:
https://reviews.llvm.org/D28053?vs=82356&id=82390#toc
Repository:
rL LLVM
chandlerc created this revision.
chandlerc added reviewers: rsmith, mehdi_amini.
chandlerc added a subscriber: cfe-commits.
chandlerc added a dependency: D28076: [PM] Add support for building a default
AA pipeline to the PassBuilder..
Herald added a subscriber: mcrosier.
The option is actually a
chandlerc marked 4 inline comments as done.
chandlerc added a comment.
Thanks for the review, will land shortly with suggested fixes.
Comment at: lib/CodeGen/BackendUtil.cpp:757
+ setCommandLineOpts();
+ cl::PrintOptionValues();
+
mehdi_amini wrote:
> This is
This revision was automatically updated to reflect the committed changes.
chandlerc marked 4 inline comments as done.
Closed by commit rL290450: [PM] Introduce options to enable the (still
experimental) new pass (authored by chandlerc).
Changed prior to commit:
https://reviews.llvm.org/D28077?v
chandlerc accepted this revision.
chandlerc added a comment.
This revision is now accepted and ready to land.
LGTM
https://reviews.llvm.org/D28385
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo
chandlerc added inline comments.
Comment at: clang/lib/CodeGen/CGOpenMPRuntime.cpp:760-762
Fn->removeFnAttr(llvm::Attribute::NoInline);
+ Fn->removeFnAttr(llvm::Attribute::OptimizeNone);
Fn->addFnAttr(llvm::Attribute::AlwaysInline);
At point where we are i
chandlerc added inline comments.
Comment at: clang/lib/CodeGen/CodeGenModule.cpp:910-912
// OptimizeNone wins over OptimizeForSize and MinSize.
F->removeFnAttr(llvm::Attribute::OptimizeForSize);
F->removeFnAttr(llvm::Attribute::MinSize);
mehdi_amin
chandlerc requested changes to this revision.
chandlerc added a comment.
This revision now requires changes to proceed.
There are some issues with this patch currently.
At a basic level, it needs well crafted test cases. You can find out how to
write them by looking at other Driver tests.
But a
chandlerc added a comment.
In https://reviews.llvm.org/D28404#640862, @probinson wrote:
> In https://reviews.llvm.org/D28404#640682, @mehdi_amini wrote:
>
> > > I'm now thinking along the lines of a `-foptimize-off` flag (bikesheds
> > > welcome) which would set the default for the pragma to 'of
chandlerc added a comment.
In https://reviews.llvm.org/D26244#641076, @Hahnfeld wrote:
> This change doesn't break existing tests but maybe I should extend
> `linux-ld.c` and so on?
>
> About the impact: Which libraries are there next to clang that could conflict
> with the system? When I look
chandlerc added a comment.
In https://reviews.llvm.org/D28404#641696, @mehdi_amini wrote:
> In https://reviews.llvm.org/D28404#641632, @probinson wrote:
>
> > In https://reviews.llvm.org/D28404#641606, @mehdi_amini wrote:
> >
> > > If we want to support `-O0 -flto` and `optnone` it the way to con
chandlerc added a comment.
Ping?
https://reviews.llvm.org/D30806
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
chandlerc added inline comments.
Comment at: include/clang/AST/ASTContext.h:1868
+ bool *OverrideNonnullReturn = nullptr,
+ unsigned *OverrideNonnullArgs = nullptr,
unsigned *IntegerConstantArgs = nullpt
chandlerc marked an inline comment as done.
chandlerc added a comment.
Function argument order fixed.
https://reviews.llvm.org/D30806
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
chandlerc updated this revision to Diff 92245.
chandlerc added a comment.
Update with fixes suggested in review.
https://reviews.llvm.org/D30806
Files:
include/clang/AST/ASTContext.h
include/clang/Basic/Builtins.def
lib/AST/ASTContext.cpp
lib/CodeGen/CGCall.cpp
test/CodeGen/nonnull.c
chandlerc added a reviewer: EricWF.
chandlerc added a comment.
This seems good to me. Check with Eric to see if we try to test this any any
specific way?
https://reviews.llvm.org/D28478
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http:/
chandlerc added inline comments.
Comment at: include/clang/Format/Format.h:993
+ /// inside ``IncludeCategories``.
+ bool IncludeRegexCaseInsensitive;
+
djasper wrote:
> Do we really need a flag here? Shouldn't we just always do this?
I have no opinion one way
chandlerc added inline comments.
Comment at: clang/lib/CodeGen/BackendUtil.cpp:804-807
+ case 0:
+return PassBuilder::O0;
+
case 1:
Why is this change needed?
Comment at: clang/lib/CodeGen/BackendUtil.cpp:885-886
if (CodeGenOpts.Op
chandlerc added inline comments.
Comment at: llvm/test/Other/new-pm-thinlto-defaults.ll:157
; CHECK-PRELINK-O-NEXT: Running pass: GlobalOptPass
-; CHECK-PRELINK-O-NEXT: Running pass: NameAnonGlobalPass
; CHECK-POSTLINK-O-NEXT: Running pass: PassManager<{{.*}}Module{{.*}}>
-
chandlerc updated this revision to Diff 104471.
chandlerc added a comment.
Update based an Daniel's feedback.
https://reviews.llvm.org/D33932
Files:
include/clang/Format/Format.h
lib/Format/Format.cpp
unittests/Format/SortIncludesTest.cpp
Index: unittests/Format/SortIncludesTest.cpp
===
chandlerc added a comment.
In https://reviews.llvm.org/D33932#793994, @djasper wrote:
> Just make clang-format always do this. I don't think anyone is relying on the
> current behavior.
Done, PTAL.
https://reviews.llvm.org/D33932
___
cfe-commits
chandlerc accepted this revision.
chandlerc added a comment.
This revision is now accepted and ready to land.
LGTM as well.
https://reviews.llvm.org/D34728
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman
chandlerc added inline comments.
Comment at: clang/include/clang/Driver/Options.td:971-973
+def fexperimental_new_pass_manager_EQ : Joined<["-"],
"fexperimental-new-pass-manager=">,
+ Group, Flags<[CC1Option]>,
+ HelpText<"Enables an experimental new pass manager in LLVM.">,
chandlerc added a comment.
This looks great to me with a CC1-layer flag. But check that others are happy
as well, thanks!
https://reviews.llvm.org/D34790
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/
chandlerc added a comment.
Already said LGTM, please go ahead and submit. If tehre are further requsets,
we can always amke follow-up changes.
Repository:
rL LLVM
https://reviews.llvm.org/D34728
___
cfe-commits mailing list
cfe-commits@lists.llv
chandlerc accepted this revision.
chandlerc added a comment.
LGTM too, but no need to wait for me to land this. =D
https://reviews.llvm.org/D34721
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo
This revision was automatically updated to reflect the committed changes.
Closed by commit rL306759: [clang-format] Switch to case-insensitive header
matching and use it to (authored by chandlerc).
Repository:
rL LLVM
https://reviews.llvm.org/D33932
Files:
cfe/trunk/include/clang/Format/For
chandlerc created this revision.
Herald added subscribers: mcrosier, sanjoy, rengolin.
Given the long time for which this path has been unused, off by default,
and unnecessary this completely removes the flags. If users are deeply
concerned about the commandline compatibility, they can be added ba
chandlerc updated this revision to Diff 104775.
chandlerc added a comment.
Remove the rest of the flag handling that I missed the first time grepping
through...
https://reviews.llvm.org/D34846
Files:
include/clang/Driver/CC1Options.td
include/clang/Driver/Options.td
include/clang/Fronten
chandlerc requested review of this revision.
chandlerc added a comment.
In https://reviews.llvm.org/D34846#796102, @rsmith wrote:
> Removing a `-cc1` flag is OK: we explicitly tell people that the `-cc1`
> interface is subject to change without notice.
What do you think about this now that it
This revision was automatically updated to reflect the committed changes.
Closed by commit rL306786: Remove Clang support for
'-fvectorize-slp-aggressive' which used LLVM's (authored by chandlerc).
Repository:
rL LLVM
https://reviews.llvm.org/D34846
Files:
cfe/trunk/include/clang/Driver/CC1
chandlerc added inline comments.
Comment at: lib/CodeGen/BackendUtil.cpp:843
PGOOptions PGOOpt;
Maybe make this an optional to avoid the big predicate below?
Comment at: lib/CodeGen/BackendUtil.cpp:847-859
if (PGOOpt.RunProfileGen)
chandlerc added a comment.
(Also, sorry for the delay reviewing this, for some reason I thought this
already got reviewed and landed...)
https://reviews.llvm.org/D35746
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/c
chandlerc accepted this revision.
chandlerc added a comment.
This revision is now accepted and ready to land.
LGTM with a tiny tweak below.
Would be good to add a test that this flag is being honored, either in this
patch or in a follow-up.
Comment at: lib/CodeGen/BackendUtil
chandlerc added a comment.
Just to be explicit, I agree with Hal's summary. This seems like the right
engineering tradeoff and I don't find anything particularly unsatisfying about
it.
In https://reviews.llvm.org/D28404#675616, @mehdi_amini wrote:
> Also note that @chandlerc in r290398 made cl
chandlerc created this revision.
Herald added a subscriber: mcrosier.
This follows the design direction discussed on cfe-dev here:
http://lists.llvm.org/pipermail/cfe-dev/2017-January/052066.html
The idea is that for C standard library builtins, even if the library
vendor chooses to annotate thei
chandlerc added a comment.
In https://reviews.llvm.org/D30806#697372, @ahatanak wrote:
> Are users allowed to call these routines with a null pointer and a non-zero
> size? Or can we assume that if the size is known to be non-zero at compile
> time, the pointers are not null?
If the sizes are
chandlerc added inline comments.
Comment at: lib/AST/ASTContext.cpp:8786
+if (OverrideNonnull && OverrideNonnullArgs)
+ *OverrideNonnullArgs |= 1 << ArgTypes.size();
+
majnemer wrote:
> `1U` to avoid overflow UB?
I'd mildly prefer an assert (or rely on U
chandlerc updated this revision to Diff 91286.
chandlerc added a comment.
Update to fix subtle bugs in handling arguments. Thanks to David for the review
comments that caused me to see the issue here.
https://reviews.llvm.org/D30806
Files:
include/clang/AST/ASTContext.h
include/clang/Basic/
chandlerc updated this revision to Diff 81008.
chandlerc added a comment.
Rebase and ping? It'd be awesome to land this minor patch, its been out for a
month now.
https://reviews.llvm.org/D26530
Files:
include/clang/Basic/DiagnosticParseKinds.td
include/clang/Basic/DiagnosticSemaKinds.td
chandlerc accepted this revision.
chandlerc added a comment.
This revision is now accepted and ready to land.
Generally makes sense. A question about the name. Feel free to land with a name
that you and other sanitizer folks are happy with.
Comment at: include/clang/Driver/Opt
chandlerc added a comment.
What error are you trying to fix? We use flags without `.getValue()` all over
the place, I don't know why we would need to change that here.
Comment at: lib/Transforms/IPO/PassManagerBuilder.cpp:173
EnablePGOInstrGen = RunPGOInstrGen;
-PGOIn
chandlerc created this revision.
chandlerc added a reviewer: GMNGeoffrey.
Herald added a subscriber: mcrosier.
chandlerc requested review of this revision.
Herald added a reviewer: jdoerfert.
Herald added a subscriber: sstefan1.
This required substantially more invasive changes I'm afraid.
First,
501 - 566 of 566 matches
Mail list logo