jroelofs closed this revision.
jroelofs added a comment.
r299003
https://reviews.llvm.org/D31422
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
jroelofs added a comment.
The 0th build seems to have been successful:
http://lab.llvm.org:8011/builders/libunwind-sphinx-docs/builds/0
That being said, I did have to kick it off manually. I'll make a no-op change
later this afternoon, and see if the builder picks it up.
https://reviews.llvm.
jroelofs added inline comments.
Comment at: utils/libcxx/test/config.py:289
+def configure_availability(self):
+# FIXME doc
+self.with_availability = self.get_lit_bool('with_availability', False)
Can you expand on what the FIXME here wants? Is
jroelofs accepted this revision.
jroelofs added a comment.
This revision is now accepted and ready to land.
LGTM
Comment at: include/clang/Driver/Options.td:1613
def mcpu_EQ : Joined<["-"], "mcpu=">, Group;
+def mmcu_EQ : Joined<["-"], "mmcu=">, Group;
def mdynamic_no_pic : J
jroelofs created this revision.
These tests are breaking when tested under the upstream 3.8.1 release + the
10.12 / 16C58 sdk. They use headers from the host SDKs, so they are not stable
with respect to adding new language features, such as class `@properties`.
Regression tests should not depen
jroelofs accepted this revision.
jroelofs added a reviewer: jroelofs.
jroelofs added a comment.
This revision is now accepted and ready to land.
LGTM
https://reviews.llvm.org/D25314
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://list
jroelofs created this revision.
Herald added a subscriber: aemerson.
The idea for this originated from a really tricky bug: ISRs on ARM don't
automatically save off the VFP regs, so if say, memcpy gets interrupted and the
ISR itself calls memcpy, the regs are left clobbered when the ISR is done.
jroelofs added a comment.
In https://reviews.llvm.org/D28820#649384, @rengolin wrote:
> Seems like a very specific corner case on ARM, but is that attribute
> guaranteed to be ARM-only?
>
> If so, LGTM as is. If not, avoid mentioning "VFP" on the error message.
Yeah, the attribute is parsed in
jroelofs closed this revision.
jroelofs added a comment.
r292375
https://reviews.llvm.org/D28820
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
jroelofs added a comment.
In https://reviews.llvm.org/D28820#649726, @efriedma wrote:
> Why can't the compiler handle this case itself transparently? According to
> your description, the interrupt calling convention is different from the
> normal hard-float AAPCS calling convention: the VFP re
jroelofs added a comment.
In https://reviews.llvm.org/D28820#649738, @jroelofs wrote:
> In https://reviews.llvm.org/D28820#649726, @efriedma wrote:
>
> > Why can't the compiler handle this case itself transparently? According to
> > your description, the interrupt calling convention is differen
jroelofs added a comment.
In https://reviews.llvm.org/D28820#649770, @efriedma wrote:
> > There would be a big performance penalty for ISRs with callees that don't
> > use VFP regs.
>
> Sacrificing correctness for the sake of performance seems like a bad idea...
I don't quite see it that way,
jroelofs created this revision.
Herald added a subscriber: mgorny.
Mostly cargo-culted from libcxxabi, since the unwinder was forked from there in
the first place.
Might still be some cruft that's only applicable to libcxxabi in here, so let
me know if you spot anything like that. I killed some
jroelofs closed this revision.
jroelofs added a comment.
r307266
https://reviews.llvm.org/D35038
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
jroelofs accepted this revision.
jroelofs added inline comments.
This revision is now accepted and ready to land.
Comment at: lib/Driver/ToolChains/Fuchsia.cpp:134
+static std::string computeTriple(llvm::Triple Triple) {
+ SmallString<64> T;
`normalizeTriple`
jroelofs added inline comments.
Comment at: cmake/caches/Android-stage2.cmake:37
+ set(RUNTIMES_${target}-linux-android_COMPILER_RT_INCLUDE_TESTS OFF CACHE
BOOL "")
+ set(RUNTIMES_${target}-linux-android_LLVM_ENABLE_ASSERTIONS ON CACHE BOOL "")
+ set(RUNTIMES_${target}-linux-
jroelofs added inline comments.
Comment at: cmake/caches/Android-stage2.cmake:37
+ set(RUNTIMES_${target}-linux-android_COMPILER_RT_INCLUDE_TESTS OFF CACHE
BOOL "")
+ set(RUNTIMES_${target}-linux-android_LLVM_ENABLE_ASSERTIONS ON CACHE BOOL "")
+ set(RUNTIMES_${target}-linux-
jroelofs added inline comments.
Comment at: test/lit.cfg:36
+else:
+lit_config.fatal('Could not find libcxx test directory for test imports'
+ ' in: %s' % libcxx_test_src_root)
manojgupta wrote:
> I do not have libcxx checked out since I a
jroelofs added inline comments.
Comment at: test/lit.cfg:36
+else:
+lit_config.fatal('Could not find libcxx test directory for test imports'
+ ' in: %s' % libcxx_test_src_root)
manojgupta wrote:
> jroelofs wrote:
> > manojgupta wrote:
> >
jroelofs accepted this revision.
jroelofs added a comment.
This revision is now accepted and ready to land.
LGTM
https://reviews.llvm.org/D35426
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/c
jroelofs added inline comments.
Comment at: lib/StaticAnalyzer/Checkers/MmapWriteExecChecker.cpp:1
+// MmapWriteExecChecker.cpp - Check for the prot argument
+//
Needs one of these at the top:
```
//===- MmapWriteExecChecker.cpp - Check the mmap prot argument
-
jroelofs added inline comments.
Comment at: lib/StaticAnalyzer/Checkers/MmapWriteExecChecker.cpp:1
+// MmapWriteExecChecker.cpp - Check for the prot argument
+//
jroelofs wrote:
> Needs one of these at the top:
>
> ```
> //===- MmapWriteExecChecker.cpp - Check t
jroelofs added inline comments.
Comment at: include/clang/StaticAnalyzer/Checkers/Checkers.td:399
+ def MmapWriteExecChecker : Checker<"MmapWriteExec">,
+HelpText<"Check if mmap() call is not both writable and executable">,
+DescFile<"MmapWriteExecChecker.cpp">;
jroelofs accepted this revision.
jroelofs added a comment.
This revision is now accepted and ready to land.
LGTM
https://reviews.llvm.org/D29817
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/c
jroelofs added inline comments.
Comment at: include/clang/Driver/Options.td:1613
def mcpu_EQ : Joined<["-"], "mcpu=">, Group;
+def mmcu_EQ : Joined<["-"], "mmcu=">, Group;
def mdynamic_no_pic : Joined<["-"], "mdynamic-no-pic">, Group;
Would it make sense to hav
jroelofs accepted this revision.
jroelofs added a comment.
This revision is now accepted and ready to land.
LGTM
https://reviews.llvm.org/D30340
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/c
jroelofs accepted this revision.
jroelofs added a comment.
This revision is now accepted and ready to land.
LGTM
https://reviews.llvm.org/D30339
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/c
jroelofs added a comment.
In https://reviews.llvm.org/D30339#685888, @EricWF wrote:
> isn't this incorrect because `config.h` always defines LIBCXX_BAREMETAL?
Oh, right, it needs to be:
#if !LIBCXXABI_BAREMETAL || !defined(NDEBUG)
Repository:
rL LLVM
https://reviews.llvm.org/D30339
_
jroelofs added a comment.
In https://reviews.llvm.org/D30339#685919, @rmaprath wrote:
> Perhaps change `config.h` and remove the definition there and adjust other
> places accordingly?
>
> The current form is very easy to trip over.
Eric's point is that LIBCXXABI_BAREMETAL is a 0/1 flag, not a
jroelofs added a comment.
libc++ headers should not be installed in the resource dir.
https://reviews.llvm.org/D30214
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
jroelofs added a comment.
In https://reviews.llvm.org/D30158#690032, @madsravn wrote:
> Looks good for the two tests the are for `random_shuffle` in llvm libc++.
There were a lot more some time ago, before @mclow.lists performed this
transformation on libc++'s testsuite. You might want to try
jroelofs added a comment.
In https://reviews.llvm.org/D30514#690318, @mehdi_amini wrote:
> LGTM.
>
> (It seems that having libc++ and libc++abi in the same repo would help
> sharing code like this)
I think it would be a step backwards in terms of opening things up for layering
violations. We
jroelofs added a comment.
In https://reviews.llvm.org/D30214#690375, @Hahnfeld wrote:
> In https://reviews.llvm.org/D30214#690010, @jroelofs wrote:
>
> > libc++ headers should not be installed in the resource dir.
>
>
> They are currently not by default. But with https://reviews.llvm.org/D30015
jroelofs added a comment.
Can the null check be performed in the callee?
That'd make this check work for a few more cases that this patch doesn't cover:
- `performSelector:` messages
- messages to `id`.
https://reviews.llvm.org/D30599
___
cfe-comm
jroelofs accepted this revision.
jroelofs added a comment.
This revision is now accepted and ready to land.
LGTM, by the way.
https://reviews.llvm.org/D30599
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailm
jroelofs added a comment.
I think this might miss loads from bitfield ivars. Also, what about the
conversion that happens for properties whose backing ivar is a bitfield? (or
does that happen in the runtime? can't remember)
Comment at: test/CodeGenObjC/ubsan-bool.m:25
+ // O
jroelofs accepted this revision.
jroelofs added a comment.
This revision is now accepted and ready to land.
LGTM
Comment at: test/CodeGenObjC/ubsan-bool.m:26
+ // OBJC: [[ICMP:%.*]] = icmp ule i8 [[ASHR]], 1, !nosanitize
+ // OBJC: call void @__ubsan_handle_load_invalid_valu
jroelofs added a comment.
In https://reviews.llvm.org/D28820#695356, @tyomitch wrote:
> When compiling for softfp targets, this new warning doesn't make sense: there
> are no VFP registers to save.
> Jonathan, would you please conditionalize it to only affect hardfp targets?
Sure, I can do th
jroelofs added inline comments.
Comment at: lib/CodeGen/CGDecl.cpp:1911
+if (auto Nullability = Ty->getNullability(getContext())) {
+ if (Nullability && *Nullability == NullabilityKind::NonNull) {
+SanitizerScope SanScope(this);
aprantl wrote:
>
jroelofs requested changes to this revision.
jroelofs added a comment.
This revision now requires changes to proceed.
As I said on https://reviews.llvm.org/D30214, it is inappropriate to be
installing libc++ in the resource directory... please **do not** do that.
https://reviews.llvm.org/D30733
jroelofs added a comment.
In https://reviews.llvm.org/D30733#697313, @Hahnfeld wrote:
> In https://reviews.llvm.org/D30733#697108, @jroelofs wrote:
>
> > As I said on https://reviews.llvm.org/D30214, it is inappropriate to be
> > installing libc++ in the resource directory... please **do not** d
jroelofs added a comment.
I'll also add that we had a BOF at EuroLLVM 2014, where this got support from
the community and people generally thought it was a good plan... Just needed
someone to follow through with it.
We (wearing my CodeSourcery hat) said we would do so, but have been making slow
jroelofs added a comment.
In https://reviews.llvm.org/D30158#699132, @madsravn wrote:
> In https://reviews.llvm.org/D30158#698871, @aaron.ballman wrote:
>
> > In https://reviews.llvm.org/D30158#696534, @madsravn wrote:
> >
> > > Any updates on this?
> >
> >
> > Have you run it over the test suite
jroelofs created this revision.
https://reviews.llvm.org/D30945
Files:
include/clang/Parse/Parser.h
lib/Parse/ParseOpenMP.cpp
lib/Parse/ParseStmt.cpp
Index: lib/Parse/ParseStmt.cpp
===
--- lib/Parse/ParseStmt.cpp
+++ lib/Pars
jroelofs added a comment.
LGTM
https://reviews.llvm.org/D27005
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
jroelofs added a comment.
In https://reviews.llvm.org/D27123#614313, @saaadhu wrote:
> Add testcases to test/Preprocessor/init.c
Awesome, thanks!
> Correct types for WChar and WInt
>
> The ABI is documented in the avr-gcc wiki (https://gcc.gnu.org/wiki/avr-gcc)
> I took the output of a trunk
jroelofs added a comment.
In https://reviews.llvm.org/D27123#615738, @saaadhu wrote:
> Thanks, setting DoubleFormat and LongDoubleFormat fixed the __DBL_ and
> __LDBL_ differences. Also, setting SigAtomicType fixed the __SIG_ATOMIC_
> differences as well. I've added those defines to the test. U
jroelofs added a subscriber: rengolin.
jroelofs added a comment.
In https://reviews.llvm.org/D27123#616887, @saaadhu wrote:
> Make defines for CHAR16_TYPE, {U,}INT_{LEAST,FAST}16_TYPE use int instead of
> short.
>
> {U,}INT16_TYPE still gets defined as short though -
> lib/Frontend/InitPreproce
jroelofs added a comment.
In https://reviews.llvm.org/D27123#617118, @jroelofs wrote:
> In https://reviews.llvm.org/D27123#616887, @saaadhu wrote:
>
> > Make defines for CHAR16_TYPE, {U,}INT_{LEAST,FAST}16_TYPE use int instead
> > of short.
> >
> > {U,}INT16_TYPE still gets defined as short thou
jroelofs added a comment.
I think you'd have to check for a maximum host SDK version, and then bump it
upstream every time there's a new one thats known to work with the then-current
trunk.
It can't be done based on language features because by definition, one cannot
know what features are goi
jroelofs added a comment.
This doesn't forbid assigning them to block properties... is that intentional?
typedef void (^Block)(int);
@interface Foo
@property Block B;
@end
void foo(Foo *f, Block __attribute__((noescape)) b) {
f.B = b;
}
Comment at: includ
jroelofs added inline comments.
Comment at: utils/libcxx/test/config.py:387
+self.config.available_features.add(
+'with_system_cxx_lib=%s' % component)
mehdi_amini wrote:
> jroelofs wrote:
> > Is it worth filtering out `none`
jroelofs added a comment.
Ping.
@arphaman I'd like to remove them, absent a concrete plan to fix this from
folks with a vested interest in them (i.e. you).
https://reviews.llvm.org/D32178
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
htt
jroelofs accepted this revision.
jroelofs added a comment.
This revision is now accepted and ready to land.
LGTM. Thanks for doing that... I totally forgot!
Repository:
rL LLVM
https://reviews.llvm.org/D32918
___
cfe-commits mailing list
cfe-comm
jroelofs added a comment.
ping @arphaman
https://reviews.llvm.org/D32178
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
jroelofs added a comment.
Sure. That'd be needed whether they stay, or get moved to test-suite.
https://reviews.llvm.org/D32178
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
jroelofs created this revision.
Herald added subscribers: javed.absar, mgorny, rengolin, aemerson.
https://reviews.llvm.org/D33259
Files:
cmake/caches/BaremetalARM.cmake
lib/Driver/CMakeLists.txt
lib/Driver/Driver.cpp
lib/Driver/ToolChains/BareMetal.cpp
lib/Driver/ToolChains/BareMetal.h
jroelofs updated this revision to Diff 99210.
jroelofs added a comment.
pass through linker flags, and remove my own paths from the test.
https://reviews.llvm.org/D33259
Files:
cmake/caches/BaremetalARM.cmake
lib/Driver/CMakeLists.txt
lib/Driver/Driver.cpp
lib/Driver/ToolChains/BareMeta
jroelofs added a comment.
> I would expect this to changes wildly depending on the specific environment.
My assertion is that our default "specific environment" ought to cater to using
llvm's own tools... at least until someone comes along and says they actually
want `-fuse-ld=gcc`, or whatever
jroelofs planned changes to this revision.
jroelofs added inline comments.
Comment at: cmake/caches/BaremetalARM.cmake:1
+set(LLVM_TARGETS_TO_BUILD ARM CACHE STRING "")
+
compnerd wrote:
> Please rename this file to `BareMetalARMv6.cmake`. (I'm interested in the
jroelofs added inline comments.
Comment at: lib/Driver/ToolChains/BareMetal.h:42
+
+ const char *getDefaultLinker() const override { return "ld.lld"; }
+
compnerd wrote:
> I think that this really should be `ld` still, as that is the canonical name
> for the li
jroelofs updated this revision to Diff 99350.
https://reviews.llvm.org/D33259
Files:
cmake/caches/BaremetalARM.cmake
lib/Driver/CMakeLists.txt
lib/Driver/Driver.cpp
lib/Driver/ToolChains/BareMetal.cpp
lib/Driver/ToolChains/BareMetal.h
test/Driver/Inputs/baremetal_arm/include/c++/v1/.k
jroelofs marked 2 inline comments as done.
jroelofs added inline comments.
Comment at: lib/Driver/ToolChains/BareMetal.cpp:107-108
+ArgStringList &CmdArgs) const {
+ CmdArgs.push_back("-lc++");
+ CmdArgs.push_back("-lc++abi");
+ CmdArgs.push
jroelofs added a comment.
@arphaman Those patches seem reasonable.
https://reviews.llvm.org/D32178
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
jroelofs added a comment.
Would be good to test for the presence/absence of the flag, too:
Comment at: test/libcxx/selftest/test.arc.pass.mm:10
+//===--===//
+
+int main()
```
#if __has_feature
jroelofs accepted this revision.
jroelofs added a comment.
This revision is now accepted and ready to land.
LGTM
https://reviews.llvm.org/D33049
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/c
jroelofs added inline comments.
Comment at: cmake/caches/BaremetalARM.cmake:1
+set(LLVM_TARGETS_TO_BUILD ARM CACHE STRING "")
+
compnerd wrote:
> jroelofs wrote:
> > compnerd wrote:
> > > Please rename this file to `BareMetalARMv6.cmake`. (I'm interested in
> >
jroelofs added inline comments.
Comment at: lib/Driver/ToolChains/BareMetal.cpp:68
+ SmallString<128> Dir(getDriver().ResourceDir);
+ llvm::sys::path::append(Dir, "lib", "baremetal");
+ return Dir.str();
compnerd wrote:
> jroelofs wrote:
> > compnerd wrote:
>
jroelofs updated this revision to Diff 99950.
https://reviews.llvm.org/D33259
Files:
cmake/caches/BaremetalARM.cmake
lib/Driver/CMakeLists.txt
lib/Driver/Driver.cpp
lib/Driver/ToolChains/BareMetal.cpp
lib/Driver/ToolChains/BareMetal.h
test/Driver/Inputs/baremetal_arm/include/c++/v1/.k
jroelofs planned changes to this revision.
jroelofs added inline comments.
Comment at: cmake/caches/BaremetalARM.cmake:10
+
+set(BUILTINS_armv7m-none-eabi_CMAKE_SYSROOT ${BAREMETAL_ARMV7M_SYSROOT} CACHE
STRING "armv7m-none-eabi Sysroot")
+set(BUILTINS_armv7m-none-eabi_CMAKE_SYST
jroelofs updated this revision to Diff 100018.
jroelofs added a comment.
fixed the v7m/v7em part of the build
https://reviews.llvm.org/D33259
Files:
cmake/caches/BaremetalARM.cmake
lib/Driver/CMakeLists.txt
lib/Driver/Driver.cpp
lib/Driver/ToolChains/BareMetal.cpp
lib/Driver/ToolChain
101 - 171 of 171 matches
Mail list logo