ervin requested changes to this revision.
ervin added inline comments.
This revision now requires changes to proceed.

INLINE COMMENTS

> DeviceAutomounterKCM.cpp:57
>  
> +    m_settings = new AutomounterSettings();
> +    addConfig(m_settings, this);

Missing this as parent, this is leaked. Also I'd likely move that in the ctor 
initialization list (same thing for m_devices actually, maybe in another patch, 
your call).

> DeviceAutomounterKCM.cpp:114
> +
> +    kcfg_AutomountUnknownDevices->setEnabled(m_settings->automountEnabled());
> +    kcfg_AutomountOnLogin->setEnabled(m_settings->automountEnabled());

I'd store the result of the automountEnabled call in an intermediate variable, 
just to make things more readable.

REPOSITORY
  R119 Plasma Desktop

REVISION DETAIL
  https://phabricator.kde.org/D27127

To: meven, ervin, ngraham, #plasma, bport, crossi
Cc: plasma-devel, Orage, LeGast00n, The-Feren-OS-Dev, cblack, jraleigh, zachus, 
fbampaloukas, GB_2, ragreen, ZrenBot, ngraham, alexeymin, himcesjf, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, apol, ahiemstra, mart

Reply via email to