On Tue, 2019-07-23 at 18:30 -0700, Matthew Wilcox wrote: > On Tue, Jul 23, 2019 at 10:33:59PM +0000, Saeed Mahameed wrote: > > > struct skb_frag_struct { > > > struct page *bv_page; > > > - __u32 size; > > > + unsigned int bv_len; > > > __u32 page_offset; > > > > Why do you keep page_offset name and type as is ? it will make the > > last > > patch much cleaner if you change it to "unsigned int bv_offset". > > We don't have an accessor for page_offset, so there are about 280 > occurrences of '>page_offset' in drivers/net/ >
I understand but why not chaining the type to "unsigned int" at least to avoid confusion ? > Feel free to be the hero who does that cleanup.