Herbert Xu wrote:
David Daney <[EMAIL PROTECTED]> wrote:

--- net/ipv4/arp.c.orig 2006-03-31 13:44:50.000000000 -0800
+++ net/ipv4/arp.c      2006-03-31 13:48:26.000000000 -0800
@@ -690,8 +691,13 @@ void arp_send(int type, int ptype, u32 d
      if (dev->flags&IFF_NOARP)
              return;

+       /* If link local address (169.254.0.0/16) we must broadcast
+         * the ARP packet.  See RFC 3927 section 2.5 for details.
+        */
+       lla = (dest_ip & htonl(0xFFFF0000UL)) == htonl(0xA9FE0000UL);


Is this really meant to be dest_ip as opposed to src_ip?

The variables seem to be misnamed, the patch does not try to rectify that issue.

Also wouldn't
be simpler if you wrote it as

        if (dest_ip & htonl(0xFFFF0000UL) == htonl(0xA9FE0000UL))
                dest_hw = NULL;

That would work as well. From the standpoint of human understanding your way seems simpler, as to the generated code, I have no idea.

Thanks,
David Daney
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to