labath added a comment.

In D132395#3745227 <https://reviews.llvm.org/D132395#3745227>, @mgorny wrote:

> Yeah, I meant inside LLDB, since that's what we're talking about. Basically, 
> I'm wondering if we should perhaps rename `WriteAll()` to `Write()`, remove 
> the old `Write()` method and just use the looped variant everywhere (implying 
> also via `SB*`).

Ok. In that case, I generally agree with you, but I am worried about 
consistency, not just with other Write methods, but also with all Read-like 
methods, and I'm not convinced that renaming just a single class will do more 
good than harm. But I would support a wider refactor of Read/Write like calls 
which makes it more obvious whether a particular call is able to complete with 
partial data.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D132395/new/

https://reviews.llvm.org/D132395

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to