mgorny added a comment. In D96548#2577762 <https://reviews.llvm.org/D96548#2577762>, @labath wrote:
> In D96548#2574437 <https://reviews.llvm.org/D96548#2574437>, @mgorny wrote: > >> In D96548#2571489 <https://reviews.llvm.org/D96548#2571489>, @mhorne wrote: >> >>> I should also note that it is my intention to merge the FreeBSD watchpoint >>> patches into the 13.0 branch, in about a week's time. So your >>> `__FreeBSD_version` checks will need to be updated after that point. >> >> Do you have any suggestion how we could check for kernel version from Python >> at runtime? (to determine whether we should expect watchpoint tests to work) > > `SBPlatform::GetOS{Major,Minor,Update}Version` ? That comes from uname as well, so no difference. However, I'm going to replace the current code with it for reuse. > In D96548#2574060 <https://reviews.llvm.org/D96548#2574060>, @mgorny wrote: > >> In D96548#2573954 <https://reviews.llvm.org/D96548#2573954>, @omjavaid wrote: >> >>> In D96548#2573245 <https://reviews.llvm.org/D96548#2573245>, @mgorny wrote: >>> >>>>> Moreover, can we shrink class name >>>>> NativeRegisterContextBreakWatchpoint_arm64 to may be >>>>> NativeDebugRegisterContext_arm64. >>>> >>>> I generally leave naming decisions to @labath ;-). >>> >>> Lets see what @labath has to say... IMO Debug Register is a general term >>> used in other architecture specs for referring to hardware debug >>> capabilities like breakpoints watchpoints etc. >> >> I agree. For consistency with the x86 class, maybe >> `NativeRegisterContextDBReg_arm64`? I wonder if we should rename the x86 >> class too. > > Sounds reasonable to me. Renaming the x86 class as well would be great. I'll do x86 as a separate patch. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D96548/new/ https://reviews.llvm.org/D96548 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits