linux-kernel
Thread
Date
Earlier messages
Later messages
Messages by Thread
Re: [PATCH v2] selftests/x86: Add a test for LASS enforcement
H. Peter Anvin
Re: [PATCH v2] selftests/x86: Add a test for LASS enforcement
Sohil Mehta
Re: [PATCH v2] selftests/x86: Add a test for LASS enforcement
H. Peter Anvin
RE: [PATCH v2 0/14] hv: vmbus: make rings and host-visible buffers survive buddy fragmentation
Michael Kelley
Re: [PATCH v2 0/14] hv: vmbus: make rings and host-visible buffers survive buddy fragmentation
Wei Liu
Re: [PATCH v2 0/14] hv: vmbus: make rings and host-visible buffers survive buddy fragmentation
Wei Liu
[PATCH 00/10] KVM: x86/xen: Don't drop event deliveries which race memslot updates
David Woodhouse
[PATCH 07/10] KVM: x86/xen: Explicitly tag "shared info" page as never being dirty tracked
David Woodhouse
[PATCH 09/10] KVM: x86: Request the guest TLB flush from record_steal_time()
David Woodhouse
[PATCH 04/10] KVM: x86/xen: Don't lose the timer event when delivery fails transiently
David Woodhouse
[PATCH 06/10] KVM: x86/xen: Extract delivery of event to vCPU into a separate helper
David Woodhouse
[PATCH 05/10] KVM: x86/xen: Retry event channel delivery which races a memslot update
David Woodhouse
[PATCH 01/10] KVM: pfncache: Return -EAGAIN for a lookup which hits an invalid memslot
David Woodhouse
[PATCH 10/10] KVM: selftests: Add Xen evtchn vs memslot-update race test
David Woodhouse
[PATCH 08/10] KVM: x86/xen: Don't dirty track "vCPU info" page
David Woodhouse
[PATCH 02/10] KVM: pfncache: Add a 'wait' argument to the refresh and activate functions
David Woodhouse
[PATCH 03/10] KVM: x86/xen: Wait out memslot updates in the Xen attribute ioctls
David Woodhouse
[PATCH] kunit: tool: Treat all-skipped results as success when parsing
Rowan Vale
[PATCH] selftests: kselftest_deps.sh: Support LLVM
Mark Brown
Re: [PATCH] selftests: kselftest_deps.sh: Support LLVM
Shuah Khan
Re: [PATCH] selftests: kselftest_deps.sh: Support LLVM
Nick Desaulniers
Re: [PATCH] selftests: kselftest_deps.sh: Support LLVM
Mark Brown
Re: [PATCH] selftests: kselftest_deps.sh: Support LLVM
Nick Desaulniers
Re: [PATCH] selftests: kselftest_deps.sh: Support LLVM
Shuah Khan
[PATCH bpf-next v4 0/2] selftests/bpf: Add tests for memcg kfuncs
listout
[PATCH bpf-next v4 1/2] selftests/bpf: Move alloc_pagecache() to cgroup_helpers
listout
[PATCH bpf-next v4 2/2] selftests/bpf: Add tests for memcg kfuncs
listout
[PATCH v4] arm64: dts: qcom: sm7125-samsung: add initial device tree
Erikas Bitovtas
Re: [PATCH v4] arm64: dts: qcom: sm7125-samsung: add initial device tree
Konrad Dybcio
Re: [PATCH v4] arm64: dts: qcom: sm7125-samsung: add initial device tree
Erikas Bitovtas
Re: [PATCH v3] remoteproc: core: Fetch the auto-boot firmware only once
Mathieu Poirier
[PATCH net-next 0/4] mptcp: misc improvements for v7.4
Matthieu Baerts (NGI0)
[PATCH net-next 3/4] selftests: mptcp: convert iptables to nftables for mptcp_sockopt.sh
Matthieu Baerts (NGI0)
Re: [PATCH net-next 3/4] selftests: mptcp: convert iptables to nftables for mptcp_sockopt.sh
netdev-bot+sashiko
Re: [PATCH net-next 3/4] selftests: mptcp: convert iptables to nftables for mptcp_sockopt.sh
Matthieu Baerts
[PATCH net-next 4/4] selftests: mptcp: convert iptables to nftables for mptcp_join.sh
Matthieu Baerts (NGI0)
Re: [PATCH net-next 4/4] selftests: mptcp: convert iptables to nftables for mptcp_join.sh
netdev-bot+sashiko
Re: [PATCH net-next 4/4] selftests: mptcp: convert iptables to nftables for mptcp_join.sh
Matthieu Baerts
[PATCH 0/7] kunit: tool: Support parallel test execution
Mark Brown
[PATCH 5/7] kunit: tool: Allow several run_kernel() calls to be in flight at once
Mark Brown
[PATCH 1/7] kunit: tool: Preserve failures from kernels without test results
Mark Brown
[PATCH 6/7] kunit: tool: Serialise output written from multiple threads
Mark Brown
Re: [PATCH 6/7] kunit: tool: Serialise output written from multiple threads
Daniel Latypov
Re: [PATCH 6/7] kunit: tool: Serialise output written from multiple threads
Mark Brown
[PATCH 7/7] kunit: tool: Add --parallel to run suites in concurrent kernels
Mark Brown
[PATCH 3/7] kunit: tool: Boot with a larger log buffer when listing tests
Mark Brown
[PATCH 2/7] kunit: tool: Combine reports from isolated kernels
Mark Brown
[PATCH 4/7] kunit: tool: Add an outfile argument to run_kernel()
Mark Brown
[PATCH bpf-next v3] selftests/bpf: Add tests for memcg kfuncs
listout
Re: [PATCH bpf-next v3] selftests/bpf: Add tests for memcg kfuncs
bot+bpf-ci
Re: [PATCH v15 14/23] KVM: selftests: Expose function to allocate vCPU stack
Lisa Wang
Re: [PATCH v2] remoteproc: virtio: Synchronize virtqueue teardown with rproc_vq_interrupt()
Mathieu Poirier
Re: [RFC PATCH] remoteproc: core: add KUnit tests for rproc_check_carveout_da()
Mathieu Poirier
Re: [PATCH 0/4] remoteproc: core: Fix the error unwind paths
Yonghao Zhang
Re: [PATCH 0/4] remoteproc: core: Fix the error unwind paths
Mathieu Poirier
[PATCH 0/2] KVM: s390: fix ESSA addressing exception injection in migration mode
Gautam Gala
[PATCH 2/2] KVM: s390: selftests: add ESSA migration mode PGM_ADDRESSING regression test
Gautam Gala
[PATCH 1/2] KVM: s390: fix ESSA addressing exception injection in migration mode
Gautam Gala
Re: [PATCH v8 0/5] thermal: samsung: Add support for Google GS101 TMU
Daniel Lezcano
Re: [PATCH v8 0/5] thermal: samsung: Add support for Google GS101 TMU
Krzysztof Kozlowski
Re: [PATCH v8 0/5] thermal: samsung: Add support for Google GS101 TMU
Daniel Lezcano
Re: [PATCH v8 0/5] thermal: samsung: Add support for Google GS101 TMU
Tudor Ambarus
Re: [PATCH v8 0/5] thermal: samsung: Add support for Google GS101 TMU
Daniel Lezcano
Re: [PATCH v8 0/5] thermal: samsung: Add support for Google GS101 TMU
Tudor Ambarus
[PATCH v5 0/4] dm zoned: fix idle reclaim problems
Kyrylo Biryuk
[PATCH v5 2/4] dm zoned: do not reclaim a random zone into another random zone
Kyrylo Biryuk
[PATCH v5 4/4] dm zoned: do not busy-loop idle reclaim when no zone needs reclaim
Kyrylo Biryuk
Re: [PATCH v5 4/4] dm zoned: do not busy-loop idle reclaim when no zone needs reclaim
Damien Le Moal
[PATCH v5 1/4] dm zoned: back off when reclaim finds no destination zone
Kyrylo Biryuk
[PATCH v5 3/4] dm zoned: keep polling for idle reclaim after a reclaim pass
Kyrylo Biryuk
Re: [PATCH v5 0/4] dm zoned: fix idle reclaim problems
Mikulas Patocka
Re: [PATCH] dm-verity: clear LSM integrity state on suspend
Mikulas Patocka
[PATCH bpf-next] selftests/bpf: Add tests for memcg kfuncs
listout
[RESEND PATCH v2 1/1] kernel/locking: Add mutual exclusion self-test
Håkon Bugge
[PATCH] rpmsg: glink: smem: preserve IRQ acquisition errors
Avi Weiss
Re: [PATCH] rpmsg: glink: smem: preserve IRQ acquisition errors
Konrad Dybcio
Re: [RFC PATCH v2 0/3] security: Add PR_CAPBSET_DROP_MASK
Serge E. Hallyn
[PATCH v2 0/6] mm/page_owner: add bpf_iter and kfuncs
Zhen Ni
[PATCH v2 5/6] mm/page_owner: add bpf_page_owner_get_memcg_info() kfunc
Zhen Ni
[PATCH v2 2/6] mm/page_owner: add bpf_iter target "page_owner"
Zhen Ni
Re: [PATCH v2 2/6] mm/page_owner: add bpf_iter target "page_owner"
bot+bpf-ci
[PATCH v2 1/6] mm/page_owner: extract page_owner_next_eligible() from read loop
Zhen Ni
[PATCH v2 3/6] mm/page_owner: add open-coded page_owner iterator
Zhen Ni
Re: [PATCH v2 3/6] mm/page_owner: add open-coded page_owner iterator
bot+bpf-ci
[PATCH v2 4/6] mm/page_owner: record the NUMA node in the scan cursor
Zhen Ni
[PATCH v2 6/6] selftests/bpf: add tests for the page_owner bpf_iter target
Zhen Ni
Re: [PATCH v2 0/6] mm/page_owner: add bpf_iter and kfuncs
Zi Yan
[PATCH v4 2/3] dm zoned: do not reclaim a random zone into another random zone
Kyrylo Biryuk
[PATCH v2] docs: remove Assisted-by references
Sasha Levin
Re: [PATCH v2] docs: remove Assisted-by references
Jori Koolstra
Re: [PATCH v2] docs: remove Assisted-by references
Krzysztof Kozlowski
Re: [PATCH v2] docs: remove Assisted-by references
Vlastimil Babka (SUSE)
Re: [PATCH v2] docs: remove Assisted-by references
Krzysztof Kozlowski
Re: [PATCH v2] docs: remove Assisted-by references
Vlastimil Babka (SUSE)
Re: [PATCH v2] docs: remove Assisted-by references
David Hildenbrand (Arm)
Re: [PATCH v2] docs: remove Assisted-by references
Shuah Khan
Re: [PATCH v2] docs: remove Assisted-by references
Mark Brown
Re: [PATCH v2] docs: remove Assisted-by references
Daniel Pereira
Re: [PATCH v2] docs: remove Assisted-by references
SJ Park
Re: [PATCH v2] docs: remove Assisted-by references
Jeff Layton
Re: [PATCH v2] docs: remove Assisted-by references
Weijie Yuan
Re: [PATCH v2] docs: remove Assisted-by references
Jonathan Corbet
Re: [PATCH v2] docs: remove Assisted-by references
Sasha Levin
Re: [PATCH v2] docs: remove Assisted-by references
Troy Benjegerdes
Re: [PATCH v2] docs: remove Assisted-by references
Miguel Ojeda
Re: [PATCH v2] audit: add FSOPEN record to log filesystem name
Ricardo Robaina
Re: [PATCH v8 5/8] KVM: nSVM: Fetch DecodeAssist bytes for synthesized faults
Tina Zhang
Re: [PATCH v8 5/8] KVM: nSVM: Fetch DecodeAssist bytes for synthesized faults
Sean Christopherson
Re: [PATCH RFC v3 03/15] hazptr: scan all per-CPU slots before overflow lists
Kai Ma
[RFC PATCH net-next 0/4] tcp: carry a BPF-chosen identifier in TSval low bits
Willem Ferguson
[RFC PATCH net-next 3/4] tcp: add TCP_TS_ID socket option
Willem Ferguson
[RFC PATCH net-next 4/4] selftests/bpf: add tcp_ts_id test
Willem Ferguson
[RFC PATCH net-next 2/4] tcp: add BPF_SOCK_OPS_TCP_TS_ID_CB to assign a TSval identifier
Willem Ferguson
Re: [RFC PATCH net-next 2/4] tcp: add BPF_SOCK_OPS_TCP_TS_ID_CB to assign a TSval identifier
Jakub Sitnicki
Re: [RFC PATCH net-next 2/4] tcp: add BPF_SOCK_OPS_TCP_TS_ID_CB to assign a TSval identifier
Jason Xing
[RFC PATCH net-next 1/4] tcp: add plumbing to carry an identifier in TSval low bits
Willem Ferguson
Re: [RFC PATCH net-next 0/4] tcp: carry a BPF-chosen identifier in TSval low bits
Stanislav Fomichev
[PATCH net-next 0/4] more virtio-net csum hardening
Michael S. Tsirkin
[PATCH net-next 1/4] net: add ip4_parse()
Michael S. Tsirkin
Re: [PATCH net-next 1/4] net: add ip4_parse()
netdev-bot+sashiko
[PATCH net-next 3/4] net: resolve uncommon partial checksums at ingress
Michael S. Tsirkin
Re: [PATCH net-next 3/4] net: resolve uncommon partial checksums at ingress
Michael S. Tsirkin
Re: [PATCH net-next 3/4] net: resolve uncommon partial checksums at ingress
Willem de Bruijn
Re: [PATCH net-next 3/4] net: resolve uncommon partial checksums at ingress
Michael S. Tsirkin
Re: [PATCH net-next 3/4] net: resolve uncommon partial checksums at ingress
Willem de Bruijn
Re: [PATCH net-next 3/4] net: resolve uncommon partial checksums at ingress
Michael S. Tsirkin
Re: [PATCH net-next 3/4] net: resolve uncommon partial checksums at ingress
Willem de Bruijn
Re: [PATCH net-next 3/4] net: resolve uncommon partial checksums at ingress
Michael S. Tsirkin
Re: [PATCH net-next 3/4] net: resolve uncommon partial checksums at ingress
Michael S. Tsirkin
Re: [PATCH net-next 3/4] net: resolve uncommon partial checksums at ingress
netdev-bot+sashiko
[PATCH net-next 4/4] net: account for ingress-resolved virtio net hdr state
Michael S. Tsirkin
Re: [PATCH net-next 4/4] net: account for ingress-resolved virtio net hdr state
Björn Töpel
Re: [PATCH net-next 4/4] net: account for ingress-resolved virtio net hdr state
Michael S. Tsirkin
Re: [PATCH net-next 4/4] net: account for ingress-resolved virtio net hdr state
netdev-bot+sashiko
[PATCH net-next 2/4] net: use ip4_parse() in receive validation
Michael S. Tsirkin
Re: [PATCH net-next 2/4] net: use ip4_parse() in receive validation
netdev-bot+sashiko
Re: [PATCH net-next 0/4] more virtio-net csum hardening
Michael S. Tsirkin
Re: [PATCH net-next 0/4] more virtio-net csum hardening
Chris Arges
Re: [PATCH net-next 0/4] more virtio-net csum hardening
Willem de Bruijn
Re: [PATCH net-next 0/4] more virtio-net csum hardening
Michael S. Tsirkin
Re: [PATCH net-next 0/4] more virtio-net csum hardening
Willem de Bruijn
Re: [PATCH net-next 0/4] more virtio-net csum hardening
Michael S. Tsirkin
Re: [PATCH net-next 0/4] more virtio-net csum hardening
Willem de Bruijn
Re: [PATCH net-next 0/4] more virtio-net csum hardening
Michael S. Tsirkin
[PATCH v7 0/3] kselftest: mm: remove HPAGE_SIZE and HPAGE_SHIFT macro
Yeoreum Yun
[PATCH v7 3/3] kselftest: mm: introduce size_to_shift() helper
Yeoreum Yun
[PATCH v7 2/3] kselftest: mm: remove HPAGE_SIZE and HPAGE_SHIFT macro
Yeoreum Yun
Re: [PATCH v7 2/3] kselftest: mm: remove HPAGE_SIZE and HPAGE_SHIFT macro
Sarthak Sharma
Re: [PATCH v7 2/3] kselftest: mm: remove HPAGE_SIZE and HPAGE_SHIFT macro
Yeoreum Yun
Re: [PATCH v7 2/3] kselftest: mm: remove HPAGE_SIZE and HPAGE_SHIFT macro
Sarthak Sharma
Re: [PATCH v7 2/3] kselftest: mm: remove HPAGE_SIZE and HPAGE_SHIFT macro
Yeoreum Yun
[PATCH v7 1/3] kselftest: mm: rename read_pmd_pagesize() to pmd_psize()
Yeoreum Yun
[PATCH v3 0/4] kunit: add optional assertions to catch taint and lockdep warnings
Malte Wechter
[PATCH v3 1/4] kunit: add logic for tracking forcefully skipped test cases/suites
Malte Wechter
[PATCH v3 2/4] kunit: add assertions for lockdep inside of kunit
Malte Wechter
[PATCH v3 3/4] kunit: add assertions for TAINT_WARN inside of kunit
Malte Wechter
[PATCH v3 4/4] Documentation: kunit: add documentation and examples to kunit documentation
Malte Wechter
[PATCH v6 0/3] kselftest: mm: remove HPAGE_SIZE and HPAGE_SHIFT macro
Yeoreum Yun
[PATCH v6 1/3] kselftest: mm: rename read_pmd_pagesize() to pmd_psize()
Yeoreum Yun
[PATCH v6 2/3] kselftest: mm: remove HPAGE_SIZE and HPAGE_SHIFT macro
Yeoreum Yun
Re: [PATCH v6 2/3] kselftest: mm: remove HPAGE_SIZE and HPAGE_SHIFT macro
Sarthak Sharma
Re: [PATCH v6 2/3] kselftest: mm: remove HPAGE_SIZE and HPAGE_SHIFT macro
Yeoreum Yun
Re: [PATCH v6 2/3] kselftest: mm: remove HPAGE_SIZE and HPAGE_SHIFT macro
Mike Rapoport
[PATCH v6 3/3] kselftest: mm: introduce size_to_shift() helper
Yeoreum Yun
Re: [PATCH 00/21] mm: change behavior of pXdp_get()/pXd_page() in compile-time folded pgtable
Yeoreum Yun
Re: [PATCH 00/21] mm: change behavior of pXdp_get()/pXd_page() in compile-time folded pgtable
David Hildenbrand (Arm)
Re: [PATCH 00/21] mm: change behavior of pXdp_get()/pXd_page() in compile-time folded pgtable
Yeoreum Yun
Re: [PATCH v5 2/3] kselftest: mm: remove HPAGE_SIZE and HPAGE_SHIFT macro
Yeoreum Yun
Re: [PATCH 2/2] remoteproc: qcom_q6v5_pas: Add remoteproc support for SOCCP on Nord
Konrad Dybcio
Re: [PATCH 2/2] remoteproc: qcom_q6v5_pas: Add remoteproc support for SOCCP on Nord
Anurag Pateriya
Re: [PATCH 2/2] remoteproc: qcom_q6v5_pas: Add remoteproc support for SOCCP on Nord
Konrad Dybcio
Re: [PATCH 2/2] remoteproc: qcom_q6v5_pas: Add remoteproc support for SOCCP on Nord
Anurag Pateriya
Re: [PATCH 2/2] remoteproc: qcom_q6v5_pas: Add remoteproc support for SOCCP on Nord
Anurag Pateriya
Re: [PATCH net-next v2 7/7] net: mctp: usblib: Add test for failing append
James Lee
[PATCH v3 0/5] ALSA: virtio: Fix request lifetime and error recovery
Joonho Lee
[PATCH v3 1/5] ALSA: virtio: Propagate PCM send failures through ACK
Joonho Lee
[PATCH v3 3/5] ALSA: virtio: Retain queued messages through device reset
Joonho Lee
[PATCH v3 4/5] ALSA: virtio: Keep PCM DMA buffers alive through device ownership
Joonho Lee
[PATCH v3 2/5] ALSA: virtio: Recover PCM state after a failed start
Joonho Lee
[PATCH v3 5/5] ALSA: virtio: Keep control payloads alive through DMA completion
Joonho Lee
Re: [PATCH v3 0/5] ALSA: virtio: Fix request lifetime and error recovery
Takashi Iwai
[PATCH RESEND 0/3] selftests: Skip SUD tests when unsupported
Christian Loehle
[PATCH RESEND 2/3] selftests/syscall_user_dispatch: Skip tests if SUD is unsupported
Christian Loehle
[PATCH RESEND 1/3] selftests/ptrace: Skip get_set_sud if SUD is unsupported
Christian Loehle
[PATCH RESEND 3/3] selftests/syscall_user_dispatch: Skip benchmark if SUD is unsupported
Christian Loehle
Re: [PATCH RFC 0/3] security: ima: support TSM measurement registers
Yeoreum Yun
Re: [PATCH RFC 0/3] security: ima: support TSM measurement registers
GONG Ruiqi
Re: [PATCH RFC 0/3] security: ima: support TSM measurement registers
Jason Gunthorpe
[PATCH net-next v7 0/4] net: mana: concurrent HWC requests and dynamic queue depth
Wei Hu
[PATCH net-next v7 1/4] net: mana: prepare HWC ownership for safe reinitialization
Wei Hu
Re: [PATCH net-next v7 1/4] net: mana: prepare HWC ownership for safe reinitialization
netdev-bot+sashiko
RE: [EXTERNAL] Re: [PATCH net-next v7 1/4] net: mana: prepare HWC ownership for safe reinitialization
Wei Hu
[PATCH net-next v7 2/4] net: mana: give each HWC message slot its own completion state
Wei Hu
Re: [PATCH net-next v7 2/4] net: mana: give each HWC message slot its own completion state
netdev-bot+sashiko
RE: [EXTERNAL] Re: [PATCH net-next v7 2/4] net: mana: give each HWC message slot its own completion state
Wei Hu
[PATCH net-next v7 3/4] net: mana: support concurrent HWC requests
Wei Hu
Re: [PATCH net-next v7 3/4] net: mana: support concurrent HWC requests
netdev-bot+sashiko
RE: [EXTERNAL] Re: [PATCH net-next v7 3/4] net: mana: support concurrent HWC requests
Wei Hu
[PATCH net-next v7 4/4] net: mana: add dynamic HWC queue depth with reinit path
Wei Hu
Re: [PATCH net-next v7 4/4] net: mana: add dynamic HWC queue depth with reinit path
netdev-bot+sashiko
Earlier messages
Later messages