[ 
https://jira.codehaus.org/browse/MPLUGIN-196?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Herve Boutemy updated MPLUGIN-196:
----------------------------------

      Description: 
the actual name isn't intuitive at all.
It would be more intuitive if we replaced
{code:java}/**
 * @parameter default-value="a default value" expression="a property"
 */
 String first;

 @Parameter( defaultValue = "a default value", expression = "a property" )
 String second;{code}
with
{code:java}/**
 * @parameter default-value="a default value" property="a property"
 */
 String first;

 @Parameter( defaultValue = "a default value", property = "a property" )
 String second;{code}

The move could be done in a compatible way, deprecating the previous expression 
javadoc tag.
And ${ } would be forbidden for property, where it was required previously for 
expression and made optional since MPLUGIN-194

  was:
the actual name isn't intuitive at all.
It would be more intuitive if we replaced
{noformat}@parameter default-value="a default value" expression="a property"
@Parameter( defaultValue = "a default value", expression = "a property" 
){noformat}
with
{noformat}@parameter default-value="a default value" property="a property"
@Parameter( defaultValue = "a default value", property = "a property" 
){noformat}

The move could be done in a compatible way, deprecating the previous expression 
javadoc tag.
And ${ } would be forbidden for property, where it was required previously for 
expression and made optional since MPLUGIN-194

    Fix Version/s: 3.0
    
> rename expression parameter to property
> ---------------------------------------
>
>                 Key: MPLUGIN-196
>                 URL: https://jira.codehaus.org/browse/MPLUGIN-196
>             Project: Maven 2.x Plugin Tools
>          Issue Type: Wish
>          Components: maven-plugin-annotations, maven-plugin-tools-java, 
> maven-plugin-tools-javadoc
>    Affects Versions: 2.9
>            Reporter: Herve Boutemy
>             Fix For: 3.0
>
>
> the actual name isn't intuitive at all.
> It would be more intuitive if we replaced
> {code:java}/**
>  * @parameter default-value="a default value" expression="a property"
>  */
>  String first;
>  @Parameter( defaultValue = "a default value", expression = "a property" )
>  String second;{code}
> with
> {code:java}/**
>  * @parameter default-value="a default value" property="a property"
>  */
>  String first;
>  @Parameter( defaultValue = "a default value", property = "a property" )
>  String second;{code}
> The move could be done in a compatible way, deprecating the previous 
> expression javadoc tag.
> And ${ } would be forbidden for property, where it was required previously 
> for expression and made optional since MPLUGIN-194

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://jira.codehaus.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Reply via email to