[ https://issues.apache.org/jira/browse/SOLR-14861?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17213282#comment-17213282 ]
Gus Heck commented on SOLR-14861: --------------------------------- Sorry didn't mean to sound accusatory. I guess I'm not understanding this: How is reload "complete" if it's time-sliced out.. that sounds like it's not "complete" to me. Looking at the test specifically, it appears to create 5 threads start them and then thread.join all of them, if reload is timesliced out, the thread in question shouldn't' be finished (unless the reload call is happening async which would be the problem I'm talking about) and the join should continue to block preventing the test harness from shutting down (because the test method isn't finished). Alternately maybe I'm confused about who is calling shutdown? Looking into the sub-methods I find another example of what I'm talking about even though it shouldn't actually cause failure here unless perhaps this heuristic can pass before reload completes... {code:java} RestTestHarness publisher = randomRestTestHarness(r); String response = publisher.post("/schema", SolrTestCaseJ4.json(payload)); {code} should be blocking until the core is reloaded and changes are safe for use by the caller (IMHO). The subsequent loop should not be needed: {code:java} try { long startTime = System.nanoTime(); long maxTimeoutMillis = 100000; while (TimeUnit.MILLISECONDS.convert(System.nanoTime() - startTime, TimeUnit.NANOSECONDS) < maxTimeoutMillis) { errmessages.clear(); Map m = getObj(harness, aField, "fields"); if (m != null) errmessages.add(StrUtils.formatString("field {0} still exists", aField)); m = getObj(harness, dynamicFldName, "dynamicFields"); if (m != null) errmessages.add(StrUtils.formatString("dynamic field {0} still exists", dynamicFldName)); List l = getSourceCopyFields(harness, aField); if (checkCopyField(l, aField, dynamicCopyFldDest)) errmessages.add(StrUtils.formatString("CopyField source={0},dest={1} still exists", aField, dynamicCopyFldDest)); m = getObj(harness, newFieldTypeName, "fieldTypes"); if (m != null) errmessages.add(StrUtils.formatString("new type {0} still exists", newFieldTypeName)); if (errmessages.isEmpty()) break; Thread.sleep(10); } {code} As for code after shutdown, It looks like people may have read isShutDown two different ways perhaps? Maybe we need two flags with clearer names... isShutDownComplete and isShutDownInProgress? > CoreContainer shutdown needs to be aware of other ongoing operations and wait > until they're complete > ---------------------------------------------------------------------------------------------------- > > Key: SOLR-14861 > URL: https://issues.apache.org/jira/browse/SOLR-14861 > Project: Solr > Issue Type: Bug > Reporter: Erick Erickson > Assignee: Erick Erickson > Priority: Major > Attachments: SOLR-14861.patch > > > Noble and I are trying to get to the bottom of the TestBulkSchemaConcurrent > failures and found what looks like a glaring gap in how > CoreContainer.shutdown operates. I don't know the impact on production since > we're shutting down anyway, but I think this is responsible for the errors in > TestBulkSchemaConcurrent and likely behind others, especially any other test > that fails intermittently that involves core reloads, including and > especially any tests that exercise managed schema. > We have clear evidence of this sequence: > 1> some CoreContainer.reloads come in and get _partway_ through, in > particular past the test at the top where CoreContainer.reload() throws an > AlreadyClosed exception if (isShutdown). > 2> Some CoreContainer.shutdown() threads get some processing time before the > reloads in <1> are finished. > 3> the threads in <1> pick back up and go wonky. I suspect that there are a > number of different things that could be going wrong here depending on how > far through CoreContainer.shutdown() gets that pop out in different ways. > Since it's my shift (Noble has to sleep sometime), I put some crude locking > in just to test the idea; incrementing an AtomicInteger on entry to > CoreContainer.reload then decrementing it at the end, and spinning in > CoreContainer.shutdown() until the AtomicInteger was back to zero. With that > in place, 100 runs and no errors whereas before I could never get even 10 > runs to finish without an error. This is not a proper fix at all, and the way > it's currently running there are still possible race conditions, just much > smaller windows. And I suspect it risks spinning forever. But it's enough to > make me believe I finally understand what's happening. > I also suspect that reload is more sensitive than most operations on a core > due to the fact that it runs for a long time, but I assume other operations > have the same potential. Shouldn't CoreContainer.shutDown() wait until no > other operations are in flight? > On a quick scan of CoreContainer, there are actually few places where we even > check for isShutdown, I suspect the places we do are ad-hoc that we've found > by trial-and-error when tests fail. We need a design rather than hit-or-miss > hacking. > I think that isShutdown should be replaced with something more robust. What > that is IDK quite yet because I've been hammering at this long enough and I > need a break. > This is consistent with another observation about this particular test. If > there's sleep at the end, it wouldn't fail; all the reloads get a chance to > finish before anything was shut down. > An open question how much this matters to production systems. In the testing > case, bunches of these reloads are issued then we immediately end the test > and start shutting things down. It needs to be fixed if we're going to cut > down on test failures though. Besides, it's just wrong ;) > Assigning to myself to track. I'd be perfectly happy, now that Noble and I > have done the hard work, for someone to swoop in and take the credit for > fixing it ;) > gradlew beast -Ptests.dups=10 --tests TestBulkSchemaConcurrent > always fails for me on current code without my hack... -- This message was sent by Atlassian Jira (v8.3.4#803005) --------------------------------------------------------------------- To unsubscribe, e-mail: issues-unsubscr...@lucene.apache.org For additional commands, e-mail: issues-h...@lucene.apache.org