On Thu, Apr 6, 2017 at 1:28 PM, Nathan Sidwell <nat...@acm.org> wrote:
> Let's try this one then.

I'd call this

+  if (result == TYPE_CANONICAL (result))
+    /* Copy so we don't give the canonical type a name.  */
+    result = build_variant_type_copy (result);

premature optimization -- I wonder if anything breaks if you always copy?
(that is, I expect result is always the canonical type here?)

Richard.

> nathan
>
> --
> Nathan Sidwell

Reply via email to