Moti Asayag has posted comments on this change. Change subject: gluster: Disable gluster cli based snapshot scheduling ......................................................................
Patch Set 24: (4 comments) https://gerrit.ovirt.org/#/c/39945/24/backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GetGlusterVolumeSnapshotCliScheduleFlagQuery.java File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GetGlusterVolumeSnapshotCliScheduleFlagQuery.java: Line 9: } Line 10: Line 11: @Override Line 12: public void executeQueryCommand() { Line 13: VDSGroup cluster = getVdsGroupDao().get(getParameters().getId()); you can use injection for VdsGroupDao instead. Line 14: getQueryReturnValue().setReturnValue(cluster.isGlusterCliBasedSchedulingOn()); Line 15: } https://gerrit.ovirt.org/#/c/39945/24/backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterSyncJob.java File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/GlusterSyncJob.java: Line 563: new GlusterVolumeActionParameters(volume.getId(), false), Line 564: ExecutionHandler.createInternalJobContext()); Line 565: Line 566: if (!returnValue.getSucceeded()) { Line 567: log.warn("Unbale to set volume snapshot scheduling flag to gluster CLI scheduler"); no need to provide more info about which volume or cluster ? Line 568: } else { Line 569: logUtil.logVolumeMessage(volume, AuditLogType.GLUSTER_CLI_SNAPSHOT_SCHEDULE_DISABLED); Line 570: } Line 571: } Line 580: } Line 581: } Line 582: } Line 583: } Line 584: please replace this with injection in the future. Line 585: public BackendInternal getBackend() { Line 586: return Backend.getInstance(); Line 587: } Line 588: https://gerrit.ovirt.org/#/c/39945/24/backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/ScheduleGlusterVolumeSnapshotCommand.java File backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/gluster/ScheduleGlusterVolumeSnapshotCommand.java: Line 43: handleVdsError(AuditLogType.GLUSTER_VOLUME_SNAPSHOT_SCHEDULE_FAILED, ex.getMessage()); Line 44: } Line 45: } Line 46: Line 47: private boolean checkAndDisableCLIScheduler() { according to camelCase naming convention it should be: checkAndDisableCliScheduler Line 48: GlusterVolumeEntity metaVolume = Line 49: getGlusterVolumeDao().getByName(getVdsGroupId(), Line 50: Config.<String> getValue(ConfigValues.GlusterMetaVolumeName)); Line 51: VDSGroup cluster = getVdsGroup(); -- To view, visit https://gerrit.ovirt.org/39945 To unsubscribe, visit https://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I6bc06f246f30769c5edaf981876c2a51ddd4fffd Gerrit-PatchSet: 24 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Shubhendu Tripathi <shtri...@redhat.com> Gerrit-Reviewer: Eli Mesika <emes...@redhat.com> Gerrit-Reviewer: Jenkins CI Gerrit-Reviewer: Kanagaraj M <kmayi...@redhat.com> Gerrit-Reviewer: Moti Asayag <masa...@redhat.com> Gerrit-Reviewer: Ramesh N <rnach...@redhat.com> Gerrit-Reviewer: Sahina Bose <sab...@redhat.com> Gerrit-Reviewer: Shubhendu Tripathi <shtri...@redhat.com> Gerrit-Reviewer: anmolbabu <anb...@redhat.com> Gerrit-Reviewer: automat...@ovirt.org Gerrit-HasComments: Yes _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches