Allon Mureinik has posted comments on this change. Change subject: core: QuotaManager Test - test 1 ......................................................................
Patch Set 4: I would prefer that you didn't submit this (1 inline comment) -1 on the naming, +1 on everything else. Consider using ParameterizedRunner or Theories, it may save a whole bunch of code. .................................................... File backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/quota/QuotaManagerTest.java Line 151: assertFalse(EXPECTED_NO_AUDIT_LOG_MESSAGE, auditLogWritten); Line 152: } Line 153: Line 154: @Test Line 155: public void testValidateAndSetStorageQuota_1() throws Exception { I'm sure you can come up with a better name than this :-) And even better - if all these tests are so similar, consider using ParameterizedRunner or Theories. Line 156: List<StorageQuotaValidationParameter> parameters = new ArrayList<StorageQuotaValidationParameter>(); Line 157: parameters.add(new StorageQuotaValidationParameter(STORAGE_QUOTA_GLOBAL_NOT_EXCEEDED, DESTINATION_GUID, 1)); Line 158: assertTrue(quotaManager.validateAndSetStorageQuota(storage_pool, parameters, canDoActionMessages)); Line 159: assertEmptyCanDoActionMessage(); -- To view, visit http://gerrit.ovirt.org/8439 To unsubscribe, visit http://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I374769dfcc4bb99de2e578d4267fb03484d9c63f Gerrit-PatchSet: 4 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: ofri masad <oma...@redhat.com> Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com> Gerrit-Reviewer: Doron Fediuck <dfedi...@redhat.com> Gerrit-Reviewer: Gilad Chaplik <gchap...@redhat.com> Gerrit-Reviewer: Laszlo Hornyak <lhorn...@redhat.com> Gerrit-Reviewer: ofri masad <oma...@redhat.com> _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches