Sahina Bose has posted comments on this change. Change subject: engine: Added username to geo-rep commands ......................................................................
Patch Set 1: (4 comments) https://gerrit.ovirt.org/#/c/39485/1/backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/jsonrpc/JsonRpcVdsServer.java File backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/jsonrpc/JsonRpcVdsServer.java: Line 1648: String slaveVolumeName, Line 1649: String slaveUserName) { Line 1650: JsonRpcRequest request = Line 1651: new RequestBuilder("GlusterVolume.geoRepSessionList").withParameter("volumeName", volumeName) Line 1652: .withParameter("remoteHost", slaveHost) > Can we have all these parameters here as optionalParameters? will try that in a separate patch Line 1653: .withParameter("remoteVolumeName", slaveVolumeName) Line 1654: .withOptionalParameter("remoteUserName", slaveUserName).build(); Line 1655: Map<String, Object> response = new FutureMap(this.client, request).withIgnoreResponseKey(); Line 1656: return new GlusterVolumeGeoRepStatusForXmlRpc(response); https://gerrit.ovirt.org/#/c/39485/1/backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/IVdsServer.java File backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/IVdsServer.java: Line 383: StatusOnlyReturnForXmlRpc glusterVolumeGeoRepConfigReset(String volumeName, Line 384: String slaveHost, Line 385: String slaveVolumeName, Line 386: String configKey, Line 387: String slaveUserName); > In parameters we use username so it would be good to have naming consistent Done Line 388: Line 389: GlusterVolumeGeoRepConfigListXmlRpc glusterVolumeGeoRepConfigList(String volumeName, Line 390: String slaveHost, Line 391: String slaveVolumeName, https://gerrit.ovirt.org/#/c/39485/1/backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VdsServerConnector.java File backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VdsServerConnector.java: Line 286: Line 287: public Map<String, Object> glusterHookAdd(String glusterCommand, Line 288: String stage, Line 289: String hookName, Line 290: String content, > Please undo this Done Line 291: String checksum, Line 292: Boolean enabled); Line 293: Line 294: public Map<String, Object> glusterHookRemove(String glusterCommand, String stage, String hookName); Line 329: Line 330: public Map<String, Object> glusterVolumeGeoRepSessionPause(String masterVolumeName, Line 331: String slaveHost, Line 332: String slaveVolumeName, Line 333: String slaveUserName, > please consider renaming it to remoteUserName as we are anyway Introducing will keep it consistent as username Line 334: boolean force); Line 335: Line 336: public Map<String, Object> glusterVolumeGeoRepSessionList(); Line 337: -- To view, visit https://gerrit.ovirt.org/39485 To unsubscribe, visit https://gerrit.ovirt.org/settings Gerrit-MessageType: comment Gerrit-Change-Id: I3fcdc7c29abb88916eacc048f2708ea68540134a Gerrit-PatchSet: 1 Gerrit-Project: ovirt-engine Gerrit-Branch: master Gerrit-Owner: Sahina Bose <sab...@redhat.com> Gerrit-Reviewer: Piotr Kliczewski <piotr.kliczew...@gmail.com> Gerrit-Reviewer: Sahina Bose <sab...@redhat.com> Gerrit-Reviewer: anmolbabu <anb...@redhat.com> Gerrit-Reviewer: automat...@ovirt.org Gerrit-Reviewer: oVirt Jenkins CI Server Gerrit-HasComments: Yes _______________________________________________ Engine-patches mailing list Engine-patches@ovirt.org http://lists.ovirt.org/mailman/listinfo/engine-patches