Einav Cohen has posted comments on this change.

Change subject: UI: change Make-Template to more readable text (#848104)
......................................................................


Patch Set 3: (1 inline comment)

....................................................
File 
frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/VmListModel.java
Line 1645:         AddVmTemplateParameters addVmTemplateParameters =
Line 1646:                 new AddVmTemplateParameters(newvm,
Line 1647:                         (String) model.getName().getEntity(),
Line 1648:                         (String) model.getDescription().getEntity());
Line 1649:         addVmTemplateParameters.setPublicUse(!(Boolean) 
model.getIsTemplatePublic().getEntity());
could be.


I actually prefer that the model's property will be logically the same as the 
backend parameter (i.e. if the backend parameter is named "PublicUse", then the 
model's property should be named "IsTemplatePublic" and represent the same 
thing - less confusing that way). It will also match the check-box name (which 
now practically means "make public" instead of the old "make private").


So the code here should actually be the old code, before the change (i.e. 
parameters.setPublicUse(model.IsTemplatePublic), but you need to make sure that 
the check-box "checked" value matches the model.IsTemplatePublic value 
appropriately (i.e. when the check-box is checked, the model.IsTemplatePublic 
value should be "true"; when check-box is un-checked, model.IsTemplatePublic 
should be "false").
Line 1650: 
Line 1651:         addVmTemplateParameters.setDiskInfoDestinationMap(
Line 1652:                 model.getDisksAllocationModel()
Line 1653:                         .getImageToDestinationDomainMap((Boolean) 
model.getDisksAllocationModel()


--
To view, visit http://gerrit.ovirt.org/7216
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I9055763d66b09da175810ad3ba2ace0ff8316264
Gerrit-PatchSet: 3
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Shahar Havivi <shav...@redhat.com>
Gerrit-Reviewer: Daniel Erez <de...@redhat.com>
Gerrit-Reviewer: Einav Cohen <eco...@redhat.com>
Gerrit-Reviewer: Shahar Havivi <shav...@redhat.com>
Gerrit-Reviewer: oVirt Jenkins CI Server
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to