Martin Mucha has posted comments on this change.

Change subject: core: scanning of configured NICs for health
......................................................................


Patch Set 9:

(4 comments)

http://gerrit.ovirt.org/#/c/34222/9/backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/enginehealth/NicsHealthCheckManager.java
File 
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/enginehealth/NicsHealthCheckManager.java:

Line 74:         log.debug("Performing engine NICs health check on: " + 
nicsToString(nicsToCheck));
Line 75: 
Line 76:         checkNicsAndUpdateEngineStatus(nicsToCheck);
Line 77: 
Line 78:         log.debug("Health check done, engine NICs are {}.", 
(engineNicHealthCache.isAllNicHealthy() ? "healthy" : "unhealthy"));
> Please remove unnecessary bracket around ternary operator
Done
Line 79:     }
Line 80: 
Line 81:     public boolean isSystemHealthy() {
Line 82:         return engineNicHealthCache.isAllNicHealthy();


Line 95:     private boolean isNicHealthy(NetworkInterface networkInterface)  {
Line 96:         try {
Line 97:             return networkInterface.isUp();
Line 98:         } catch (SocketException e) {
Line 99:             log.warn("Unable to get network interface '{}' status, 
pronouncing it unhealthy. Due to {}",
> Please remove "Due to" string from message:
sorry, I thought this would be more readable
Done
Line 100:                     networkInterface.getDisplayName(), 
e.getMessage());
Line 101:             log.debug("Exception", e);
Line 102:             return false;
Line 103:         }


Line 106:     /**
Line 107:      * @return string representation of NetworkInterface list for 
logging purposes.
Line 108:      */
Line 109:     private String nicsToString(List<NetworkInterface> 
networkInterfaces) {
Line 110:         return 
StringUtils.join(toNicsDisplayNames(networkInterfaces), ", ");
> Method nicsToString is called only once, so it's better to call StringUtils
I thought this would be more readable, inlined
DONE
Line 111:     }
Line 112: 
Line 113:     private List<String> toNicsDisplayNames(List<NetworkInterface> 
networkInterfaces) {
Line 114:         List<String> result = new ArrayList<>();


http://gerrit.ovirt.org/#/c/34222/9/backend/manager/modules/dal/src/main/resources/bundles/AuditLogMessages.properties
File 
backend/manager/modules/dal/src/main/resources/bundles/AuditLogMessages.properties:

Line 626: VDS_ALERT_PM_HEALTH_CHECK_FAILED_FOR_SEQ_SECONDARY_AGENT=Health check 
failed on Host ${VdsName} secondary sequential agent, future fence operations 
may fail if primary agent is not defined properly.
Line 627: VDS_ALERT_FENCE_OPERATION_SKIPPED_BROKEN_CONNECTIVITY=Host ${VdsName} 
became non responsive and was not restarted due to Fencing Policy: ${Percents} 
percents of the Hosts in the Cluster have connectivity issues.
Line 628: VDS_ALERT_NOT_RESTARTED_DUE_TO_POLICY=Host ${VdsName} became non 
responsive and was not restarted due to the Cluster Fencing Policy.
Line 629: VDS_ALERT_FENCE_DISABLED_BY_CLUSTER_POLICY=Host ${VdsName} became Non 
Responsive and was not restarted due to disabled fencing in the Cluster Fencing 
Policy.
Line 630: VDS_ALERT_FENCE_TEMPORARILY_DISABLED_DUE_TO_UNHEALTHY_SYSTEM=Host 
${VdsName} became Non Responsive and was not restarted due to unhealthy system 
state.
> I would rephrase to:
Done
Line 631: VDS_HOST_NOT_RESPONDING_CONNECTING=Host ${VdsName} is not responding. 
It will stay in Connecting state for a grace period of ${Seconds} seconds and 
after that an attempt to fence the host will be issued.
Line 632: TASK_STOPPING_ASYNC_TASK=Stopping async task ${CommandName} that 
started at ${Date}
Line 633: REFRESH_REPOSITORY_IMAGE_LIST_FAILED=Refresh image list failed for 
domain(s): ${imageDomains}. Please check domain activity.
Line 634: REFRESH_REPOSITORY_IMAGE_LIST_SUCCEEDED=Refresh image list succeeded 
for domain(s): ${imageDomains}


-- 
To view, visit http://gerrit.ovirt.org/34222
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I3c092ab5d3cf33e1ef83cd0225d2803733fbde89
Gerrit-PatchSet: 9
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Martin Mucha <mmu...@redhat.com>
Gerrit-Reviewer: Lior Vernia <lver...@redhat.com>
Gerrit-Reviewer: Martin Mucha <mmu...@redhat.com>
Gerrit-Reviewer: Martin Peřina <mper...@redhat.com>
Gerrit-Reviewer: Oved Ourfali <oourf...@redhat.com>
Gerrit-Reviewer: automat...@ovirt.org
Gerrit-Reviewer: oVirt Jenkins CI Server
Gerrit-HasComments: Yes
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to