Allon Mureinik has posted comments on this change.

Change subject: engine: Adding tests for VdcQueryType
......................................................................


Patch Set 1: (3 inline comments)

....................................................
File 
backend/manager/modules/bll/src/main/java/org/ovirt/engine/core/bll/QueriesCommandBase.java
Line 61: 
Originally this was private for security reasons (preventing Overriding it), 
but I agree this may be a bit paranoid, as VdcCommandBase does the same...

If you're adding this access method, please kill off 
TestHelperQueriesCommandType which is a disgusting hack to handle accessing the 
private field.


BTW, I think "public" is a bit pushing it - how about protected?

....................................................
File 
backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/AbstractQueryTest.java
Line 83:     public void testQueryType() {
Consider user assertNotSame - it's more readable.

Aslo, why not static import the method from Assert?

....................................................
File 
backend/manager/modules/bll/src/test/java/org/ovirt/engine/core/bll/AbstractUserQueryTest.java
Line 63: 
Isn't this is exactly what the testQueryIsAUserQuery() does?

--
To view, visit http://gerrit.ovirt.org/2438
To unsubscribe, visit http://gerrit.ovirt.org/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I6591190bc5f4a7d9445eea1ecd34da0c79564e25
Gerrit-PatchSet: 1
Gerrit-Project: ovirt-engine
Gerrit-Branch: master
Gerrit-Owner: Maor Lipchuk <mlipc...@redhat.com>
Gerrit-Reviewer: Allon Mureinik <amure...@redhat.com>
_______________________________________________
Engine-patches mailing list
Engine-patches@ovirt.org
http://lists.ovirt.org/mailman/listinfo/engine-patches

Reply via email to