On 7/5/26 9:13 PM, Anna Maniscalco wrote: > Program all the register needed to start up LPAC and send initialization > sequence. > > Additionally, now that the LPAC ring is live, make the code aware of it. > > Signed-off-by: Anna Maniscalco <[email protected]> > ---
I believe some/all of these writes need to be guarded by if (has_lpac), as many GPUs lack these registers and there may be side effects on others [...] > a6xx_gpu->shadow = msm_gem_kernel_new(gpu->dev, > - sizeof(u32) * > gpu->nr_rings, > + sizeof(u32) * > (gpu->nr_rings + !!gpu->lpac_rb), Should we rename nr_rings to something like nr_XXX_rings where XXX is some uarch-generic (i.e. not SQE because we also support pre-a6xx) name for the main number cruncher? Konrad
