On 2014-07-03 11:37, Daniel Cederman wrote:
  /**
+ *  @brief Sends a SMP message to a set of processors.
+ *
+ *  The sending processor may be part of the set.
+ *
+ *  @param[in] cpus The set of target processors of the message.
+ *  @param[in] message The message.
+ */
+void _SMP_Send_message_cpu_set( const cpu_set_t *cpus, uint32_t message );

What about naming this _SMP_Send_message_multicast()? So we that we have

_SMP_Send_message()
_SMP_Send_message_multicast()
_SMP_Send_message_broadcast()

--
Sebastian Huber, embedded brains GmbH

Address : Dornierstr. 4, D-82178 Puchheim, Germany
Phone   : +49 89 189 47 41-16
Fax     : +49 89 189 47 41-09
E-Mail  : sebastian.hu...@embedded-brains.de
PGP     : Public key available on request.

Diese Nachricht ist keine geschäftliche Mitteilung im Sinne des EHUG.
_______________________________________________
devel mailing list
devel@rtems.org
http://lists.rtems.org/mailman/listinfo/devel

Reply via email to