hokein marked an inline comment as done. ================ Comment at: clang-tidy/misc/UnusedUsingDeclsCheck.cpp:24 @@ +23,3 @@ +// FIXME: Move this node matcher to ASTMatcher. +AST_MATCHER(Stmt, unresolvedLookupExpr) { + return isa<UnresolvedLookupExpr>(Node); ---------------- alexfh wrote: > That's because we need a node matcher, not narrowing matcher. I guess, this > should work: > > const internal::VariadicAllOfMatcher<UnresolvedLookupExpr> > unresolvedLookupExpr; Yeah. But as the name indicates, `VariadicAllOfMatcher` is used internally in ASTMatcher, is it reasonable to use it here? I can't find such usage in clang-tidy side.
http://reviews.llvm.org/D20326 _______________________________________________ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits