pdhaliwal added inline comments.

================
Comment at: clang/lib/Driver/Driver.cpp:755
+                      *this, TT, *HostTC, C.getInputArgs(), 
Action::OFK_OpenMP);
+                else if (TT.isAMDGCN())
+                  DeviceTC =
----------------
JonChesterfield wrote:
> Minor suggestion,
> ```
> if (TT.isNVPTX() {
>  ...
> } else {
>   assert(TT.isAMDGCN());
>   ...
> }```
> 
> ? Semantically equivalent, but `if () else if ()` looks like there is a 
> missing else clause.
I think, having assert in last else is bit cleaner.  What do you think?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D94961/new/

https://reviews.llvm.org/D94961

_______________________________________________
cfe-commits mailing list
cfe-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Reply via email to