Hi Akim, > Or completely change: all the bitsets of a bitsetv have the same dimension, > so we could go to bitmatrix.
On the other hand, the module does not implement matrix operations (matrix multiplication, transposition, determinant), only transitive closure (which maybe is not so suitable for gnulib and should stay in Bison?). The definition 'typedef bitset * bitsetv;' is really an array of bitsets. > I went for 'bitset/vector.h': same initial, and clear meaning (to me?). Good idea. Yes, 'vector' commonly means an array of variable size (as in C++, Common Lisp, Java, ...). This also means that bitsetv.h should probably be renamed to bitset-array.h, not bitset-vector.h. > Currently bitset/ is only about implementation details, so I don't think > bitset vectors should be part of bitset/. I agree. The name conflict between bitset-vector.h and bitset/vector.h is superficial; given that only the implementor knows about the second one, I find it acceptable. Bruno