Right - I'd just have the data dir be generic (like core0, core1 as you have i example 2) and then the names will be live and offline and flip back and forth between the core0, core1 dirs.

On 03/28/2010 04:06 PM, Blargy wrote:
Mark, first off thanks for the response. Im glad someone is around today ;)

So this is what I have so far:

<solr persistent="true" sharedLib="lib">
   <cores adminPath="/admin/cores" shareSchema="true">
     <core name="items-live" instanceDir="items" default="true"
dataDir="data/live"/>
     <core name="items-offline" instanceDir="items" default="true"
dataDir="data/offline"/>
   </cores>
</solr>

So my directory structure is:

home/items/data/live/index
home/items/data/offline/index

So after playing around I see that swap literally just swaps the dataDir in
solr.xml. I have peristent = true so it saves which core is pointing to
which dataDir. So where I think I am a little confused is the naming
convention I used above. In this type of setup there is no such thing as a
live or offline dataDir as at any point they can be one or the other... the
core name is what really matters. So Im guessing this naming convention
makes a little more sense

<solr persistent="true" sharedLib="lib">
   <cores adminPath="/admin/cores" shareSchema="true">
     <core name="items-live" instanceDir="items" default="true"
dataDir="data/core0"/>
     <core name="items-offline" instanceDir="items" default="true"
dataDir="data/core1"/>
   </cores>
</solr>

Sine the actually dataDir name really doesnt mean anything. Is this the
correct reasoning?


--
- Mark

http://www.lucidimagination.com



Reply via email to