davidedmundson updated this revision to Diff 12807.
davidedmundson added a comment.
fixed spacing
CHANGES SINCE LAST UPDATE
https://phabricator.kde.org/D5172?vs=12801&id=12807
BRANCH
scaling_final
REVISION DETAIL
https://phabricator.kde.org/D5172
AFFECTED FILES
plugins/qpa/screen.cp
davidedmundson updated this revision to Diff 12806.
davidedmundson added a comment.
Restricted Application edited projects, added Plasma; removed KWin.
Restricted Application added a subscriber: KWin.
use pixelSize
REPOSITORY
R108 KWin
CHANGES SINCE LAST UPDATE
https://phabricator.kde.org
davidedmundson updated this revision to Diff 12804.
davidedmundson added a comment.
Restricted Application edited projects, added KWin; removed Plasma.
Rename Output::size to Output::pixelSize
This mirrors KWayland::Client::Output and is useful
to separate the two co-ordinate spaces.
subdiff added inline comments.
INLINE COMMENTS
> davidedmundson wrote in egl_gbm_backend.cpp:159
> I like that. Taking that one step further. I'll just make size() the native
> size and adjust the rest of the code to that.
Assuming that you mean with native size the unscaled output size: Just m
davidedmundson updated this revision to Diff 12801.
davidedmundson added a comment.
Updated
CHANGES SINCE LAST UPDATE
https://phabricator.kde.org/D5172?vs=12789&id=12801
BRANCH
scaling_final
REVISION DETAIL
https://phabricator.kde.org/D5172
AFFECTED FILES
plugins/qpa/screen.cpp
pl
davidedmundson added inline comments.
INLINE COMMENTS
> subdiff wrote in egl_gbm_backend.cpp:159
> Better: Add an additional variable of the "real" unscaled output size in
> DrmOutput with appropriate getter to also solve the rounding issue from the
> other Diff.
I like that. Taking that one s
graesslin accepted this revision.
graesslin added a comment.
This revision is now accepted and ready to land.
Apart from the two minor issues, looks good to me :)
INLINE COMMENTS
> markg wrote in screen.cpp:79
> c cast... no no no!
> static_cast(...)
is the cast needed at all? It should be i
subdiff added inline comments.
INLINE COMMENTS
> subdiff wrote in egl_gbm_backend.cpp:159
> You could add to `struct Output` a value for that, which you then use in
> makeContextCurrent.
Better: Add an additional variable of the "real" unscaled output size in
DrmOutput with appropriate getter
davidedmundson added a comment.
In https://phabricator.kde.org/D3504#97513, @subdiff wrote:
> Just a heads up: Atomic mode setting allows to scale buffers / content of a
plane directly instead of using GL. But I assume this would be possible to add
later.
Although it sort of look
graesslin added a dependency: D5174: Add support for
wl_shell_surface::set_popup and popup_done.
REPOSITORY
R108 KWin
REVISION DETAIL
https://phabricator.kde.org/D5177
To: graesslin, #plasma, #kwin
Cc: plasma-devel, kwin, progwolff, lesliezhai, ali-mohamed, hardening,
jensreuterberg, abett
graesslin added a dependent revision: D5177: Initial support for popup window
handling.
REPOSITORY
R127 KWayland
REVISION DETAIL
https://phabricator.kde.org/D5174
To: graesslin, #plasma_on_wayland, #frameworks, #kwin
Cc: plasma-devel, progwolff, lesliezhai, ali-mohamed, jensreuterberg, abet
graesslin created this revision.
Restricted Application added a project: KWin.
Restricted Application added subscribers: kwin, plasma-devel.
REVISION SUMMARY
So far KWin did not properly handle popup windows. That is when a popup
surface got created and a click outside the surface happened KWi
Zren added a comment.
And yes I know KDE Neon is Qt 5.7.1 at the moment, I meant to ask wither it's
part of the standard install of Qt.
REPOSITORY
R119 Plasma Desktop
REVISION DETAIL
https://phabricator.kde.org/D5170
To: Zren, hein
Cc: broulik, plasma-devel, progwolff, lesliezhai, ali-m
Zren added a comment.
Oh neat! Hmm experimental Qt 5.8 library is fine, but would it be installed
by default on say KDE Neon or would it need a package to be manually installed?
REPOSITORY
R119 Plasma Desktop
REVISION DETAIL
https://phabricator.kde.org/D5170
To: Zren, hein
Cc: broulik,
subdiff added a comment.
Just a heads up: Atomic mode setting allows to scale buffers / content of a
plane directly instead of using GL. But I assume this would be possible to add
later.
Something else: How does this work, when Gl / compositing is skipped (i.e. in
my case for the direct
subdiff requested changes to this revision.
subdiff added inline comments.
This revision now requires changes to proceed.
INLINE COMMENTS
> scene_qpainter_drm_backend.cpp:67
> auto initBuffer = [&o, output, this] (int index) {
> -o.buffer[index] = m_backend->createBuffer(output->size
graesslin created this revision.
Restricted Application added a subscriber: plasma-devel.
Restricted Application added projects: Plasma on Wayland, Frameworks.
REVISION SUMMARY
This extends the client side API to support creating popup ShellSurface
windows and the server side API to send out t
markg added inline comments.
INLINE COMMENTS
> screen.cpp:25
> #include
> +#include
>
Looks like its unused.
> screen.cpp:79
> +{
> +return = m_output ? (qreal)m_output->scale() : 1.0;
> +}
c cast... no no no!
static_cast(...)
REVISION DETAIL
https://phabricator.kde.org/D5172
To:
rthomsen marked an inline comment as done.
REPOSITORY
R102 KInfoCenter
REVISION DETAIL
https://phabricator.kde.org/D5169
To: rthomsen, #plasma, elvisangelaccio
Cc: cfeck, plasma-devel, progwolff, lesliezhai, ali-mohamed, jensreuterberg,
abetts, sebas, apol
rthomsen edited the summary of this revision.
REPOSITORY
R102 KInfoCenter
REVISION DETAIL
https://phabricator.kde.org/D5169
To: rthomsen, #plasma, elvisangelaccio
Cc: cfeck, plasma-devel, progwolff, lesliezhai, ali-mohamed, jensreuterberg,
abetts, sebas, apol
rthomsen updated this revision to Diff 12793.
rthomsen added a comment.
- Also port the libraw1394 module.
- Fix tab indentation.
REPOSITORY
R102 KInfoCenter
CHANGES SINCE LAST UPDATE
https://phabricator.kde.org/D5169?vs=12779&id=12793
REVISION DETAIL
https://phabricator.kde.org/D516
davidedmundson added a comment.
As discussed when I met at the Plasma sprint - changing the viewport is
semantically exactly what we want.
Yes it does break many things, but I have also (hopefullly!) fixed those many
things.
Can you reconsider this and https://phabricator.kde.org/D3500
davidedmundson updated this revision to Diff 12790.
davidedmundson added a comment.
Restricted Application edited projects, added Plasma; removed KWin.
Restricted Application added a subscriber: KWin.
Set m_output as well as m_outputDevice
REPOSITORY
R108 KWin
CHANGES SINCE LAST UPDATE
ht
davidedmundson created this revision.
Restricted Application added a project: Plasma.
Restricted Application added a subscriber: plasma-devel.
REVISION SUMMARY
Basically just a copy and paste from the relevant Qt Wayland parts.
BRANCH
scaling_final
REVISION DETAIL
https://phabricator.kde.o
drosca added a comment.
> Does PulseAudio have any DBus service? The applet could be DBus activated,
too
Yes, but on its own connection, so I assume not supported to be DBus
activated by plasma.
REPOSITORY
R115 Plasma Audio Volume Applet
REVISION DETAIL
https://phabricator.kde.org/
broulik added a comment.
Does PulseAudio have any DBus service? The applet could be DBus activated, too
REPOSITORY
R115 Plasma Audio Volume Applet
REVISION DETAIL
https://phabricator.kde.org/D5171
To: drosca, #plasma
Cc: broulik, plasma-devel, progwolff, lesliezhai, ali-mohamed, jensreut
drosca created this revision.
Restricted Application added a project: Plasma.
Restricted Application added a subscriber: plasma-devel.
REVISION SUMMARY
Instead of trying reconnect only once after pulseaudio crashes, try
to reconnect with 1 second intervals.
BUG: 358772
TEST PLAN
This w
https://bugs.kde.org/show_bug.cgi?id=376121
CnZhx changed:
What|Removed |Added
CC||z...@cnzhx.net
--- Comment #1 from CnZhx ---
I don't s
28 matches
Mail list logo