From: Hideo AOKI <[EMAIL PROTECTED]>
Date: Sun, 30 Dec 2007 03:51:44 -0500
> To consolidate memory accounting functions, this patch adds memory
> accounting calls to network core functions. Moreover, present
> memory accounting call is renamed to new accounting call.
>
> Cc: Satoshi Oshima <[EMAI
From: Hideo AOKI <[EMAIL PROTECTED]>
Date: Sun, 30 Dec 2007 03:47:33 -0500
> Hello,
>
> This patch set introduces new memory accounting interface.
> Current interface is written for stream protocols only.
> To enable memory accounting in other protocols (e.g. UDP),
> I enhanced the interface and
From: Gui Jianfeng <[EMAIL PROTECTED]>
Date: Fri, 28 Dec 2007 15:12:28 +0800
> There are useless codes in fib6_del_route(). The following patch
> has been tested, every thing looks fine, as usual.
>
> Signed-off-by: Gui Jianfeng<[EMAIL PROTECTED]>
Patch applied to net-2.6.25, thanks.
--
To unsub
From: "Rami Rosen" <[EMAIL PROTECTED]>
Date: Fri, 28 Dec 2007 17:56:46 +0200
> It seems to me that neigh_is_valid() inline method from
> include/net/neighbour.h can be removed since it is not used.
>
> Though it can be considered as an API for future use, and
> indeed we have neigh_is_connected()
From: "Rami Rosen" <[EMAIL PROTECTED]>
Date: Fri, 28 Dec 2007 17:20:34 +0200
> Signed-off-by: Rami Rosen <[EMAIL PROTECTED]>
This was added long ago by some bonding driver infrastructure changes
so that code could check whether the arp_create() helper function
existed in the kernel.
But it is to
From: "chas williams - CONTRACTOR" <[EMAIL PROTECTED]>
Date: Sat, 29 Dec 2007 20:08:30 -0500
> [ATM]: [he] fixing compilation when you define USE_RBPS_POOL/USE_RBPL_POOL
>
> Signed-off-by: Jorge Boncompte <[EMAIL PROTECTED]>
> Signed-off-by: Chas Williams <[EMAIL PROTECTED]>
Appl
From: "chas williams - CONTRACTOR" <[EMAIL PROTECTED]>
Date: Sat, 29 Dec 2007 20:08:12 -0500
> [ATM]: [ambassador] kmalloc + memset conversion to kzalloc
>
> Signed-off-by: Joonwoo Park <[EMAIL PROTECTED]>
> Signed-off-by: Chas Williams <[EMAIL PROTECTED]>
Applied.
--
To unsubscr
From: "chas williams - CONTRACTOR" <[EMAIL PROTECTED]>
Date: Sat, 29 Dec 2007 20:07:49 -0500
> [ATM]: [br2864] whitespace cleanup
>
> Signed-off-by: Chas Williams <[EMAIL PROTECTED]>
Applied.
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a messag
From: "chas williams - CONTRACTOR" <[EMAIL PROTECTED]>
Date: Sat, 29 Dec 2007 20:07:24 -0500
> [ATM]: [br2864] routed support
>
> From: Eric Kinzie <[EMAIL PROTECTED]>
> Signed-off-by: Chas Williams <[EMAIL PROTECTED]>
Applied.
--
To unsubscribe from this list: send the line "uns
From: "chas williams - CONTRACTOR" <[EMAIL PROTECTED]>
Date: Sat, 29 Dec 2007 20:06:56 -0500
> [ATM]: [he] This patch removes the ancient version string.
>
> Signed-off-by: Adrian Bunk <[EMAIL PROTECTED]>
> Signed-off-by: Chas Williams <[EMAIL PROTECTED]>
Applied.
--
To unsubscri
From: "chas williams - CONTRACTOR" <[EMAIL PROTECTED]>
Date: Sat, 29 Dec 2007 20:06:24 -0500
> [ATM]: Convert struct class_device to struct device
>
> Signed-off-by: Kay Sievers <[EMAIL PROTECTED]>
> Cc: Tony Jones <[EMAIL PROTECTED]>
> Signed-off-by: Greg Kroah-Hartman <[EMAI
From: "chas williams - CONTRACTOR" <[EMAIL PROTECTED]>
Date: Sat, 29 Dec 2007 20:06:03 -0500
> [ATM]: atm is no longer experimental
>
> From: Robert P. J. Day <[EMAIL PROTECTED]>
> Signed-off-by: Chas Williams <[EMAIL PROTECTED]>
Applied.
--
To unsubscribe from this list: send th
subscribe linux-wireless
--
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at http://vger.kernel.org/majordomo-info.html
Hello.
This is a repost of a patch submitted at http://lkml.org/lkml/2007/11/19/545 .
Current status is that I'm waiting for Samir Bellabes's answer
whether we can handle the following example without this patch.
Tetsuo Handa wrote:
> Hello.
>
> Samir Bellabes wrote:
> > >> what differences bet
On Sun, Dec 30, 2007 at 03:34:45PM -0500, Alan Stern wrote:
> On Sun, 30 Dec 2007, Ingo Molnar wrote:
>
> > * Andreas Mohr <[EMAIL PROTECTED]> wrote:
> >
> > > (yes, that's all there is, despite CONFIG_USB_DEBUG being set)
> > >
> > > The LED of a usb stick isn't active either, for obvious reaso
From: Herbert Xu <[EMAIL PROTECTED]>
Date: Mon, 31 Dec 2007 15:23:55 +1100
> [IPSEC]: Move all calls to xfrm_audit_state_icvfail to xfrm_input
>
> Let's nip the code duplication in the bud :)
>
> Signed-off-by: Herbert Xu <[EMAIL PROTECTED]>
Applied.
--
To unsubscribe from this list: se
From: Herbert Xu <[EMAIL PROTECTED]>
Date: Sun, 30 Dec 2007 23:36:04 +1100
> [IPSEC]: Fix double free on skb on async output
>
> When the output transform returns EINPROGRESS due to async operation we'll
> free the skb the straight away as if it were an error. This patch fixes
> that so that the
From: Herbert Xu <[EMAIL PROTECTED]>
Date: Mon, 31 Dec 2007 11:31:18 +1100
> [IPSEC]: Fix transport-mode async resume on intput without netfilter
>
> When netfilter is off the transport-mode async resumption doesn't work
> because we don't push back the IP header. This patch fixes that by
> movi
From: Jarek Poplawski <[EMAIL PROTECTED]>
Date: Sun, 30 Dec 2007 15:13:23 +0100
> On Sat, Dec 29, 2007 at 07:14:43PM -0800, David Miller wrote:
> ...
> "again" loop should skip this entry next time: s->ax25_dev should
> be NULL, so not equal to ax25dev. (But of course there could be
> this unknown
Since I knew there would be some TCP conflicts etc.
I worked last night and today on a rebase, and I just
pushed that out at the usual location:
kernel.org:/pub/scm/linux/kernel/git/davem/net-2.6.25.git
Don't worry about respinning patches, I'll take care of things.
--
To unsubscribe fro
Hi Dave:
While refreshing the async IPsec patches I noticed some fresh code
duplication.
[IPSEC]: Move all calls to xfrm_audit_state_icvfail to xfrm_input
Let's nip the code duplication in the bud :)
Signed-off-by: Herbert Xu <[EMAIL PROTECTED]>
diff --git a/net/ipv4/ah4.c b/net/ipv4/a
Hi Dave:
Found another bug on the input path when NETFILTER is off.
[IPSEC]: Fix transport-mode async resume on intput without netfilter
When netfilter is off the transport-mode async resumption doesn't work
because we don't push back the IP header. This patch fixes that by
moving most of the c
Hi Kim,
On Fri, Aug 17, 2007 at 11:34:37AM -0700, K Naru wrote:
> From: Kim Naru ([EMAIL PROTECTED])
>
> Added support to offload TCP/UDP/IP checksum to the
> VIA Technologies VT6105M chip.
> Firstly, let the stack know this chip is capable of
> doing its own checksum(IPV4 only).
> Secondly offlo
On Dec 30, 2007 10:24 PM, J. Bruce Fields <[EMAIL PROTECTED]> wrote:
>
> On Fri, Dec 28, 2007 at 03:07:46PM -0800, Andrew Morton wrote:
> > On Fri, 28 Dec 2007 23:53:49 +0100 "Torsten Kaiser" <[EMAIL PROTECTED]>
> > wrote:
> >
> > > On Dec 23, 2007 5:27 PM, Torsten Kaiser <[EMAIL PROTECTED]> wrote
On Fri, Dec 28, 2007 at 03:07:46PM -0800, Andrew Morton wrote:
> On Fri, 28 Dec 2007 23:53:49 +0100 "Torsten Kaiser" <[EMAIL PROTECTED]> wrote:
>
> > On Dec 23, 2007 5:27 PM, Torsten Kaiser <[EMAIL PROTECTED]> wrote:
> > > On Dec 23, 2007 8:30 AM, Andrew Morton <[EMAIL PROTECTED]> wrote:
> > > >
>
On Sun, 30 Dec 2007, Ingo Molnar wrote:
> * Andreas Mohr <[EMAIL PROTECTED]> wrote:
>
> > (yes, that's all there is, despite CONFIG_USB_DEBUG being set)
> >
> > The LED of a usb stick isn't active either, for obvious reasons.
> >
> > And keep in mind that this is a (relatively old) OHCI-only ma
Quoting Marcin Juszkiewicz <[EMAIL PROTECTED]>:
+ PCMCIA_DEVICE_PROD_ID1233(
+ "The Linksys Group, Inc.", "Wireless Network CF
Card", "ISL37300P",
+ 0xa5f472c2, 0x9c05598d, 0xc9049a39),
Acked-by: Pavel Roskin <[EMAIL PROTECTED]>
--
Regards,
Pavel Roskin
-
* Andreas Mohr <[EMAIL PROTECTED]> wrote:
> (yes, that's all there is, despite CONFIG_USB_DEBUG being set)
>
> The LED of a usb stick isn't active either, for obvious reasons.
>
> And keep in mind that this is a (relatively old) OHCI-only machine...
> (which had the 2.6.19 lsmod showing ohci-h
On Sun, Dec 30, 2007 at 05:12:05PM +0200, Andy Johnson wrote:
> Can there be a case in such environment (using IPv4 only) where
> hh_cache of a neighbour instance is a
> list with more than one entry ?
In theory if some device supplies own multiple dst_ops with different
protocol numbers. From a
Hello,
First, thanks for your reply.
Second, apart from when using both IPV4 and IPV6:
Suppose I work only in IPv4 (and this is indeed the case).
Can there be a case in such environment (using IPv4 only) where
hh_cache of a neighbour instance is a
list with more than one entry ?
Regards,
Andy Jo
Dnia sobota, 29 grudnia 2007, Pavel Roskin napisał:
> Hello!
>
> On Fri, 2007-12-28 at 14:16 +0100, Marcin Juszkiewicz wrote:
> > + PCMCIA_DEVICE_PROD_ID1234(
> > + "The Linksys Group, Inc.", "Wireless Network CF
> > Card", "ISL37300P", + "RevA",
> > +
"Andy Johnson" <[EMAIL PROTECTED]> writes:
> Can anybody give an example when hh_cache of a neighbour instance is a
> list with more than
> one entry ?
When you're talking to the same host on a local ethernet with both native IPv4
and native IPv6.
-Andi
--
To unsubscribe from this list: send th
On Sat, Dec 29, 2007 at 07:14:43PM -0800, David Miller wrote:
...
> You can't just drop this linked list lock and expect it to stay
> consistent like that.
>
> Once you drop it, any thread of control can get in there and delete
> entries from the list.
>
> Since we know it can happen, using a WAR
Hi,
struct neighbour has a member named hh_cache; this
hh_cache caches link layer headers to speed up transmission
(instead filling them again and again for each packet).
The hh_cache struct is defined in linux/netdev.h.
Its first member is hh_next, which is a pointer to
hh_cache.
I tried to thin
Hi Dave:
Here's a fix for a silly bug on the async output path for IPsec.
[IPSEC]: Fix double free on skb on async output
When the output transform returns EINPROGRESS due to async operation we'll
free the skb the straight away as if it were an error. This patch fixes
that so that the skb is fr
On Sun, 30 Dec 2007, Ilpo Järvinen wrote:
> I guess the non-minimum TSO delays are only significant in case there was
> something unexpectional happening and in such case we definately want to
> have some measurements taken.
Broadly speaking, delay-based schemes need as much information about t
Hi,
On Sat, 29 Dec 2007, David Miller wrote:
> Never mind about making the relative patch, I didn't want to have
> to wait for you to send me that and have it block my merge of
> fixes with Linus this evening.
Ah, sorry for the inconvenience. I didn't realise you had merged it yet.
> The follo
On Sun, 30 Dec 2007, Gavin McCullagh wrote:
> Hi,
>
> On Fri, 21 Dec 2007, Ilpo Järvinen wrote:
>
> > > I need to re-read properly, but I think the same problem affects the
> > > microsecond values where TCP_CONG_RTT_STAMP is set (used by vegas, veno,
> > > yeah, illinois). I might follow up wi
Hideo AOKI a écrit :
This patch adds UDP memory usage accounting in IPv4. Currently,
receiving buffer accounting is only supported.
This patch is also introduced memory_allocated variable for UDP protocol.
OK, but sockstat_seq_show() should be updated so that this
udp_memory_allocated value c
This patch adds UDP memory usage accounting in IPv6. Currently,
receiving buffer accounting is only supported.
This patch is also introduced memory_allocated variable for UDP protocol.
Cc: Satoshi Oshima <[EMAIL PROTECTED]>
Cc: Masami Hiramatsu <[EMAIL PROTECTED]>
signed-off-by: Takahiro Yasui <[
This patch adds UDP memory usage accounting in IPv4. Currently,
receiving buffer accounting is only supported.
This patch is also introduced memory_allocated variable for UDP protocol.
Cc: Satoshi Oshima <[EMAIL PROTECTED]>
Cc: Masami Hiramatsu <[EMAIL PROTECTED]>
signed-off-by: Takahiro Yasui <[
This patch adds sysctl parameters for customizing UDP memory accounting:
/proc/sys/net/ipv4/udp_mem
/proc/sys/net/ipv4/udp_rmem_min
/proc/sys/net/ipv4/udp_wmem_min
Udp_mem indicates number of pages which can be used for all UDP scokets.
Each UDP packet is dropped, when the number of
This patch replaces present memory accounting calls with new interface
in TCP.
Cc: Satoshi Oshima <[EMAIL PROTECTED]>
Cc: Masami Hiramatsu <[EMAIL PROTECTED]>
signed-off-by: Takahiro Yasui <[EMAIL PROTECTED]>
signed-off-by: Hideo Aoki <[EMAIL PROTECTED]>
---
include/net/tcp.h |4 ++--
ne
Hello,
This is the latest patch set of UDP memory accounting and limitation.
I split my patch set into accounting interface consolidation and UDP
memory accounting support. This patch set implements UDP memory
accounting support.
To use consolidated accounting functions, I matched format of udp_
To consolidate memory accounting functions, this patch adds memory
accounting calls to network core functions. Moreover, present
memory accounting call is renamed to new accounting call.
Cc: Satoshi Oshima <[EMAIL PROTECTED]>
Cc: Masami Hiramatsu <[EMAIL PROTECTED]>
signed-off-by: Takahiro Yasui <
This patch introduces new memory accounting functions for each network
protocol. Most of them are renamed from memory accounting functions
for stream protocols. At the same time, some stream memory accounting
functions are removed since other functions do same thing.
Renaming:
sk_stream_fr
This patch replaces present memory accounting calls with new interface
in SCTP.
Cc: Satoshi Oshima <[EMAIL PROTECTED]>
Cc: Masami Hiramatsu <[EMAIL PROTECTED]>
signed-off-by: Takahiro Yasui <[EMAIL PROTECTED]>
signed-off-by: Hideo Aoki <[EMAIL PROTECTED]>
---
include/net/sctp/sctp.h |3 +--
Hello,
This patch set introduces new memory accounting interface.
Current interface is written for stream protocols only.
To enable memory accounting in other protocols (e.g. UDP),
I enhanced the interface and updated TCP and SCTP memory
accounting.
The patch set consists of the following 4 patch
48 matches
Mail list logo