[Lldb-commits] [PATCH] D45298: [debugserver] Fix LC_BUILD_VERSION load command handling.

2018-04-05 Thread Pavel Labath via Phabricator via lldb-commits
labath added a comment. I thing the changes are fine. The only part that worries me is the in-class initialization of the simulator variables. I think this will fail on non-apple hosts. Comment at: packages/Python/lldbsuite/test/tools/lldb-server/TestAppleSimulatorOSType.py:

[Lldb-commits] [lldb] r329296 - Remove unused NativeProcessProtocol.h include from Platform.h

2018-04-05 Thread Pavel Labath via lldb-commits
Author: labath Date: Thu Apr 5 08:17:51 2018 New Revision: 329296 URL: http://llvm.org/viewvc/llvm-project?rev=329296&view=rev Log: Remove unused NativeProcessProtocol.h include from Platform.h After removing it, I got a couple of compile errors because we were missing some symbols (SIGKILL and

[Lldb-commits] [lldb] r329295 - Fix error in QEnableErrorStrings gdb-remote docs

2018-04-05 Thread Pavel Labath via lldb-commits
Author: labath Date: Thu Apr 5 08:17:43 2018 New Revision: 329295 URL: http://llvm.org/viewvc/llvm-project?rev=329295&view=rev Log: Fix error in QEnableErrorStrings gdb-remote docs this probably happened because we changed the name of the packet mid-review. Modified: lldb/trunk/docs/lldb-gd

[Lldb-commits] [PATCH] D45298: [debugserver] Fix LC_BUILD_VERSION load command handling.

2018-04-05 Thread Frederic Riss via Phabricator via lldb-commits
friss added inline comments. Comment at: packages/Python/lldbsuite/test/tools/lldb-server/TestAppleSimulatorOSType.py:16-18 +sim_devices_str = subprocess.check_output(['xcrun', 'simctl', 'list', '-j', + 'devices']) +sim_devic

[Lldb-commits] [PATCH] D45170: Cleanup DWARFCompileUnit and DWARFUnit in preparation for adding DWARFTypeUnit

2018-04-05 Thread Adrian Prantl via Phabricator via lldb-commits
aprantl accepted this revision. aprantl added a comment. This revision is now accepted and ready to land. That's great! Let's go for it then. Could you please doxygen'ify the comments? https://reviews.llvm.org/D45170 ___ lldb-commits mailing list ll

[Lldb-commits] [lldb] r329305 - Cleanup DWARFCompileUnit and DWARFUnit in preparation for adding DWARFTypeUnit

2018-04-05 Thread Greg Clayton via lldb-commits
Author: gclayton Date: Thu Apr 5 08:52:39 2018 New Revision: 329305 URL: http://llvm.org/viewvc/llvm-project?rev=329305&view=rev Log: Cleanup DWARFCompileUnit and DWARFUnit in preparation for adding DWARFTypeUnit Many things that were in DWARFCompileUnit actually need to be in DWARFUnit. This p

[Lldb-commits] [PATCH] D45170: Cleanup DWARFCompileUnit and DWARFUnit in preparation for adding DWARFTypeUnit

2018-04-05 Thread Phabricator via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL329305: Cleanup DWARFCompileUnit and DWARFUnit in preparation for adding DWARFTypeUnit (authored by gclayton, committed by ). Herald added a subscriber: llvm-commits. Changed prior to commit: https://re

Re: [Lldb-commits] [lldb] r329305 - Cleanup DWARFCompileUnit and DWARFUnit in preparation for adding DWARFTypeUnit

2018-04-05 Thread Davide Italiano via lldb-commits
On Thu, Apr 5, 2018 at 8:52 AM, Greg Clayton via lldb-commits wrote: > Author: gclayton > Date: Thu Apr 5 08:52:39 2018 > New Revision: 329305 > > URL: http://llvm.org/viewvc/llvm-project?rev=329305&view=rev > Log: > Cleanup DWARFCompileUnit and DWARFUnit in preparation for adding DWARFTypeUnit >

[Lldb-commits] [lldb] r329309 - Fix windows build after r329296

2018-04-05 Thread Pavel Labath via lldb-commits
Author: labath Date: Thu Apr 5 09:23:54 2018 New Revision: 329309 URL: http://llvm.org/viewvc/llvm-project?rev=329309&view=rev Log: Fix windows build after r329296 Add a couple of #include s. Modified: lldb/trunk/source/Plugins/Process/gdb-remote/GDBRemoteCommunicationServerPlatform.cpp

[Lldb-commits] [lldb] r329314 - One more windows build fix

2018-04-05 Thread Pavel Labath via lldb-commits
Author: labath Date: Thu Apr 5 09:59:36 2018 New Revision: 329314 URL: http://llvm.org/viewvc/llvm-project?rev=329314&view=rev Log: One more windows build fix Modified: lldb/trunk/source/Target/Platform.cpp Modified: lldb/trunk/source/Target/Platform.cpp URL: http://llvm.org/viewvc/llvm-pr

[Lldb-commits] [PATCH] D45332: [LIT] Add new LLDB test format

2018-04-05 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere created this revision. JDevlieghere added reviewers: zturner, labath, davide, aprantl. Herald added a subscriber: delcypher. JDevlieghere added a comment. As discussed in https://reviews.llvm.org/D45215 This adds a new test format to lit which will be used for LLDB. (If it's possib

[Lldb-commits] [PATCH] D45332: [LIT] Add new LLDB test format

2018-04-05 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added a comment. As discussed in https://reviews.llvm.org/D45215 Repository: rL LLVM https://reviews.llvm.org/D45332 ___ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commit

[Lldb-commits] [PATCH] D45333: WIP: [LIT] Have lit run the lldb test suite

2018-04-05 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere created this revision. JDevlieghere added reviewers: zturner, labath, davide, aprantl. Herald added subscribers: llvm-commits, mgorny. This is the initial attempt (v1) to run the lldb test suite with lit, using the custom LLDB test format. Here every`Test*.py` is seen as a single tes

[Lldb-commits] [PATCH] D45332: [LIT] Add new LLDB test format

2018-04-05 Thread Zachary Turner via Phabricator via lldb-commits
zturner added a comment. It should be possible to define it outside the LLVM repo. Just in `llvm/lldb/lit/lit.cfg` replace this line: config.test_format = lit.formats.ShTest(execute_external) with something like this: import lldb_format config.test_format = lldb_format.LLDBTestFormat()

[Lldb-commits] [PATCH] D45333: WIP: [LIT] Have lit run the lldb test suite

2018-04-05 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added a comment. This isn't meant to be checked-in as is, however I'm looking for feedback as early as possible. There are currently two problems with the current diff: - `./bin/llvm-lit ../llvm/tools/lldb/lit/Suite/` doesn't work, and I haven't figured out why yet. - We'd run the

[Lldb-commits] [PATCH] D45215: RFC/WIP: Have lit run the lldb test suite

2018-04-05 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added a comment. Please see https://reviews.llvm.org/D45332 for the lldb test format and https://reviews.llvm.org/D45333 for how to use that to run the tests. https://reviews.llvm.org/D45215 ___ lldb-commits mailing list lldb-commits@l

[Lldb-commits] [PATCH] D45332: [LIT] Add new LLDB test format

2018-04-05 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added a comment. In https://reviews.llvm.org/D45332#1058914, @zturner wrote: > It should be possible to define it outside the LLVM repo. Just in > `llvm/lldb/lit/lit.cfg` replace this line: > > config.test_format = lit.formats.ShTest(execute_external) > > > with something like th

[Lldb-commits] [PATCH] D45332: [LIT] Add new LLDB test format

2018-04-05 Thread Zachary Turner via Phabricator via lldb-commits
zturner added a comment. I don't think `sys.path` is set up correctly to be able to find the lldbtest package from the `lldb/lit` folder. These things kind of evolved separately, and the `lldb/lit` folder was created as a place to start iterating on LLVM-style lit / FileCheck tests. These kind

[Lldb-commits] [PATCH] D45332: [LIT] Add new LLDB test format

2018-04-05 Thread Jonas Devlieghere via Phabricator via lldb-commits
JDevlieghere added a comment. In https://reviews.llvm.org/D45332#1058970, @zturner wrote: > I don't think `sys.path` is set up correctly to be able to find the lldbtest > package from the `lldb/lit` folder. > > These things kind of evolved separately, and the `lldb/lit` folder was > created as

[Lldb-commits] [lldb] r329358 - [dotest] --skip-category should append and not override.

2018-04-05 Thread Davide Italiano via lldb-commits
Author: davide Date: Thu Apr 5 15:46:39 2018 New Revision: 329358 URL: http://llvm.org/viewvc/llvm-project?rev=329358&view=rev Log: [dotest] --skip-category should append and not override. Modified: lldb/trunk/packages/Python/lldbsuite/test/dotest.py Modified: lldb/trunk/packages/Python/l

[Lldb-commits] [PATCH] D45298: [debugserver] Fix LC_BUILD_VERSION load command handling.

2018-04-05 Thread Jason Molenda via Phabricator via lldb-commits
jasonmolenda accepted this revision. jasonmolenda added a comment. This revision is now accepted and ready to land. Looks good to me. Comment at: packages/Python/lldbsuite/test/decorators.py:359 +output = subprocess.check_output(["xcodebuild", "-showsdks"], stderr=

[Lldb-commits] [PATCH] D45348: Don't return error for settings set .experimental. settings that are absent

2018-04-05 Thread Jason Molenda via Phabricator via lldb-commits
jasonmolenda created this revision. jasonmolenda added a reviewer: jingham. jasonmolenda added a project: LLDB. Herald added a subscriber: llvm-commits. setting paths that include .experimental. are intended for settings that may be promoted to "real" settings in the future, or may be removed. W

[Lldb-commits] [PATCH] D45298: [debugserver] Fix LC_BUILD_VERSION load command handling.

2018-04-05 Thread Frederic Riss via Phabricator via lldb-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL329374: [debugserver] Fix LC_BUILD_VERSION load command handling. (authored by friss, committed by ). Herald added a subscriber: llvm-commits. Changed prior to commit: https://reviews.llvm.org/D45298?vs

[Lldb-commits] [lldb] r329374 - [debugserver] Fix LC_BUILD_VERSION load command handling.

2018-04-05 Thread Frederic Riss via lldb-commits
Author: friss Date: Thu Apr 5 21:28:12 2018 New Revision: 329374 URL: http://llvm.org/viewvc/llvm-project?rev=329374&view=rev Log: [debugserver] Fix LC_BUILD_VERSION load command handling. Summary: In one of the 2 places the LC_BUILD_VERSION load command is handled, there is a bug preventing us