Re: + arc-convert-to-dma_map_ops.patch added to -mm tree

2015-12-16 Thread Andrew Morton
On Thu, 17 Dec 2015 10:58:55 +0530 Vineet Gupta wrote: > On Tuesday 24 November 2015 01:20 PM, h...@lst.de wrote: > > Hi Vineet, > > > > the original version went through the buildbot, which succeeded. It seems > > like the official buildbot does not support arc, and might benefit from > > hel

Re: [patch V4] lib: GCD: Use binary GCD algorithm instead of Euclidean

2016-05-06 Thread Andrew Morton
On Fri, 6 May 2016 17:42:42 +0800 zengzhao...@163.com wrote: > From: Zhaoxiu Zeng > > The binary GCD algorithm is based on the following facts: > 1. If a and b are all evens, then gcd(a,b) = 2 * gcd(a/2, b/2) > 2. If a is even and b is odd, then gcd(a,b) = gcd(a/2, b) > 3. If

Re: [PATCH v2] arch: define weak abort

2017-12-19 Thread Andrew Morton
#endif > > + > > +__weak void abort(void) > > +{ > > + BUG(); > > + > > + /* if that doesn't kill us, halt */ > > + panic("Oops failed to kill thread"); > > +} > > Hmm, I realize there's a small gotcha with this, when testing with a

Re: [PATCH] bug.h: Work around GCC PR82365 in BUG()

2018-02-07 Thread Andrew Morton
arvik Cc: Jesper Nilsson Cc: Tony Luck Cc: Fenghua Yu Cc: Geert Uytterhoeven Cc: "David S. Miller" Cc: Christopher Li Cc: Thomas Gleixner Cc: Peter Zijlstra Cc: Kees Cook Cc: Ingo Molnar Cc: Josh Poimboeuf Cc: Will Deacon Cc: "Steven Rostedt (VMware)" Cc: Mark

Re: [PATCH] fix double ;;s in code

2018-02-20 Thread Andrew Morton
On Tue, 20 Feb 2018 10:03:56 +0200 Jani Nikula wrote: > On Mon, 19 Feb 2018, Pavel Machek wrote: > > On Mon 2018-02-19 16:41:35, Daniel Vetter wrote: > >> Yeah, pls split this into one patch per area, with a suitable patch > >> subject prefix. Look at git log of each file to get a feeling for w

Re: [RFC PATCH v2 1/2] Randomization of address chosen by mmap.

2018-03-22 Thread Andrew Morton
On Thu, 22 Mar 2018 19:36:37 +0300 Ilya Smith wrote: > include/linux/mm.h | 16 -- > mm/mmap.c | 164 > + You'll be wanting to update the documentation. Documentation/sysctl/kernel.txt and Documentation/admin-guide/kernel-parame

Re: [RFC PATCH v2 2/2] Architecture defined limit on memory region random shift.

2018-03-22 Thread Andrew Morton
Please add changelogs. An explanation of what a "limit on memory region random shift" is would be nice ;) Why does it exist, why are we doing this, etc. Surely there's something to be said - at present this is just a lump of random code? ___ linux-

Re: [RFC PATCH v2 0/2] Randomization of address chosen by mmap.

2018-03-22 Thread Andrew Morton
On Thu, 22 Mar 2018 19:36:36 +0300 Ilya Smith wrote: > Current implementation doesn't randomize address returned by mmap. > All the entropy ends with choosing mmap_base_addr at the process > creation. After that mmap build very predictable layout of address > space. It allows to bypass ASLR in ma

Re: [PATCH] mm: Generalize and rename notify_page_fault() as kprobe_page_fault()

2019-06-13 Thread Andrew Morton
On Thu, 13 Jun 2019 15:37:24 +0530 Anshuman Khandual wrote: > Architectures which support kprobes have very similar boilerplate around > calling kprobe_fault_handler(). Use a helper function in kprobes.h to unify > them, based on the x86 code. > > This changes the behaviour for other architectu

Re: [PATCH V13] mm/debug: Add tests validating architecture page table helpers

2020-02-09 Thread Andrew Morton
On Thu, 6 Feb 2020 13:49:35 +0530 Anshuman Khandual wrote: > > On 02/06/2020 04:40 AM, kbuild test robot wrote: > > Hi Anshuman, > > > > Thank you for the patch! Yet something to improve: > > > > [auto build test ERROR on powerpc/next] > > [also build test ERROR on s390/features linus/master

Re: [PATCH V14] mm/debug: Add tests validating architecture page table helpers

2020-02-26 Thread Andrew Morton
tely respin if that will be > preferred. I didn't see this fix? I assume it's this? If so, are we sure it's OK to be added to -next without testing?? From: Andrew Morton Subject: mm-debug-add-tests-validating-architecture-page-table-helpers-fix A warning gets exposed wi

Re: [PATCH 0/2] mm/thp: Rename pmd_mknotpresent() as pmd_mknotvalid()

2020-03-30 Thread Andrew Morton
On Sun, 29 Mar 2020 19:12:35 +0530 Anshuman Khandual wrote: > > > On 03/20/2020 10:24 AM, Anshuman Khandual wrote: > > This series renames pmd_mknotpresent() as pmd_mknotvalid(). Before that it > > drops an existing pmd_mknotpresent() definition from powerpc platform which > > was never requir

Re: [PATCH V3 13/15] parisc/kmap: Remove duplicate kmap code

2020-05-07 Thread Andrew Morton
On Thu, 7 May 2020 08:00:01 -0700 ira.we...@intel.com wrote: > parisc reimplements the kmap calls except to flush it's dcache. This is > arguably an abuse of kmap but regardless it is messy and confusing. > > Remove the duplicate code and have parisc define > ARCH_HAS_FLUSH_ON_KUNMAP for a kunm

Re: [PATCH V3 15/15] kmap: Consolidate kmap_prot definitions

2020-05-07 Thread Andrew Morton
ase report them to the maintainer, see CHECKPATCH in MAINTAINERS. Please run checkpatch prior to sending patches Cc: Ira Weiny Signed-off-by: Andrew Morton --- arch/sparc/include/asm/highmem.h |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) --- a/arch/sparc/include/asm/highm

Re: [PATCH v2 00/12] mm: consolidate definitions of page table accessors

2020-05-15 Thread Andrew Morton
On Thu, 14 May 2020 20:03:15 +0300 Mike Rapoport wrote: > The low level page table accessors (pXY_index(), pXY_offset()) are > duplicated across all architectures and sometimes more than once. For > instance, we have 31 definition of pgd_offset() for 25 supported > architectures. > > Most of the

Re: [PATCH] arch/{mips,sparc,microblaze,powerpc}: Don't enable pagefault/preempt twice

2020-06-03 Thread Andrew Morton
On Thu, 21 May 2020 10:42:50 -0700 Ira Weiny wrote: > > > > > > Actually it occurs to me that the patch consolidating kmap_prot is odd for > > > sparc 32 bit... > > > > > > Its a long shot but could you try reverting this patch? > > > > > > 4ea7d2419e3f kmap: consolidate kmap_prot definitions

Re: [RFC] proc: get_wchan() stack unwind only makes sense for sleeping/non-self tasks

2020-11-06 Thread Andrew Morton
On Thu, 5 Nov 2020 15:11:32 -0800 Vineet Gupta wrote: > Most architectures currently check this in their get_wchan() implementation > (ARC doesn't hence this patch). However doing this in core code shows > the semantics better so move the check one level up (eventually remove > the boiler-plate

Re: [PATCH v3 8/9] mm: replace CONFIG_NEED_MULTIPLE_NODES with CONFIG_NUMA

2021-06-08 Thread Andrew Morton
On Tue, 8 Jun 2021 12:13:15 +0300 Mike Rapoport wrote: > From: Mike Rapoport > > After removal of DISCINTIGMEM the NEED_MULTIPLE_NODES and NUMA > configuration options are equivalent. > > Drop CONFIG_NEED_MULTIPLE_NODES and use CONFIG_NUMA instead. > > Done with > > $ sed -i 's/CONFIG

Re: [PATCH V7 00/26] mm/mmap: Drop __SXXX/__PXXX macros from across platforms

2022-07-11 Thread Andrew Morton
On Mon, 11 Jul 2022 12:35:34 +0530 Anshuman Khandual wrote: > This series drops __SXXX/__PXXX macros from across platforms in the tree. I've updated mm-unstable to this version, thanks. I skipped the added-to-mm emails to avoid wearing out people's inboxes. Reissuing a 26-patch series N times

Re: [PATCH] profile: setup_profiling_timer() is moslty not implemented

2022-07-25 Thread Andrew Morton
On Thu, 21 Jul 2022 20:55:09 +0100 Ben Dooks wrote: > The setup_profiling_timer() is mostly un-implemented by many > architectures. In many places it isn't guarded by CONFIG_PROFILE > which is needed for it to be used. Make it a weak symbol in > kernel/profile.c and remove the 'return -EINVAL' im

Re: [PATCH 00/19] Introduce __xchg, non-atomic xchg

2022-12-22 Thread Andrew Morton
On Thu, 22 Dec 2022 12:46:16 +0100 Andrzej Hajda wrote: > Hi all, > > I hope there will be place for such tiny helper in kernel. > Quick cocci analyze shows there is probably few thousands places > where it could be useful. So to clarify, the intent here is a simple readability cleanup for exi

Re: [PATCH] bit_spinlock: Include

2023-01-09 Thread Andrew Morton
On Sun, 8 Jan 2023 20:04:44 +0100 Christophe JAILLET wrote: > In an attempt to simplify some includes in , it > appeared, when compiling fs/ecryptfs/dentry.c, that > was relying on other includes to get the definition of cpu_relax(). > (see [1]) > > It broke on arc. > > Include in to fix t

Re: [PATCH 3/3] mm, arch: add generic implementation of pfn_valid() for FLATMEM

2023-01-25 Thread Andrew Morton
On Wed, 25 Jan 2023 21:07:57 +0200 Mike Rapoport wrote: > Every architecture that supports FLATMEM memory model defines its own > version of pfn_valid() that essentially compares a pfn to max_mapnr. > > Use mips/powerpc version implemented as static inline as a generic > implementation of pfn_va

Re: [PATCH] ARC: mm: retire support for aliasing VIPT D$

2023-08-14 Thread Andrew Morton
On Sun, 13 Aug 2023 12:25:43 -0700 Vineet Gupta wrote: > Legacy ARC700 processors (first generation of MMU enabled ARC cores) has > VIPT cached which could be configured such that they could alias. > I added the VIPT aliasing support, with all the cache flush overhead to > support all but 1 silic

Re: [PATCH v5 7/8] execmem: add support for cache of large ROX pages

2024-10-09 Thread Andrew Morton
On Wed, 9 Oct 2024 21:08:15 +0300 Mike Rapoport wrote: > Using large pages to map text areas reduces iTLB pressure and improves > performance. Are there any measurable performance improvements? What are the effects of this series upon overall memory consumption? The lack of acks is a bit surp

Re: [PATCH v5 7/8] execmem: add support for cache of large ROX pages

2024-10-13 Thread Andrew Morton
On Sun, 13 Oct 2024 11:43:41 +0300 Mike Rapoport wrote: > > > The idea is to keep everything together and have execmem_info describe all > > > that architecture needs. > > > > But why? That's pretty different from our normal style of arch hooks, > > and introduces an indirect call in a securit

Re: [PATCH mm-unstable v2 00/16] mm: Introduce arch_mmap_hint()

2024-12-12 Thread Andrew Morton
On Thu, 12 Dec 2024 22:51:34 + Lorenzo Stoakes wrote: > You've fundamentally violated kernel process and etiquette. I'd be more > forgiving, but this is at v2 and you've not cc'd KEY people. Twice. This is > totally unacceptable. See [0] if you are unsure of how to do so. This feels excessi

Re: [PATCH mm-unstable v2 06/16] mm: csky: Introduce arch_mmap_hint()

2024-12-12 Thread Andrew Morton
On Thu, 12 Dec 2024 16:40:10 -0500 "Liam R. Howlett" wrote: > * Kalesh Singh [241211 18:28]: > > Introduce csky arch_mmap_hint() and define HAVE_ARCH_MMAP_HINT. > > This is a preparatory patch, no functional change is introduced. > > This also looks like it has changed the validation order and

Re: [PATCH 00/13] arch, mm: reduce code duplication in mem_init()

2025-03-07 Thread Andrew Morton
On Thu, 6 Mar 2025 20:51:10 +0200 Mike Rapoport wrote: > Every architecture has implementation of mem_init() function and some > even more than one. All these release free memory to the buddy > allocator, most of them set high_memory to the end of directly > addressable memory and many of them s