comment is kinda scary.
> I haven't changed the character length variables for the co-array
> intrinsics, as this is something that may need to be synchronized with
> OpenCoarrays.
Won’t that mean that coarray programs will fail due to ABI mismatch?
FX
ibitm, probably needs primarily a build
> maintainer or global reviewer.
The Fortran part is OK, but I can’t approve the libitm part.
FX
the libgfortran_set_options to remove unused fields?
3. What will happen to people who try to run older compiled codes with newer
library versions? Will it fail with an error message? Segfault? Do we have a
way to make it fail in a better way?
Cheers,
FX
ric user code.
Another issue is that we have some documented, user-callable functions that
currently live in the __gfortran_ “namespace”, e.g. the mixed-language routines
(https://gcc.gnu.org/onlinedocs/gfortran/Non-Fortran-Main-Program.html). We
want to avoid changing those for no reason, and so for consistency I think we
should keep everything under __gfortran_
FX
earlier on Windows
and was corrected, but behind a __MINWG32__ check, although the fixed code is
actually correct for all platforms.
I have thus committed the attached fix (revision 243796), removing the
target-specific branch. Will work on all platforms now.
FX
chmod.ChangeLog
Description
were kept only for
compatibility.
Bootstrapped and regtested on x86_64-apple-darwin16.3.0
OK to commit?
FX
iso_c_binding.ChangeLog
Description: Binary data
iso_c_binding.diff
Description: Binary data
PAUSE/STOP/ERROR STOP runtime functions.
Bootstrapped and regtested on x86_64-apple-darwin16.3.0.
OK to commit?
FX
stop.ChangeLog
Description: Binary data
stop.diff
Description: Binary data
we can now remove them.
Attached patch bootstrapped and regtested on x86_64-apple-darwin16.3.0.
OK to commit?
FX
transpose.ChangeLog
Description: Binary data
transpose.diff
Description: Binary data
s. Also the unused
> store_exe_path function is removed.
>
> Regtested on x86_64-pc-linux-gnu, Ok for trunk?
I’m okaying the patch as is. While we continue cleaning up the library (I have
submitted a number of patches now) we should discuss how we will arrange the
symbols in gfortran.map at the end.
FX
-darwin13.6.0.
OK to commit?
FX
bitint.ChangeLog
Description: Binary data
bitint.diff
Description: Binary data
> No, this was actually part of r243799 which I just committed (after you Ok'd
> it. :) )
Oops. Sorry!
> Thanks, committed as r243799.
I think something went wrong in your commit, as none of the “removed” files
were removed: https://gcc.gnu.org/viewvc/gcc?view=revision&revision=243799
FX
I’ll leave that as an improvement if there is agreement on
that side.
FX
For ABI compatibility, we kept some unused elements in the array argument to
_gfortran_set_options (options that we have removed). With the current ABI
breakage, we might as well remove those.
Bootstrapped and regtested on x86_64-apple-darwin16.3.0
OK to commit?
FX
set_options.ChangeLog
m calls a newer
library, the runtime will simply use default values for all options there were
not passed.
And when we remove options, we simply pass zero values in their stead — until
we break the ABI, when we clean up everything.
Patch committed, thanks for reviewing.
FX
the incompatibility in our release notes.
Cheers,
FX
on-Fortran main program section in the manual should be
> kept as is.
Then, if we keep some functions under _gfortran_, I say let’s keep them all
there. It’s not hurting, and the few users who care have come to expect it.
Cheers,
FX
map.ChangeLog
Description: Binary data
map.diff
Description: Binary data
=16) :: y
I’m guessing if that emits the correct code in both settings, the rest should
be fine.
--
FX
d if someone wants to add/fix
something they can commit as additional change.
Thanks,
FX
it is tricky to achieve, because identification of the target triplet
is not sufficient. We need to test some functions/macros too.
FX
eview of the simple libquadmath patch :(
Sorry,
FX
Attached patch fixes libgfortran’s FPU initialization by only performing it
when the user explicitly asked for it, with option -ffpe-trap.
Bootstrapped and regtested on x86_64-apple-darwin14.
OK to commit to trunk?
FX
fpu.ChangeLog
Description: Binary data
fpu.diff
Description: Binary data
Trivial patch below committed as rev. 226734 to bring the output of “gfortran
--version” in line with “gcc --version”.
FX
Index: ChangeLog
===
--- ChangeLog (revision 226733)
+++ ChangeLog (working copy)
@@ -1,3 +1,8 @@
+2015
> 2015-08-06 Uros Bizjak
>
>PR fortran/64022
>* gfortran.dg/ieee/large_4.f90: New test.
>
> Tested on x86_64-linux-gnu {,-m32} and alphaev68-linux-gnu.
> OK for mainline?
OK. Thanks for the patch!
FX
> for the IEEE modules on __float128, and requires logbq().
>
> Bootstrapped and regtested on x86_64-apple-darwin14.
> OK to commit to trunk?
>
> FX
logbq.diff
Description: Binary data
logbq.ChangeLog
Description: Binary data
>> In the apparent absence of the libquadmath maintainers, could a global
>> reviewer approve this rather simple patch, please?
>
> OK
Committed as rev. 226748. Thanks.
FX
Attached patch committed as rev. 226750, to restore build on mingw32.
We don’t use umask() around mkstemp() on mingw32 because it doesn’t support the
interesting permissions (“group” and “others”).
FX
mingw_umask.diff
Description: Binary data
mingw_umask.ChangeLog
Description: Binary data
that the shell could not be executed. The attached testcase
checks that.
Bootstrapped and regtested on x86_64-apple-darwin14.
OK to commit to trunk?
FX
PS: I’ve also taken the opportunity to rework a bit the runtime error message
issued when CMDSTAT is not present, to actually include the
3. In libgfortran, we remove our own code and substitute calls to libbacktrace
Bootstrapped and regtested on x86_64-pc-linux-gnu (which has full libbacktrace
support) and x86_64-apple-darwin14 (which has minimal libbacktrace support). OK
to commit to trunk?
FX
--
The fine print:
This is
@@
!$ACC ENTER DATA CREATE (I)
CALL ACC_CREATE (I)
+ PRINT *, "CheCKpOInT"
+ FLUSH OUTPUT_UNIT
END
I hope this helps,
FX
x86_64-apple-darwin14 (which has minimal libbacktrace support). OK to commit
>> to trunk?
>
> backtrace.ChangeLog is unreadable for me …
Sending again, this time with .txt extension, hoping this makes it go through
OK.
FX
2015-08-14 Francois-Xavier Coudert
PR libfort
as it should, and x86_64-apple-darwin14, where
SUPPORTS_WEAKREF gets defined to 0 as it should. Then regtested on both targets.
OK to commit to trunk?
FX
2015-08-14 Francois-Xavier Coudert
PR libfortran/47571
* acinclude.m4 (LIBGFOR_GTHREAD_WEAK): Remove
Committed attached patch as rev. 226923 to document the behavior of gfortran
when opening & closing symbolic links.
Clearing up some of the old libgfortran PRs...
FX
Index: ChangeLog
===
--- ChangeLog (revision 22
libquadmath function call signbitq().
Regtested on x86_64-apple-darwin14, covered by existing testcases in
gfortran.dg/ieee/.
FX
PS: I figured, since few gfortran maintainers appear to be around right now,
and I’m probably the one who knows that area best, I’d commit it directly
rather than
BUILT_IN_SQRT is a bit special in the Fortran front-end, because it’s part of
our math built-ins which map one-to-one to Fortran intrinsics (and get special
treatment for that), but it is only a built-in we call directly in the
front-end when emitting code for NORM2.
I didn’t realize this corne
expand inline).
Tested on x86_64-apple-darwin14, OK to commit?
FX
gcc/
2015-08-17 Francois-Xavier Coudert
PR middle-end/36757
* builtins.c (expand_builtin_signbit): Add asserts to make sure
we can expand BUILT_IN_SIGNBIT inline.
* builtins.def (BUILT_IN_SIGNBIT
n.
Committed to trunk, with that __builtin_printf removed, as revision 226990.
Thanks for the review.
FX
hether it’s worth doing, but yes, with the type-generic
__builtin_signbit you can revert that patch with no change to the generated
code.
FX
UWIN support was apparently removed from GCC in 2008. Yet some traces can still
be found in gcc/config.* files.
Attached patch would remove them. OK to commit?
FX
PS: gcc/config.host and gcc/config.build include some other such targets…
without checking them all, I think the following could
are not supported.)
FX
-*-vsta
- powerpc-*-beos*
All were deleted as targets in 2008, except for i386-*-vsta which was removed
in 2004.
OK to commit to trunk?
FX
config.ChangeLog
Description: Binary data
config.diff
Description: Binary data
> OK
Thanks. Committed, along with the additional patch for m68k-hp-hpux*, which I
had forgotten (but was deprecated in 2008 along with the others).
FX
Index: ChangeLog
===
--- ChangeLog (revision 227077)
+++ Change
2.95.2
- ftp.thewrittenword.com only offers gcc 4.0.2
Tested with "make pdf info html", OK to commit?
FX
binaries.ChangeLog
Description: Binary data
binaries.diff
Description: Binary data
10-day *ping* for my 3 Fortran patches:
- Handle invalid command line in EXECUTE_COMMAND_LINE
(https://gcc.gnu.org/ml/gcc-patches/2015-08/msg00758.html)
- Use libbacktrace in libgfortran
(https://gcc.gnu.org/ml/gcc-patches/2015-08/msg00762.html)
- Fix configure test for weakref support
(https:/
pinion).
In realize this is mostly taste an very subjective, so with this nugget of
extra input, I leave the final decision to you: let me know what you think
best, between readability and "conformance" to GDB format.
Cheers,
FX
if you prefer).
Nope, strncat() is C90: http://clc-wiki.net/wiki/strncat
Thus, safe to use, I think. I committed as submitted, as revision 227105.
Thanks for the review.
FX
function is now useless, but is retained due to ABI compatibility.
Remove when bumping the library ABI. */
;
}
> Please also add a note to the libgfortran ABI cleanup wiki page so we
> don't forget about it.
Done.
> With these changes, Ok for trunk. Thanks a lot for working on this!
Committed as revision 227106 with the changes above.
Thanks for reviewing the patch.
FX
ently not restrictive enough. Maybe we could use a
AC_EGREP_HEADER test, as is currently done for dl_interate_phdr()?
FX
> I guess we can always just hard-code that SPU does not have mmap, similar
> to how Solaris is hard-coded to not have dl_iterate_phdr.
>
> Would something like the below be OK (if it passes testing)?
Looks good to me, though I cannot approve it.
FX
are expanded inline, rather than requiring a
function call.
Bootstrapped and regtested on x86_64-apple-darwin15.
OK to commit to trunk?
FX
float.ChangeLog
Description: Binary data
float.diff
Description: Binary data
ouldn’t you first set the
-fPIC flag before try to compile with that?
FX
c/testsuite/ChangeLog entries
- reformated date and PR entries in ChangeLog
Thanks again,
FX
block.diff
Description: Binary data
east I had a look at config.log this time…)
That looks better :)
But I can’t approve the patch.
FX
implemented in gfortran. And show_variables() isn’t
very useful.
OK to commit to trunk?
FX
unusedcode.ChangeLog
Description: Binary data
unusedcode.diff
Description: Binary data
omeone wants to nuke the whole
section, fine with me :)
FX
though it’s in libgfortran
configury, you should decide and commit what’s best. I don’t think we have any
newlib expert in the Fortran maintainers.
Wait for 48 hours to see if anyone else objects, though.
Cheers,
FX
Turns out I missed some of the dead code. And I now also fixed comments and
some formatting.
libgfortran/runtime/environ.c is now much more readable than before.
The patch is still a no-op, in terms of user functionality.
OK to commit to trunk?
FX
unusedcode.ChangeLog
Description: Binary
h a way to figure out how to test that in the testuite,
though.)
FX
sign.ChangeLog
Description: Binary data
sign.diff
Description: Binary data
t; t show_sep
> t show_string
> T _gfortrani_show_locus
Nope, none of those functions are actually publicly exported. They are not in
gfortran.map, being either static, or having _gfortrani_ prefix which means
internal libgfortran use.
FX
> OK. Just checking. Thanks for the code cleanup.
Thanks for the review. Committed as rev. 227208.
FX
descriptor is accessed. But it’s cleaner that way.
Committed as revision 227210, after bootstrapping and regtesting on
x86_64-apple-darwin15.
FX
shape.ChangeLog
Description: Binary data
shape.diff
Description: Binary data
= 1
f(x) = x
x = 2
print *, f(x)
end
touille /tmp $ cat b.f90
integer :: f
integer :: x = 1
f(x) = x
x = 2
print *, f(x)
end
touille /tmp $ gfortran a.f90 && ./a.out
0
touille /tmp $ gfortran b.f90 && ./a.out
2
FX
> This patch was committed without regenerating gcc/configure.
Thanks for spotting that. Committed regenerated gcc/configure as revision
227266.
FX
ping**2
Given that it’s a configury-patch, I think what it needs is real exposure on
unusual targets more than formal review, so I intend to commit it in 48 hours
unless someone objects in the meantime. Then I’ll be around to fix things if
some fall apart…
FX
> Le 14 août 2015 à 17:06,
regtesting on x86_64-apple-darwin15.
I have updated the wiki ABI cleanup page.
FX
z.diff
Description: Binary data
Hi Jerry,
The patch is OK, but I’m a bit puzzled about what the testcase does.
It tests that we can OPEN a directory, but not READ from it? I didn’t know that
was expected (to be able to OPEN a directory), and I find it somewhat puzzling.
Can you shed light on that?
Thanks,
FX
, shorter and more unified.
Committed as revision 227316, after regtesting on x86_64-pc-linux-gnu.
FX
x.ChangeLog
Description: Binary data
x.diff
Description: Binary data
Committed the two attached patches doing some minor cleanup in libgfortran:
- removed unused “min” macro in io/unix.c
- remove some unused configure checks (functions we check for but don’t use
the result)
Regtested on x86_64-apple-darwin15, then committed separately.
FX
z1.diff
. 227336 after bootstrap and regtesting on
x86_64-apple-darwin15.
FX
free.ChangeLog
Description: Binary data
free.diff
Description: Binary data
tached patch to fix it: we retain the old macros for gthr.h’s
sake, and use the new one internally. Testsuite clean so far on x86_64-linux.
FX
z.diff
Description: Binary data
And: very sorry about the breakage.
FX
mmap", errno);
mmapio.c: error_callback (data, "mmap", errno);
mmapio.c:error_callback (data, "munmap", errno);
posix.c: error_callback (data, "close", errno);
read.c: error_callback (data, "lseek", errno);
read.c: error_callback (data, "read", errno);
FX
> Hmm, in that case errnum must be set to 0. What about the attached
> patch, which prints the existing message if errnum == 0, and the new
> and improved only for errnum > 0?
OK. Thanks for the patch.
FX
The attached patch, committed as rev. 227502 after regtesting on
x86_64-apple-darwin15, removes an unused simplify function for MVBITS.
FX
z.diff
Description: Binary data
se.
>(internal_error): Likewise.
>(generate_error): Likewise.
>(notify_std): Likewise.
>* runtime/stop.c (error_stop_string): Likewise.
>(error_stop_numeric): Likewise.
OK, except that the PR number is wrong in the ChangeLog).
(Related: I’ve just closed PR 63930 as WONTFIX.)
Thanks for the patch!
FX
r nothing, but libbacktrace is compiled and its headers
provided in all cases.
Can you please give us something to investigate? Like, the error message you’re
seeing.
FX
time understanding how the non-constant filename can give an
overflow error. Or maybe the error is wrong, and it’s O_RDONLY | O_BINARY |
O_CLOEXEC that have crazy values?
This looks like a valid POSIX construct to me.
FX
> #define _FCLOEXEC 0x0010L
> #define O_CLOEXEC _FCLOEXEC /* sets FD_CLOEXEC on open */
That’s weird, and definitely an AIX bug:
http://pubs.opengroup.org/onlinepubs/9699919799/functions/open.html
How does that even work? open() takes int as second arg.
FX
libbacktrace patch, you need Ian to approve it, it’s his area.
FX
ea in the first place.
FX
ld you document the module/submodule behavior in the user doc?
Thanks,
FX
> 2015-09-09 Steven G. Kargl
>
> PR fortran/67526
> * gfortran.dg/pr67526.f90: New test.
>
> 2015-09-09 Steven G. Kargl
>
> PR fortran/67526
> * expr.c (gfc_check_init_expr): Do not dereference a NULL pointer.
OK.
Thanks for the patch!
> 2015-08-10 Paul Thomas
>
>PR fortran/66993
>* module.c (read_module): If a symtree exists and the symbol has
>been associated in a submodule from a parent (sub)module, attach
>the symbol to a 'unique symtree' and the new symbol to the
>existing symtree.
>
> 2015-08-10 Pa
undefined behavior, I
committed the attached patch to trunk to fix them.
Regtested on x86_64-apple-darwin15.
Issues are latent, so I don’t think a backport is in order.
Cheers,
FX
lib.diff
Description: Binary data
ntation
supports handling of the corresponding exception”. It evens says:
> Each constant is defined if and only if the FPU you are compiling for
> supports that exception, so you can test for FPU support with ‘#ifdef’.
So it seems rather clear that compile-time tests are the recommended way to go.
FX
ption state correctly.
Well, if we have no choice, then let’s do it. (With an updated patch)
FX
pu_trap): Use feenableexcept.
OK to commit.
FX
better
> workaround.
Can you XFAIL the test on your platform, open a PR and assign it to me?
This is a corner of the Fortran standard that is not entirely clear, and there
have been some corrigenda on the topic, so I need to review it.
Thanks,
FX
The attached patch removes some remaining mentions of cloog and ppl in our docs.
Tested with “make info html pdf”. OK for trunk?
FX
PS: with this, the remaining mentions of cloog or ppl are comments in
config/isl.m4, graphite.c and graphite-blocking.c. They should probably go away
too, but
is in the
> toplevel configure.ac, where we already pass down the respective -L options.
> Indeed, the attached patch restores bootstrap on x86_64-apple-darwin14 with
> gcc as system compiler (and doesn’t break the bootstrap with clang as system
> compiler).
>
> OK to commi
> While in my testing, 64-bit Mac OS X 10.10.1 (x86_64-apple-darwin14.0.0)
> now bootstraps, but 32-bit (i386-apple-darwin14.0.0) does not:
Is it due to my patch, or pre-existing bootstrap failure?
How do you configure this 32-bit compiler? target/build/host/CFLAGS/CXXFLAGS/etc
FX
config/mh-darwin says that -mdynamic-no-pic is there because it “speeds
compiles by 3-5%”. I don’t think we care about speed when the bootstrap fails,
so can we remove it altogether?
FX
darwin.diff
Description: Binary data
> Can you try adding it as
>
> T_CFLAGS += -mdynamic-no-pic
>
> in gcc/config/t-tarwin instead?
Nope, doing so fails to link libgcc_s.dylib:
/Users/fx/devel/gcc/i/./gcc/xgcc -B/Users/fx/devel/gcc/i/./gcc/
-B/Users/fx/devel/gcc/i2/i386-apple-darwin14.0.0/bin/
-B/Users/fx/de
OK. But if we rename the function, why not simply terminal_width() ?
FX
> Le 6 déc. 2014 à 23:14, Tobias Burnus a écrit :
>
> This patch fixes a Fortran diagnostic "regression".
>
> With the current common diagnostic, the width shown with caret diagnostic is
>
ovides it) keeps
synchronized to the terminal width anyway (as is the case for bash and zsh).
FX
OK, I think, from the Fortran POV.
I hope I didn't miss some logic issue in the middle of the trivial stuff.
Thanks for doing that work!
FX
Le 12 déc. 2014 à 08:43, Tobias Burnus a écrit :
> This patch cleans up Fortran's option handling and moves it closer to the
> comm
> PING - https://gcc.gnu.org/ml/gcc-patches/2014-12/msg00731.html
OK.
> Good point, thank you. Updated patch attached.
> I guess I still new formal approval by someone with reviewer status …
OK
> Built and currently regtested on x86-64-gnu-linux.
> OK for the trunk?
OK.
I’m not sure exactly why we have a hardcoded minimal value of (2^16-1) for “max
array constructor”, or a default max stack of 2^15. But that’s a separate issue.
Thanks,
FX
This patch below allows ubsan to run when libstdc++ is built but not installed
(something which happens on darwin, in particular). This fixes all 658 ubsan
failures when run in this particular configuration.
OK to commit?
FX
2014-12-20 Francois-Xavier Coudert
* lib/ubsan-dg.exp
201 - 300 of 633 matches
Mail list logo