on 2019/9/12 下午4:14, Richard Biener wrote:
> On Wed, 11 Sep 2019, Kewen.Lin wrote:
>
>> Hi,
>>
>> Sorry for the late update. I've updated the words of target hooks part.
>>
>> Could someone help to review it? Thanks in advance!
>>
>> By the way, as previous emails in this thread, Bin has approve
Hi all,
exactly the same as for plugin-hsa on the trunk:
https://gcc.gnu.org/ml/gcc-patches/2019-09/msg00718.html
Only a different file (which is only in this branch).
Tobias
commit 392044a8db285d9aea0a280983ce7c5014a4e99c
Author: Tobias Burnus
Date: Thu Sep 12 18:07:53 2019 +0200
l
Hello world,
the attached patch improves the rather hard to read error
messages for argument mismatches. With this patch, this reads
argument_checking_21.f90:7:11:
6 | call foo(1.0) ! { dg-warning "Rank mismatch" }
| 2
7 | call foo(b) ! { dg-warning "Rank mismatch
This seems to be the way the rest of ira-color.c does it.
I hope it's OK. It does fix the segfault.
2019-09-10 Maya Rashish
PR target/85401
* ira-color.c: (allocno_copy_cost_saving) Call
ira_init_register_move_cost_if_necessary
diff --git a/gcc/ira-color.c b/gcc/ira-
On Sat, Sep 14, 2019 at 02:27:15PM +0200, Thomas Koenig wrote:
>
> the attached patch improves the rather hard to read error
> messages for argument mismatches. With this patch, this reads
>
> argument_checking_21.f90:7:11:
>
> 6 | call foo(1.0) ! { dg-warning "Rank mismatch" }
>
> It is somewhat hard to write a testcase to show role of range info only with
> this patch. If another patch "Generalized predicate/condition for parameter
> reference in IPA (PR ipa/91088)" is accepted, it will become easy and I will
> update this testcase to show that.
>
> And this new version
> +/* Analyze EXPR if it represents a series of simple operations performed on
> + a function parameter and return true if so. FBI, STMT, EXPR, INDEX_P and
> + AGGPOS have the same meaning like in unmodified_parm_or_parm_agg_item.
> + Type of the parameter or load from an aggregate via the p
I found another instance of PR testsuite/83889 in the g++ testsuite.
I've committed the attached patch to fix it in the same way as all the
others.
-Sandra
2019-09-14 Sandra Loosemore
PR testsuite/83889
gcc/testsuite/
* g++.dg/vect/pr87914.cc: Remove explicit dg-do run.
Index: gcc/tests
On 9/5/19 10:35 AM, Wilco Dijkstra wrote:
> Agreed. I've got a couple of general comments:
>
> * The option name -matomic-ool sounds too abbreviated. I think eg.
> -moutline-atomics is more descriptive and user friendlier.
Changed.
> * Similarly the exported __aa64_have_atomics variable could be
On Wed, 11 Sep 2019 at 11:50, Wilco Dijkstra wrote:
>
> While code hoisting generally improves codesize, it can affect performance
> negatively. Benchmarking shows it doesn't help SPEC and negatively affects
> embedded benchmarks, so only enable code hoisting with -Os on Arm.
>
> Bootstrap OK, OK
10 matches
Mail list logo