gcc/ChangeLog:
2016-08-16 Martin Liska
* builtins.c (fold_builtin_memchr): Support following
transformations:
memchr (x, y, 0) -> NULL
memchr ("known_string", 'n', 5) -> &"known_string" + 1
memchr ("known_string", 'n', 1) -> NULL
---
gcc/builtins.c | 20
gcc/ChangeLog:
2016-08-16 Martin Liska
* builtins.c (fold_builtin_strncmp): Rename to
fold_builtin_strncmp_strncasecmp and support also
strncasecmp.
(fold_builtin_3): Handle BUILT_IN_STRNCASECMP.
---
gcc/builtins.c | 19 +--
1 file changed, 13 i
On Tue, Aug 16, 2016 at 03:10:13PM +0200, marxin wrote:
> 2016-08-16 Martin Liska
>
> * builtins.c (fold_builtin_strncmp): Rename to
> fold_builtin_strncmp_strncasecmp and support also
> strncasecmp.
> (fold_builtin_3): Handle BUILT_IN_STRNCASECMP.
> ---
> -/* Fold funct
2016-08-16 21:26 GMT+03:00 Nathan Sidwell :
> On 08/16/16 13:04, Jan-Benedict Glaw wrote:
>
>> That'll probably work. But after all, I'm not an AVR maintainer (not
>> even an user), but just running the Build Robot.
>
>
> Does your robot approve? :)
>
I'm an AVR maintainer.
The patch does not have
On 08/17/2016 09:20 AM, Denis Chertykov wrote:
> 2016-08-16 21:26 GMT+03:00 Nathan Sidwell :
>> On 08/16/16 13:04, Jan-Benedict Glaw wrote:
>>
>>> That'll probably work. But after all, I'm not an AVR maintainer (not
>>> even an user), but just running the Build Robot.
>>
>>
>> Does your robot appro
On 08/17/2016 09:10 AM, Jakub Jelinek wrote:
> Did you really mean to use this block for strncasecmp only (rather than for
> strncmp only, i.e. !is_strncasecmp)?
Sure, that was a typo. Unfortunately I had a test case with strings that was
eaten by fold_const_call. I enhanced test coverage for that
v2.
Martin
>From 42ea652d00fec821514d34b2af81f2a9e11b248c Mon Sep 17 00:00:00 2001
From: marxin
Date: Tue, 16 Aug 2016 15:56:01 +0200
Subject: [PATCH 3/3] Test folding of strn{case}cmp and memchr
gcc/testsuite/ChangeLog:
2016-08-16 Martin Liska
* gcc.dg/tree-ssa/builtins-folding.c: New tes
On Tue, 16 Aug 2016, Jakub Jelinek wrote:
> Hi!
>
> The FRE devirtualization unlike gimple-fold or other places would transform
> some method call with TREE_ADDRESSABLE lhs into __builtin_unreachable call
> with the same lhs, which is invalid (__builtin_unreachable returns void).
> Also, gimple_c
On Tue, 2016-08-16 14:26:38 -0400, Nathan Sidwell wrote:
> On 08/16/16 13:04, Jan-Benedict Glaw wrote:
>
> > That'll probably work. But after all, I'm not an AVR maintainer
> > (not even an user), but just running the Build Robot.
>
> Does your robot approve? :)
Ohoooh! See there! :)
http://to
../../gcc/input.c:1470:1: error: 'const char*
get_source_range_for_char(cpp_reader*, string_concat_db*, location_t,
cpp_ttype, int, source_range*)' defined but not used [-Werror=unused-function]
get_source_range_for_char (cpp_reader *pfile,
^
Andreas.
--
Andreas Schwa
On Mon, 15 Aug 2016, Richard Biener wrote:
>
> This adds a verifier that makes sure no overlapping life-ranges occur
> for virtuals.
>
> Bootstrap and regtest running on x86_64-unknown-linux-gnu.
The following is what I ended up applying. It fixes fallout found
in the vectorizer, general SSA i
On Tue, Aug 16, 2016 at 6:06 PM, Jeff Law wrote:
> On 08/16/2016 08:01 AM, Tamar Christina wrote:
>>
>>
>> Hi All,
>>
>> This patch turns off the usage of section anchors for
>> declarations that do not fit in a single anchor range.
>> A large enough object will use the full anchor range
>> and al
On Tue, Aug 16, 2016 at 7:54 PM, Martin Sebor wrote:
> On 08/16/2016 10:47 AM, Jeff Law wrote:
>>
>> On 08/16/2016 10:44 AM, Jakub Jelinek wrote:
>>>
>>> On Tue, Aug 16, 2016 at 10:27:58AM -0600, Jeff Law wrote:
I think you're being rather short-sighed here. GCC is being used in
wa
On Tue, Aug 16, 2016 at 3:14 PM, marxin wrote:
> gcc/ChangeLog:
>
> 2016-08-16 Martin Liska
>
> * builtins.c (fold_builtin_memchr): Support following
> transformations:
> memchr (x, y, 0) -> NULL
> memchr ("known_string", 'n', 5) -> &"known_string" + 1
>
On Wed, Aug 17, 2016 at 10:03:28AM +0200, Richard Biener wrote:
> On Tue, 16 Aug 2016, Jakub Jelinek wrote:
>
> > Hi!
> >
> > The FRE devirtualization unlike gimple-fold or other places would transform
> > some method call with TREE_ADDRESSABLE lhs into __builtin_unreachable call
> > with the sam
On Wed, 17 Aug 2016, Jakub Jelinek wrote:
> On Wed, Aug 17, 2016 at 10:03:28AM +0200, Richard Biener wrote:
> > On Tue, 16 Aug 2016, Jakub Jelinek wrote:
> >
> > > Hi!
> > >
> > > The FRE devirtualization unlike gimple-fold or other places would
> > > transform
> > > some method call with TREE_
Ping?
Best regards,
Thomas
On 10/08/16 14:28, Thomas Preudhomme wrote:
Hi,
Mappings (MULTILIB_MATCHES and MULTILIB_REUSE) in ARM aprofile multilib suffer
from a number of issues:
* missing mapping of -mcpu=cortex-a7 to -march=armv7-a
* typo on vfpv3-d16-fp16 (MULTILIB_MATCHES uses vfpv3-fp16
Ping?
Best regards,
Thomas
On 10/08/16 14:51, Thomas Preudhomme wrote:
Hi,
Currently, the Makefile fragment for ARM aprofile multilib is using a
substractive approach. It specifies a set of options to be combined (eg.
-march=armv7-a,armv7ve,armv8-a, with
-mfpu=vfpv3-d16,neon,vfpv4-d16,neon-fp
Ping?
Best regards,
Thomas
On 10/08/16 15:07, Thomas Preudhomme wrote:
Hi,
It was discovered while working on ARM's aprofile multilib Makefile fragment
that some REUSE rules were mentioning on the RHS options not in
MULTILIB_OPTIONS. This is not supposed to happen and leads to unexpected
beha
On 17/08/16 09:23, Richard Biener wrote:
> On Tue, Aug 16, 2016 at 6:06 PM, Jeff Law wrote:
>> On 08/16/2016 08:01 AM, Tamar Christina wrote:
>>>
>>>
>>> Hi All,
>>>
>>> This patch turns off the usage of section anchors for
>>> declarations that do not fit in a single anchor range.
>>> A large eno
Ping?
Best regards,
Thomas
On 11/08/16 11:31, Thomas Preudhomme wrote:
Hi Sandra,
Thanks for your feedback. Please find an updated version attached to this email.
ChangeLog entry is unchanged:
*** gcc/ChangeLog ***
2016-08-02 Thomas Preud'homme
* doc/fragments.texi (MULTILIB_EXC
On 16/08/2016 10:01, "Alan Hayward" wrote:
>
>
>On 16/08/2016 09:33, "Richard Biener" wrote:
>
>>On Mon, Aug 15, 2016 at 4:16 PM, Alan Hayward
>>wrote:
>>>
>>>
>>> On 15/08/2016 12:17, "Richard Biener"
>>>wrote:
>>>
On Mon, Aug 15, 2016 at 11:48 AM, Alan Hayward
wrote:
> The tes
../configure --target=msp430-elf --enable-languages=c,c++ && make -j4
Results in the msp430 -mlarge multilib failing to build with...
> configure: error: Unknown underlying type for size_t
> make[1]: *** [configure-target-libstdc++-v3] Error 1
This relates to...
> commit 13143e139230dc4d72710a
Greetings,
This patch extends the GNU Fortran front-end to add support for
DEC-style AUTOMATIC and STATIC symbol attributes with a new flag
-fdec-static, allowing explicit control of variable storage. AUTOMATIC
local variables are placed on the stack, whereas STATIC variables are
placed in static
On 17/08/16 12:19 +0100, Joe Seymour wrote:
Disabling the original changes for targets with unsupported pointer
sizes seems
like a reasonable solution to me, but I can't see an existing
mechanism to do
so? Do others agree?
Yes, the intention was that the transaction-safe exceptions would only
The ISL version we download from download_prerequesites on the GCC 6
branch (0.15) has a trailing comma at the end of an enumerator list.
This causes GCC 4.3.4 to error as we are compiling with -pedantic
(GCC 4.4 and up just warn). The following fixes this bootstrap issue
by patching the ISL sou
On Mon, 15 Aug 2016, Richard Biener wrote:
>
> The following fixes PR76490 which happens because how VRP expects
> +INF vs. +INF(OVF) to behave wrt comparisons. I fixed all
> operand_equal_p cases that matter.
>
> Bootstrapped on x86_64-unknown-linux-gnu, testing in progress.
The following is
On 17/08/2016 12:30, Jonathan Wakely wrote:
> On 17/08/16 12:19 +0100, Joe Seymour wrote:
>> Disabling the original changes for targets with unsupported pointer sizes
>> seems
>> like a reasonable solution to me, but I can't see an existing mechanism to do
>> so? Do others agree?
>
> Yes, the int
https://gcc.gnu.org/ml/fortran/2016-08/msg00077.html
Minor correction to the previously submitted patch:
On Wed, Aug 17, 2016 at 7:20 AM, Fritz Reese wrote:
> ...
> Note that AUTOMATIC does NOT override -fno-automatic; with the flag, a
> warning is produced for variables marked AUTOMATIC.
> ...
On 2016/8/15 5:57 PM, Jakub Jelinek wrote:
> On Mon, Aug 15, 2016 at 05:52:29PM +0800, Chung-Lin Tang wrote:
>> Hi Jakub,
>> This patch fixes an OpenACC reduction lowering segfault which
>> triggers when nested acc loop directives are present.
>> Cesar has reviewed this patch internally (since he m
Alan Modra wrote:
> PR rtl-optimization/72771
> * reload.c (find_reloads): Don't assume that a subreg mem is OK
> when find_reloads_toplev returns address_reloaded==-1.
> (alternative_allows_const_pool_ref): Update comment.
> testsuite/
> * gcc.c-torture/compile/pr727
On 08/17/2016 02:27 AM, Richard Biener wrote:
On Tue, Aug 16, 2016 at 7:54 PM, Martin Sebor wrote:
On 08/16/2016 10:47 AM, Jeff Law wrote:
On 08/16/2016 10:44 AM, Jakub Jelinek wrote:
On Tue, Aug 16, 2016 at 10:27:58AM -0600, Jeff Law wrote:
I think you're being rather short-sighed here.
On 16/08/16 16:15 +0300, Ville Voutilainen wrote:
On 16 August 2016 at 15:58, Jonathan Wakely wrote:
This patch constrains the new overloads using:
template
using _If_sv = enable_if_t<
__and_,
__not_>>::value,
_Res>;
so that anything convertible to const _CharT* goe
On Wed, Aug 17, 2016 at 4:27 AM, kugan
wrote:
> Hi,
>
>
> On 16/08/16 20:58, Richard Biener wrote:
>>
>> On Tue, Aug 16, 2016 at 9:39 AM, kugan
>> wrote:
>>>
>>> Hi,
>>>
as said the refactoring that would be appreciated is to split out the
update_value_range calls
from the worker f
On Wed, Aug 17, 2016 at 4:50 AM, kugan
wrote:
> Hi Richard,
>
>
> On 17/08/16 08:20, kugan wrote:
>>
>> Hi,
>>
>> On 16/08/16 21:56, Richard Biener wrote:
>>>
>>> On Tue, Aug 16, 2016 at 10:09 AM, kugan
>>> wrote:
On 23/07/16 20:12, kugan wrote:
>
>
> Hi Richa
On Wed, Aug 17, 2016 at 12:52 PM, Alan Hayward wrote:
>
>
> On 16/08/2016 10:01, "Alan Hayward" wrote:
>
>>
>>
>>On 16/08/2016 09:33, "Richard Biener" wrote:
>>
>>>On Mon, Aug 15, 2016 at 4:16 PM, Alan Hayward
>>>wrote:
On 15/08/2016 12:17, "Richard Biener"
wrote:
>
These patches fix some failures seen when running tests with different
-std options.
Adjust testcase for C++14 compatibility
* testsuite/24_iterators/headers/iterator/range_access.cc: Adjust
expected signatures for C++14 compatibility.
Tested powerpc64le-linux, committed to t
On Wed, 2016-08-17 at 10:12 +0200, Andreas Schwab wrote:
> ../../gcc/input.c:1470:1: error: 'const char*
> get_source_range_for_char(cpp_reader*, string_concat_db*, location_t,
> cpp_ttype, int, source_range*)' defined but not used [-Werror=unused
> -function]
> get_source_range_for_char (cpp_read
Adding TR1 and LFTS components to namespace std makes some tests fail
due to ambiguous names. This resolves those problems so the tests pass
using C++17.
Adjust testcases for C++17 compatibility
* testsuite/26_numerics/headers/cmath/types_std_c++0x_neg.cc: Disable
test for C++
Another patch tweaking directives, and replacing -std with an
effective target.
Adjust DG directives in libstdc++ Profile Mode test
* testsuite/ext/profile/all.cc: Use effective target instead of
-std=gnu++11. Use dg-additional-options instead of repeating options.
Tested pow
Some tweaks to dejagnu directives.
* testsuite/20_util/bind/ref_neg.cc: Use effective target instead of
-std=gnu++11. Add -fno-show-columns to dg-options. Use dg-prune-output
instead of dg-excess-errors.
Tested powerpc64le-linux, committed to trunk.
commit 964ab6e50270e
This test got a second dg-options directive in the middle of the
licence text somehow.
* testsuite/21_strings/basic_string_view/operations/rfind/char/2.cc:
Remove duplicate dg-options directive.
Tested x86_64-linux, committed to trunk.
commit 50786265d0950ac2cc2d21bcc960bcd17d68
On Tue, Aug 16, 2016 at 09:21:57PM +0200, Uros Bizjak wrote:
> The idea is indeed good, but please leave full names in the *.def
> file. We can change them later, if need arises.
Ok, here it is.
i386-builtin.def is basically moved the bdesc_* definitions, except that
{ ... },
is replaced with
BD
Hi!
I've noticed a couple of places that should be using
gimple_call_noreturn_p but are using gimple_call_flags (stmt) & ECF_NORETURN
instead.
Bootstrapped/regtested on x86_64-linux and i686-linux, ok for trunk?
2016-08-17 Jakub Jelinek
* gimple-fold.c (gimple_fold_call): Use gimple_
On Wed, 17 Aug 2016, Jakub Jelinek wrote:
> Hi!
>
> I've noticed a couple of places that should be using
> gimple_call_noreturn_p but are using gimple_call_flags (stmt) & ECF_NORETURN
> instead.
>
> Bootstrapped/regtested on x86_64-linux and i686-linux, ok for trunk?
Ok.
Richard.
> 2016-08-17
On Fri, Jul 22, 2016 at 09:59:33PM +, Joseph Myers wrote:
> Index: gcc/testsuite/gcc.dg/torture/fp-int-convert-float16-timode.c
> ===
> --- gcc/testsuite/gcc.dg/torture/fp-int-convert-float16-timode.c
> (nonexistent)
> +++ gc
I tried changing this test to use { dg-do compile { target c++14 } }
and it started to FAIL, because the complex_literals operators are
only used for -std=c++14 mode. With -std=gnu++14 we get the GNU
extension described at https://gcc.gnu.org/onlinedocs/gcc/Complex.html
* testsuite/26_num
On Wed, 17 Aug 2016, James Greenhalgh wrote:
> The obvious fix would be this modification to fp-int-convert.h:
>
> - TEST_I_F_VAL (U, F, (U)~(((U)~(U)0) >> 1), 1); \
> + TEST_I_F_VAL (U, F, (U)~(((U)~(U)0) >> 1), P_OK1 (P, U));\
That's not logically correct, because this is a
Hi Bill,
On Wed, 3 Feb 2016, Bill Schmidt wrote:
> The following was applied to the website to record additional GCC 6
> changes for PowerPC. The changes passed XHTML verification.
Thanks for documenting all those changes so diligently!
Somehow I missed this originally, but ran into this now,
Larger MOVE_RATIO will always make code faster. 17 is the number with
smaller code sizes for Lakemont.
Tested on x86-64. OK for trunk?
H.J.
---
gcc/
PR target/72839
* config/i386/i386.c (lakemont_cost): Set MOVE_RATIO to 17.
gcc/testsuite/
PR target/72839
* g
Hi!
The bug here is that it dereferences expr->ts.u.cl if non-NULL
unconditionally, no matter what expr->ts.type is.
But, ts.u is an union, where ts.u.cl is only valid for BT_CHARACTER,
ts.u.derived for BT_DERIVED etc. ts.u.pad (an int rather than pointer)
for BT_HOLLERITH? and unused in others.
S
Le 17/08/2016 à 20:56, Jakub Jelinek a écrit :
Hi!
The bug here is that it dereferences expr->ts.u.cl if non-NULL
unconditionally, no matter what expr->ts.type is.
But, ts.u is an union, where ts.u.cl is only valid for BT_CHARACTER,
ts.u.derived for BT_DERIVED etc. ts.u.pad (an int rather than p
This prevents these tests from failing when run with -std=gnu++98
* testsuite/20_util/tuple/67844.cc: Require c++11 effective target.
* testsuite/20_util/tuple/cons/nested_tuple_construct.cc: Likewise.
* testsuite/27_io/rvalue_streams.cc: Likewise.
Tested x86_64-linux, co
This changes some tests that have multiple dg-options directives to
use { target c++11 }, so they only need the dg-options that sets extra
options for simulators.
(We could use dg-additional-options for the simulator targets, but I
haven't bothered as it doesn't make any practical difference for
This dg-do compile was being ignored due to a missing space, so we
were running a test that was meant to be compile-only. I've also taken
the opportunity to make it use an effective target of c++11.
* testsuite/20_util/reference_wrapper/invoke-2.cc: Fix invalid dg-do
directive and
builtin_memset_gen_str returns a register used for memset, which only
supports integer registers. But a target may use vector registers in
memmset. This patch adds a TARGET_GEN_MEMSET_VALUE hook to duplicate
QImode value to mode derived from STORE_MAX_PIECES, which can be used
with vector instruc
On Thu, 16 Jun 2016, Tom G. Christensen wrote:
> Latest results for 6.x
Thanks a bunch, Tom! (Somehow I must have missed this, unlike
the other one, and then I was essentially out for a month, sorry.)
Gerald
On Wed, 2016-08-17 at 09:51 -0400, David Malcolm wrote:
> On Wed, 2016-08-17 at 10:12 +0200, Andreas Schwab wrote:
> > ../../gcc/input.c:1470:1: error: 'const char*
> > get_source_range_for_char(cpp_reader*, string_concat_db*,
> > location_t,
> > cpp_ttype, int, source_range*)' defined but not used
In OpenACC, if an offloaded region is lexically nested inside an acc
data region, then those variables should technically be marked as
present. For the most part we can get away with a simpler analysis and
making those variables present_or_copy, as that is the default for array
variables. However,
On 08/17/2016 02:23 AM, Richard Biener wrote:
On Tue, Aug 16, 2016 at 6:06 PM, Jeff Law wrote:
On 08/16/2016 08:01 AM, Tamar Christina wrote:
Hi All,
This patch turns off the usage of section anchors for
declarations that do not fit in a single anchor range.
A large enough object will use t
On 08/17/2016 05:33 AM, Richard Biener wrote:
The ISL version we download from download_prerequesites on the GCC 6
branch (0.15) has a trailing comma at the end of an enumerator list.
This causes GCC 4.3.4 to error as we are compiling with -pedantic
(GCC 4.4 and up just warn). The following fix
On 08/16/2016 10:59 AM, Marek Polacek wrote:
On Thu, Aug 11, 2016 at 04:49:30PM +0200, Marek Polacek wrote:
A few more cases where I'm unsure whether the fall through is intended.
Jason, can you please look at the cp/ part?
Given Jason is on PTO this week, can I just commit the patch as-is, mo
On 08/12/2016 07:31 AM, Martin Liška wrote:
On 08/09/2016 09:03 PM, Andi Kleen wrote:
It could potentially make things a lot slower. I don't think it's a good
idea to do this by default.
-Andi
Ok, alternative can be a warning in the driver that would inform a user
that combining -pthread and
On 08/11/2016 04:31 AM, Thomas Preudhomme wrote:
diff --git a/gcc/doc/fragments.texi b/gcc/doc/fragments.texi
index
b6d8541c8ca820fa732363a05221e2cd4d1251c2..abf4e128671bb4751d21f24bb69625593d3c839e
100644
--- a/gcc/doc/fragments.texi
+++ b/gcc/doc/fragments.texi
@@ -117,12 +117,15 @@ specifie
On Wed, Aug 17, 2016 at 8:26 PM, H.J. Lu wrote:
> Larger MOVE_RATIO will always make code faster. 17 is the number with
> smaller code sizes for Lakemont.
>
> Tested on x86-64. OK for trunk?
OK, I assume that the patch is based on some benchmark.
Thanks,
Uros.
>
> H.J.
> ---
> gcc/
>
>
On Wed, Aug 17, 2016 at 10:11 PM, H.J. Lu wrote:
> builtin_memset_gen_str returns a register used for memset, which only
> supports integer registers. But a target may use vector registers in
> memmset. This patch adds a TARGET_GEN_MEMSET_VALUE hook to duplicate
> QImode value to mode derived fr
On Wed, Aug 17, 2016 at 4:17 PM, Jakub Jelinek wrote:
> On Tue, Aug 16, 2016 at 09:21:57PM +0200, Uros Bizjak wrote:
>> The idea is indeed good, but please leave full names in the *.def
>> file. We can change them later, if need arises.
>
> Ok, here it is.
> i386-builtin.def is basically moved the
67 matches
Mail list logo