> ctnode between the two loops isn't used, so I think it is cleaner to just
> use two
> for (comdat_type_node *ctnode = comdat_type_list; ctnode != NULL;
>ctnode = ctnode->next)
> loops instead of reusing the iterator variable.
Thanks. IMO it's more readable this way though and it's the
On Tue, Sep 07, 2021 at 02:06:29PM +0200, Eric Botcazou wrote:
> this is the recent LTO bootstrap failure with Ada enabled. The compiler now
> generates DW_OP_deref_type for a unit of the Ada front-end, which means that
> the offset of base types in the CU must be computed during early DWARF too