> ctnode between the two loops isn't used, so I think it is cleaner to just > use two > for (comdat_type_node *ctnode = comdat_type_list; ctnode != NULL; > ctnode = ctnode->next) > loops instead of reusing the iterator variable.
Thanks. IMO it's more readable this way though and it's the same idiom as in prune_unused_types and dwarf2out_finish so I'm leaving it as-is. -- Eric Botcazou